• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 207
  • Last Modified:

help with JRNL_WRAP_ERROR on a Win2000 SP4 DC


We have two win2000 SP4 domain controllers. One of them is in a JRNL_WRAP_ERROR. the error reports is pasted below. Everything I read about this explains what to do up to service pack 3. I can find nothing to tell me how to get out of this state when using service pack 4. Help would be much appreciated.

The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.
 Replica set name is    : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"
 Replica root path is   : "c:\winnt\sysvol\domain"
 Replica root volume is : "\\.\C:"
 A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found.  This can occur because of one of the following reasons.
 [1] Volume "\\.\C:" has been formatted.
 [2] The NTFS USN journal on volume "\\.\C:" has been deleted.
 [3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal.
 [4] File Replication Service was not running on this computer for a long time.
 [5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\C:".
 Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state.
 [1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service.
 [2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set.
WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again.
To change this registry parameter, run regedit.
Click on Start, Run and type regedit.
Click down the key path:
Double click on the value name
   "Enable Journal Wrap Automatic Restore"
and update the value.
If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above.
  • 4
  • 3
1 Solution
Michael PfisterCommented:
Did you do set "Enable Journal Wrap Automatic Restore" in registry to 1 as recommended and it didn't help?
Michael PfisterCommented:
harry_tuttleAuthor Commented:
When I read up about setting "Enable Journal Wrap Automatic Restore" in registry to 1 it had said not to do this after SP3 and we are on SP4. This is my dilema, I can't find any info on what to do for SP4.
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Michael PfisterCommented:
After re-reading the articel I would say, MS doesn't recommend to set this registry key permanently. But to fix your problem I'd set it to 1, after your replication has completed I'd set it back to what it was, i.e. remove the value.

Or you do a non-authoritive restore by using BurFlags, see http://support.microsoft.com/kb/840674/en-us

Hope it helps,

harry_tuttleAuthor Commented:
well i am going to try one of these and will let you know
harry_tuttleAuthor Commented:
Hi, not to be a pain but Microsoft says (quoted below) not to use the "Enable Journal Wrap Automatic Restore" option past SP4. Its a shame as this is the one that mentions Journal Wraps.

"Important Microsoft does not recommend that you use this registry setting, and it should not be used post-Windows 2000 SP3."

With the burflags option, The artical does not say what to do once you have completed the steps. ie, would I then remove any keys etc that were created?
Michael PfisterCommented:
Did it once and as far as I remember it removed them automatically
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now