Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 366
  • Last Modified:

Deleting Sub directories of Public Folders

Have Exchange server 2003, we created 2 sub directories in the public folder some time ago and now wish to delete them. We have tried all the usual methods as supplied here with out success. It is possible they were created under a different user name that now does not exist. Everytime we go to delete or change them in ESM we get error "C1030afi" . We believe this is to do with persmissions , so exactly where do we change the permissions , we have tried to do it in Outlook and the ESM but get the above error when we press 'properties'.


0
John Pike
Asked:
John Pike
  • 3
  • 3
1 Solution
 
SembeeCommented:
Public Folder permissions can be set either via Outlook, or ESM.
If you are using ESM (because you think you have been locked out), then right click on the folder and choose Properties. Click on the tab "Permissions" and the client permissions.

If you still can't get in, then force the parent permissions to propagate down.
Right click on the parent and choose All Tasks, Manage Settings. Select overwrite settings and then follow the wizard.

Simon.
0
 
John PikeConsultant SystemsAuthor Commented:
Sorry for long delay will try this evening and let you know.
0
 
John PikeConsultant SystemsAuthor Commented:
I have tried your suggestion , to no avail.
The parent of the directory in question is 'Public Folders' when you selt 'All Tasks' the only options that are avaiable
are View,New, Refresh,Export List, Help (The greyed out ones do not include Manage Settings either)
The Parent of that area id 'Public Store'
We are using Exchange Server 2003

Any other suggestions would be appreciated

0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
SembeeCommented:
You cannot do anything at the root of the public folder tree. Have you tried accessing the folders through ESM?
The only other thing I can suggest is to create a new test public folder at the same level, then compare the security settings of both folders to ensure that you have full NTFS permissions to the folder.

It should be impossible for someone with Exchange full administrator rights to be locked out of a public folder.

Simon.
0
 
John PikeConsultant SystemsAuthor Commented:
Ok this is now annoying.
I have changed permissions for the administrator back to default and you still cannot delete the
sub folders in public folder.
Now i believe when we set these little folders up we used another user, that we have since deleted.

If we cant delete them can we hide them

It wont let you do any thing even look at the properties is forbidden

I cannot get to Manage settings either. Its not there

Ther must be a simple way to delete them

Help........................
0
 
SembeeCommented:
Are you looking at the public folders through Outlook or through ESM?
As I posted earlier, it is impossible for someone to lock the administrator out of public folders. As you have access to ESM, you can do what you like with the folders.

You should be able to delete the folders through ESM. Failing that, look at the properties of the folder, choose the Replication tab and remove all servers from the list of replicas. The folders will then disappear through Exchange's own clean up process.

Simon.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now