?
Solved

PIX firewall

Posted on 2006-07-12
7
Medium Priority
?
413 Views
Last Modified: 2013-11-16
Hi,

I am stuck up with below pix config .not able to ping or browse the public which i have natted to inside zone ip. seems like both icmp and http requests are being recived at PIx end when checked up the access-list .Kindly look at the below configs and help me to resolve the issue. thanks


PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password DS1yhSk68ojtXT2A encrypted
passwd 93cuN9bZRhoPmf6Z encrypted
hostname ciscopix
domain-name sss
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit tcp any host 210.212.*..8 eq www
access-list outside_access_in permit icmp any host 210.212.*.8

pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 210.212.*.7 255.255.255.0
ip address inside 172.16.60.101 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm location 172.16.0.0 255.255.0.0 inside
pdm location 172.16.16.76 255.255.255.255 inside
pdm location 172.16.50.43 255.255.255.255 inside
pdm location 172.16.60.15 255.255.255.255 inside
pdm location 172.16.60.0 255.255.255.0 inside
pdm location 210.212.*.* 255.255.255.255 outside
pdm location 210.212.*.*  255.255.255.255 outside
pdm location 210.212.*.* 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
nat (inside) 0 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 210.212.*.*  172.16.16.76 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
rip inside passive version 1
rip inside default version 1
route outside 0.0.0.0 0.0.0.0 210.212.*.*  1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 172.16.60.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 210.212.*.*  255.255.255.255 outside
telnet 210.212.*.*  255.255.255.255 outside
telnet 172.16.60.15 255.255.255.255 inside
telnet 172.16.50.43 255.255.255.255 inside
telnet timeout 10
ssh 210.212.*.*  255.255.255.255 outside
ssh 210.212.*.*  255.255.255.255 outside
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username babu password qcNlihb8awfR9nvm encrypted privilege 2
username dileep password 5IdlDfF/QhqmnsGH encrypted privilege 15
ciscopix# sh run
: Saved

====================================================================
ciscopix# sh access-list
access-list cached ACL log flows: total 0, denied 0 (deny-flow-max 1024)
            alert-interval 300
access-list outside_access_in; 3 elements
access-list outside_access_in line 1 permit tcp any host 210.212.*.*  eq www (hitcnt=28)
access-list outside_access_in line 2 permit icmp any host 210.212.*.*  (hitcnt=91)


0
Comment
Question by:ssshibu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17090724
Do this;

no nat (inside) 0 0.0.0.0 0.0.0.0 0 0

nat (inside) 1 0.0.0.0 0.0.0.0
global (outside) 1 interface

Save the config and then try accessing internet from inside.

Cheers,
Rajesh
0
 

Author Comment

by:ssshibu
ID: 17090846
Hi,

Thanks

 i did the change as u suggested but still i am not able to ping from internet to my natted (public iP). i am able to reach the pIX outside ip.

Pl check



0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 300 total points
ID: 17090930
Do a clear xlate on the pix and then try to

telnet 210.212.*.8 80

Let me know what is that you see.

What is the default gateway set on the 172.16.16.76 machine? Does it point to PIX ?

The earlier comment I gave was for your internal clients to get outside.

Cheers,
Rajesh

0
Ransomware Attacks Keeping You Up at Night?

Will your organization be ransomware's next victim?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with our Ransomware Prevention Kit!

 

Author Comment

by:ssshibu
ID: 17091148
1.C:\Documents and Settings\admin>telnet 210.212.*.*  80
Connecting To 210.212.*.*...Could not open connection to the host, on port 80
: Connect failed

2. What is the default gateway set on the 172.16.16.76 machine? Does it point to PIX ? - this i need to check as i am sitting away from that office..will let u know

3. The earlier comment I gave was for your internal clients to get outside - cant we accomplish the outside connectivity with nat (inside) 0 0.0.0.0 0.0.0.0 command,  what does actually this command do ?
in this case  i dont want people to get outside from inside. but that 172.16.16.76 should get accessed from outside with 210.212.*.8

thanks for your quick reply
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17092049
For the testing purpose, just do;

icmp allow any any

Then first try to see if you can ping the outside ip address of PIX.

If yes, then try to ping that webserver address (Public ip)

2. You need to check to see if the default gateway is pointing to pix, otherwise the communication may be reaching the device but it may not be coming back, thus fails.

3. nat 0 command disables all the natting, so if you don't want your inside clients to get out even then do this

no nat (inside) 0 0.0.0.0 0.0.0.0

Cheers,
Rajesh
0
 

Author Comment

by:ssshibu
ID: 17113125
Rajeshji

Sorry for the late written reply

Exactly as u pointed out the default gateway was wrong . Thanks a lot...!!!

Pl clarrify below doubts

1.  Suppose at later stage if i want to allow a specific inside ip to go to internet how do i do the natting ? is it possible to allow a single ip alone?

2. 3. nat 0 command disables all the natting, so if you don't want your inside clients to get out even then do this

no nat (inside) 0 0.0.0.0 0.0.0.0 -  should i remove the Global command aslo along with this?  if i remove this can inside IPs ping outside IPs?

3. nat (inside) 0 0.0.0.0 0.0.0.0 - instead of this command can we put statement for individual network?

Thanks again







0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17113139
Glad you got it working.

1. Yes it is possible;

global (outside) 1 interface
nat (inside) 1 10.10.10.10 255.255.255.255

The above statements allow the client machine 10.10.10.10 to go out to internet using PAT of outside interface ip address of PIX.

2. Global and nat commands are required for inside to outside nat. (Basically nat command defines *what* to nat and global command defined *towhat* )

3. Same as question 1.

nat (inside) 1 10.10.10.0 255.255.255.0

The above statement will make sure that all the machines in the subnet 10.10.10.0 will be able to go out....

Cheers,
Rajesh
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Suggested Courses
Course of the Month12 days, 20 hours left to enroll

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question