• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 12624
  • Last Modified:

Remote Connection - CTRL-ALT-DEL

Hello,

I use remote connection a lot and sometimes my remote pc screen saver will come on. It requires a CTRL-ALT-DEL to logon again. However, since I am using remote connection I can't do that. Is there a hot-key or another key sequence I can send to simulate CTRL-ALT-DEL on the remote machine?

Thanks,
John
0
jhieb
Asked:
jhieb
1 Solution
 
zephyr_hex (Megan)DeveloperCommented:
how are you remoting?  with VNC, you can right-click on the top bar of the screen and select "send cntrl-alt-del"
0
 
LucFCommented:
Hi jhieb,

If you're using Terminal Services/Remote desktop, the equivalent of CTRL-ALT-DEL for the MS client is CTRL-ALT-END.

Greetings,

LucF
0
 
StillUnAwareCommented:
Simply do that:

Right click on Your desktop, select 'Properties', choose 'Screen Saver' tab and uncheck the checkbox 'On resume, password protect'.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
jhiebAuthor Commented:
I'm connecting using the default Terminal Services i.e. Remote Desktop Connection that comes with Windows XP and Windows 2003.

0
 
GeisrudSystems AdministratorCommented:
Most Remote software, as Zephyr_hex mentions, allows you to "send" and CTRL-ALT-DEL to the remote PC.  With PCAnywhere (what my company uses) it is an option on the left sidebar and under the tools drop down.
0
 
jhiebAuthor Commented:
Hi LucF

That might be the answer. I remote into my Server and then via my server I connect to various workstations. If I am connected to a w/s via the server and do a CTRL-ALT-END then my primary connection (the server) receives the ctrl-alt-del request. However, the next workstation doesn't. Does that make sense? It almost seems like the CTRL-ALT-END can only go one remote connection deep.

0
 
jhiebAuthor Commented:
StillUnAware,

I need the password left on the screen saver to prevent unauthorized access if the machine is left unsecured and unused.

0
 
LucFCommented:
Glad to help.

On your follow up question at http:#17094868, indeed, the CTRL-ALT-DEL request only goes to the first remote desktop connection. As far as I know there's no way around that.
There is however almost always an option to connect to a certain workstation directly, for example by using different portnumbers for RDP as explained at "How to change Terminal Server's listening port" => http://support.microsoft.com/?id=187623 
In short, just change the following key in the registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp  
Then, if you use a NAT router, you can forward these ports to the appropriate client and just connect to that specific computer using <WAN-IP>:<Portnumber> in the RDP client software when you're connecting.

LucF
0
 
jhiebAuthor Commented:
This is pretty slick. Thanks for the extra info!
0
 
LucFCommented:
You're welcome.

LucF
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now