• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4293
  • Last Modified:

Promise fasttrack 378 and XP

Hi - I have an ASUS p4c800- with the fasttrack 378 RAID.

I have 2 SATA 400gig seagates that I want to use as the array.

I can build the array using the utility.  everything is happy.

I have tested the harddrives everything is happy

I create a RAID 1, Mirror of the drives.

I pop in the XP disc and boot to it.  I choose F6 to add additional drivers.

Windows finds the array.

Windows formats the array (quick and regular)

WIndows installs.

Goes through copying all the files
reboot
installs windows.
reboot

CRASH

everytime.

It tells me that windows cant find the drives.

I've tried different drivers.

I've slipstreamed the raid driver into the windows CD so I dont have to press F6.

Nothing will let me boot to windows after the installation.

any ideas would be greatly apprieciated.

also the SATA drives are SATA 300.  the RAID is SATA 150.  The drives have a jumper that sets them to 150.  I tried that as well.  No go on all.

What baffles me is that winblows obviously sees the drives becasue it goes through the whole install before crapping out.

Now of course after 2 days dinking with it Im under a time crunch so any ideas would be great.

the mobo is good.  i can install windows on it using those drives without the raid....

and I can use the raid if windows is installed outside the RAID.

thanks
0
livegirllove
Asked:
livegirllove
1 Solution
 
Gary CaseRetiredCommented:
Do I correctly understand it is completely installing Windows (the "countdown screen" that takes about 30 min) and THEN crashing on the final reboot ??

Is the boot order in the BIOS set to boot from the RAID array?
0
 
Gary CaseRetiredCommented:
... meant to ask "Is the boot order in the BIOS set to boot from the RAID array FIRST ?
0
 
livegirlloveAuthor Commented:
yes it goes through the whole install with count down.  enter in profduct keyt.  type in user name typical network settings etc...  then on final reboot before going to log in screen it crashs.

im going to set it to boot to the array first...  

right now it is set as cd then array

ill post back momentarily
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
livegirlloveAuthor Commented:
btw you were helping me on a similar issue yesterday.  Actually this is a different computer with the same mobo...
0
 
livegirlloveAuthor Commented:
ok set the raid to be the only boot device.. I should have mentioned Im not getting a no os found or anything.  Its giving me
Windows could not start because of a computer disk hardware configuration problem.

Could not read from the selected boot disk. Check boot path and disk hardware.

Please check the Windows documentation about hardware disk configuration and your hardware reference manuals for additional information.

and now that I RTFMd it... I come up with this:
http://support.microsoft.com/kb/314477/

so I may try that.

what do you think.  What would cause this?
0
 
Gary CaseRetiredCommented:
Ahh .. you're actually not "crashing" AT the reboot -- you're crashing DURING the reboot.  That's different than what I understood from the question.   Yes, I think you should try correcting the BOOT.INI => the Recovery Console method is probably the easiest (see the Microsoft article above).

... as to what caused it ==> I simply don't know.   This is a fresh install on a new "disk" (actually an array) -- right?   I'd have certainly expected XP to generate a correct BOOT.INI.

Did you leave the drives set to SATA-150 rates?  (You said you tried it -- not clear if you left them that way ==> since the interface is SATA-150, I'd leave the drives jumpered for that)
0
 
livegirlloveAuthor Commented:
i did leave them jumpered.  and now its giving the error above.  before it would just start loading atnd die and agp440.sys.

so Ill try the boot.ini.

Yes these are brand new drives.  in a new array.  using a full and quick format with same results.  so win blows just doesnt want to create the proper boot.ini

ill post back soon.  gonna try to get this out of the office tonight. ;-)
0
 
livegirlloveAuthor Commented:
well i did method 2 in teh above KB

Worked!!  booted.

but I must be crazy because it just started the windows install.  So I must not have actually gotten all teh way through it this time.  I've installed win so many times the last couple days its all a fog.

anyway.  if it continues install and works I'll go ahead and award points.  other wise you;ll here back soon.

quick question.  If windows knows enough about the harddrive to give a windows error, why the hell wont it boot?  seems very strange.  
0
 
livegirlloveAuthor Commented:
ok so it went through the install and then rebooted and goes back into a never ending reboot cycle.  I try to boot into safe mode and it gets to agp440.sys and then reboots.  
(this is what normally has happened)

Also this has happened a couple of times now...it says the raid has gone critical.  I have tested both of the drives and actually have 4 of the same drive and I know it isnt bad drives?  I'm beginning to wonder if the RAID has gone bad on the mobo.  

any other ideas?  I've pulled all the pci cards out.

I tried a different video card.  

basically at a loss as to the problem.
0
 
Gary CaseRetiredCommented:
Alright, let's test what you said in the question:

"... i can install windows on it using those drives without the raid.... " ==>  Since you have a bunch of these drives, DO THAT  (install XP on a non-RAID drive).   Make the XP partition fairly small (20GB).

"... and I can use the raid if windows is installed outside the RAID." ==> ... and with 2 other drives do this.

==>  So if you do the above, you'll have XP working fine on a non-RAID drive, and a RAID-1 array available for data, etc.    Be sure the RAID drivers are installed in XP.   Now create another partition on the non-RAID drive (remember you only used 20GB for XP); and IMAGE XP to that partition  (I'd use Boot-It NG, but you can use whatever imager you're comfortable with).

... NOW use your imaging program to Restore the Image TO THE RAID array (as the first partition ==> you can "wipe" the array if you want.   Then set that partition active, and make it the first boot device --> and see if it boots !!

... off to bed => the above should give you plenty to try tonight.   ... and will likely get you booting just fine (although it won't explain why the install isn't working right in the "normal" method)
0
 
tmj883Commented:
http://support.microsoft.com/kb/324764/en-us
I don't believe the problem lies in the array...
T
0
 
rindiCommented:
You tried a different video card, have you tried a PCI card? the agp.sys file is probably the AGP driver (not the Video card driver), so it might work if you use a PCI card. Otherwise you might have slipstreamed a bad AGP driver into your CD. You could try renaming that file from a recovery console and then try booting.


0
 
livegirlloveAuthor Commented:
I think I figured it out.

Seems that the RAID channel 1 is squirlly

I installed windows on a seperate drive.  Installed the raid.  Installed the RAID Utility.  It showed up fine etc.

Then I rebooted and I get critical raid...

So I looked at the util in win and it shows critical there on channel 1.  

So I got a new raid card.  Im gonna test that now.

And yes... I tried a PCI video card...
0
 
Gary CaseRetiredCommented:
That's one of the reasons I had you install independent of the RAID ==> much easier to isolate WHERE the problem is :-)
0
 
livegirlloveAuthor Commented:
yup... I just put in a new card.  array built fine.  windows is installing now.  cross your fingers that it reboots ;-)
0
 
Gary CaseRetiredCommented:
... been gone most of the day --> but I'll be watching for your next status report with fingers crossed !!  :-)
0
 
livegirlloveAuthor Commented:
Well I got the new raid card and everything worked like it should.  definately had to be the channel gone bad.

thanks for your support.
0
 
Gary CaseRetiredCommented:
Good.  Glad it's resolved -- and you're welcome.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now