?
Solved

Excel on SBS:  Cannot access 'Filename.xls'.

Posted on 2006-07-12
13
Medium Priority
?
749 Views
Last Modified: 2008-05-13
I have a group share and every user on the domain has full control of the share.
Every user is having a problem opening Excel worksheets that are saved in this share.

When they use Windows Explorer, or open with the 'open' command in excel they get the error:
Connot Access 'Filename.xls'.

The odd thing: If they try it again, it will work fine...it might take 2 or 3 more tries, but they can eventually get it open.

If they copy the file to their local C:\ on their workstation then they never get the error.

Here's what I've done for troubleshooting:
1) Make sure nobody else is trying to open the file (only 5 users so this is easy)
2) Reboot and try again...didn't fix it
3) Replaced the netowrk Switch..nope
4) Tried from every computer in the office...same issue on all workstations EXCEPT the server itself. I don't get the error when I'm opening locally on the server.

Google searching didn't help me much.

Please Note: No encryption is on, no compression is on, and Shadow Copies is turned off.

Any ideas?
0
Comment
Question by:ahelgeson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 3
13 Comments
 
LVL 21

Expert Comment

by:suppsaws
ID: 17097563
Hi ahelgeson,

Did you try this with the administrator account on the client machines?
perhaps you only tested with normal user accounts. Logon with the domain admin account on a client and try to open the file ...?

Cheers!
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17098416
How did you create this share?  What are the permissions you granted?

And how are you opening this on the server?  I hope you don't have Office installed on your server and only the Excel Viewer... you should NOT use the server as a workstation and should never have Office installed on it.

If this is truly a shared file, you really should store it in your SharePoint (http://companyweb) document library... which is much easier to get to and has many more features than Windows Explorer would have.  For more info on this, open Help & Support on your server and search for "Sharepoint Document Library"

Jeff
TechSoEasy

0
 

Author Comment

by:ahelgeson
ID: 17099179
Suppsaws: Yes, I logged into a client machine with my Domain Admin account and still had the same issue. Sometimes it errored, sometimes it opened fine.

TechSoEasy:
I created the share be right clicking on the folder > Properties > Sharing > Share this Folder.  Then I set the permissions to Everyone having Full Control.
I then used their profile login to map the G: drive to this share.
I also went into the Server Properties Snapin and pulled up the folder in the Shares (local) menu and gave the "Users" group Full Control in the Security tab.

Oddly enough, this only happens with Excel files.  It doesn't matter if the file contains data or not.

More info: The server is not being used as a workstation and MS Office is not installed on the server (I installed it temporarily to see if it fixed the issue, but it didn't so I unstalled it).  We won't be using Sharepoint, thanks for the suggestion.
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17103285
You need to not only set permissions on the share, but also on the Security Tab you need to set the file permissions.  Generally a companywide share will have the following:

Administrators - Full Control  - This Folder Only
Creator Owner - Full Control - Subfolders and files only
Domain Admins - Full Control - This Folder, subfolders and files
Folder Operators -  Full Control - This Folder, subfolders and files
SYSTEM -  Full Control - This Folder, subfolders and files

I'd suggest that you create the share inside the Users Shared Folders folder which will then give it propagated permissions as described above.

FYI, on Office, if you installed it with Outlook there is a possibility that you damaged Exchange's MAPI service... so keep that in mind if you ever see any Exchange issues in the future.

Too bad about not using SharePoint... in a couple of years, that's how all shared documents will be handled... better to start moving that direction, in my opinion.

Jeff
TechSoEasy
0
 

Author Comment

by:ahelgeson
ID: 17126261
Sorry for the delay in responding.  The folder permissions/security are set properly.  This office isn't using Exchange.

I have rebuilt a PC from scratch and installed Office 2003 and patched everything.
I joined it to the domain and I'm getting the same issue.

It doesn't matter if the user double clicks on a shortcut or the file directly from a folder view, and it also gives the same issue when opening from the 'open' command in Excel.

I'm stumpped.
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 17126290
Well, this most certainly is a domain security issue, so if you don't mind, please answer the following:

How did you join the domain?

Do you have all users in the default Active Directory OU?  (\MyBusiness\Users\SBSUsers)?

Do you have all computers in the default Active Directory OU? (MyBusiness\Computers\SBSComputers)?

Jeff
TechSoEasy
0
 

Author Comment

by:ahelgeson
ID: 17168800
I join a PC to the domain by: Right clicking My Computer > Properties > Computer Name Move from workgroup to Domain and use my Domain Admin ID to join it.

Yes, all users are in: DomainName/MyBusiness/Users/SBSUsers

No, none of the computer were in the SBSComputers folder.
I made this change today and I will let you know if this resolves the issue.

0
 
LVL 21

Expert Comment

by:suppsaws
ID: 17168954
you really should join the pc's the sbs way.
http://servername/connectcomputer

Log on to the pc with the local admin
join the pc to a workgroup
delete the program files\small business server\ folder
make sure the sbs server is the dhcp server, and put the client on dhcp

open server management
delete the 'old' pc
recreate a computeraccount via the wizard

reboot the pc, and joint the pc via http://servername/connectcomputer

Your really should add all your worstations that way.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 17168978
so make sure the users and computers are added via the wizards under server management
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17170219
Just to clarify the steps for fixing how you joined your workstations to the domain please follow these items:

The following needs to be done with the client machine:
1.  Log in with THAT machine's LOCAL administrator account.
2.  Unjoin the domain into a WORKGROUP
3.  Change the name of the computer
4.  Delete or rename the following directory C:\Program Files\Microsoft Windows Small Business Server\Clients if it exists
5.  Make sure that the network settings are configured to get an IP address automatically (DHCP enabled)
6.  Reboot

Then on the server, from the Server Management Console:
1.  Remove the client computers if it still shows in the Client Computer screen on the Server Management Console
2.  Add the client with it's NEW name using the Add Computer wizard

Then, go back to the client machine and join the domain by opening Internet Explorer and navigating to http://servername/connectcomputer

If you want to see what connectcomputer does for you, please see http://sbsurl.com/connectcomputer

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17170238
Back to your actual problem however, can you please provide the EXACT error message that is received when trying to open an xls file on the network?

Thanks.

Jeff
TechSoEasy
0
 

Author Comment

by:ahelgeson
ID: 17175311
The problem is now resolved. I put the computers in the default OU and all is well.

Thanks for all your help!!!
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17175472
Thanks for the follow-up.  Now that I review the whole thread it makes sense that it's a computer permissions problem and not a user permissions problem.  Because of the multiple attempts to open the file which finally succeeds.  My guess is that there are parts of Excel (such as data connectors) which are trying to bind or connect to other domain assets, and those are actually still in a fail state once the document gets open.  But most likely they aren't even being used by that particular document so nobody would even notice.   It could even be just the user's My Documents folder being established as the default storage folder, but the workstation didn't have permission to do that.

At any rate... you've just given us one more important notch on the connectcomputer post!

Jeff
TechSoEasy
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A lot of problems and solutions are available on the net for the error message "Source server does not meet minimum requirements for migration" while performing a migration from Small Business Server 2003 to SBS 2008. This error pops up just before …
The SBS 2011 release date (RTM) is supposed to be around Christmas, 2011.  This article is a compilation of my notes -- things I have learned first hand.  The items are in a rather random order, but I think this list covers most of what is new and d…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question