Solved

Cisco ADSL with no Authentication

Posted on 2006-07-13
12
766 Views
Last Modified: 2010-03-17
Hi,

I am setting up a Cisco 857 for adsl that does not require authentication according to the ISP. I have got a connection on the ATM0 interface but am not getting a PPP connection?! I have not configured any type of authentication on the dialer interface.

When i run 'debug ppp authentication' I receive

vi2 ppp Authorization required
vi2 ppp no remote authentication for call-outs

Can anyone help?

Many Thanks
0
Comment
Question by:willwetherman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
12 Comments
 
LVL 6

Expert Comment

by:Booda2us
ID: 17101271
Step 1. a) Connect to your router using Telnet, SSH or via console.

b) Enter the global configuration mode using the command:

Router(config)#enable
Step 2. Enable the router's HTTP/HTTPS server, using the following IOS commands.

If http/hhtps is enabled and configured to use non standard port numbers, you can skip this step and simply use the port number configured already.

Router(config)# ip http server
Router(config)# ip http secure-server
Router(config)# ip http authentication local
Note: HTTPS is enabled only for crypto enabled IOS images.

Step 3. Create a user with privilege level 15.

Router(config)# username <username> privilege 15 password 0 <password>
Note: Replace <username> and <password> with the username and password that you want to configure.

Step 4. Configure SSH and Telnet for local login and privilege level 15:

Router(config)# line vty 0 4
Router(config-line)# privilege level 15
Router(config-line)# login local
Router(config-line)# transport input telnet
Router(config-line)# transport input telnet ssh
Router(config-line)# exit
Step 5. (Optional) Enable local logging to support the log monitoring function:

Router(config)# logging buffered 51200 warning
I hope this helps..Booda2us
 
 
 
 
0
 

Author Comment

by:willwetherman
ID: 17101667
Sorry I dont understand, this looks like how to gain access to the routers web interface. The problem that I am having is that the router will not connect to the internet. I have been told by my isp that it does not require any authentication (chap or pap). When i run the debugging i get the above errors
0
 
LVL 10

Expert Comment

by:naveedb
ID: 17105232
Can you post running configuration from the router?

Also, provide the information you received fromt he ISP, VPI/VC, IP Address etc.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:willwetherman
ID: 17112033
Current configuration : 3621 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 password
!
username User password 0 password
aaa new-model
!
!
aaa authentication login default local
aaa session-id common
ip subnet-zero
!
!
ip cef
ip inspect name myfw cuseeme timeout 3600
ip inspect name myfw ftp timeout 3600
ip inspect name myfw rcmd timeout 3600
ip inspect name myfw realaudio timeout 3600
ip inspect name myfw smtp timeout 3600
ip inspect name myfw tftp timeout 30
ip inspect name myfw udp timeout 15
ip inspect name myfw tcp timeout 3600
ip inspect name myfw h323 timeout 3600
no ip domain lookup
no ftp-server write-enable
!

!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dial pool-member 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
 no ip address
 no cdp enable
!
interface FastEthernet1
 no ip address
 no cdp enable
!
interface FastEthernet2
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet3
 no ip address
 shutdown
 no cdp enable
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Dialer0
 ip address (removed)
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no http server
no http authentication local
no http secure-server
ip nat inside source list 102 interface Dialer0 overload
!
!
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
!
line con 0
 no modem enable
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 transport preferred all
 transport input ssh
 transport output all
!
scheduler max-task-time 5000
end
0
 
LVL 6

Expert Comment

by:Booda2us
ID: 17114638
does this help?:
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto

interface ATM0.1 point-to-point
 pvc 0/35
  pppoe-client dial-pool-number 1

interface Dialer0
 mtu 1492
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname <some value here>
 ppp chap password 7 <another value here>
 ppp pap sent-username <some info here> password 7 <still more info here>

0
 

Author Comment

by:willwetherman
ID: 17117173
Hi,

Sorry for the late reply. This problem has been sorted, it was due to the lack of information supplied by the ISP.

Thanks
0
 
LVL 6

Expert Comment

by:Booda2us
ID: 17117659
What like the authentication?
0
 

Author Comment

by:willwetherman
ID: 17118327
No, it was due to the connection not using ppp. It's configured directly on the atm interface with a private hidden ip address directly to the isp (its own form of authentication)
0
 
LVL 4

Expert Comment

by:Justin Malone
ID: 17143820
have you set up the VPI and VCI for your isp correctley? ATT would be 0 and 35 verison i beleave is 6 & 35 ect..
0
 
LVL 4

Expert Comment

by:Justin Malone
ID: 17143825
nvm i see it in the config
0
 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 17371121
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
Come and listen to Percona CEO Peter Zaitsev discuss what’s new in Percona open source software, including Percona Server for MySQL (https://www.percona.com/software/mysql-database/percona-server) and MongoDB (https://www.percona.com/software/mongo-…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question