• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 491
  • Last Modified:

Lan Voip calls with no audio

In my LAN, I have about 10 Linksys SPA942s, all registering to a hosted proxy.  Calls to/from any of the phones to an outside number (ie through the WAN) seem to work just fine.  However, when I try to call from one 942 to another, the call sets up, the phones ring, but no audio, in either direction.  The router is a Netopia 3347W and that is providing DHCP, NAT, DNS, etc.  We are using an unmanaged switch to provide the remaining ports.  Any ideas as to why the phones work Lan-Wan and Wan-Lan, but not Lan-Lan?
0
santiagokid
Asked:
santiagokid
  • 2
2 Solutions
 
jfradyCommented:
What about this - since you are using a hosted proxy - the hosted proxy does not know the IP addresses of the phones since they are NAT'd.  It is trying to set up a call to both phones using the same IP address?  Maybe NAT-T compliance or also could be a routing issue.
0
 
Reid PalmeiraTelecom EngineerCommented:
jfrady is probably right no audio is likely a problem of NAT traversal. You'll need a session border controller or some form of STUN proxy to handle the NAT traversal and you'll probably have to check with your provider for that.

One thing to check though, if the call is being set up the SIP sessions registrations are getting through. are there any local firewall policies in place that might be preventing the RTP stream? probably not but it's good to check.

if you to a packet trace, can you see the RTP packet stream? where is it getting blocked?
0
 
santiagokidAuthor Commented:
Thanks for the comments and sorry for the late response.  I was unable to get the Netopia router to pass the RTP streams, even by disabling the firewall.  It seems that it wont let the streams pass from port to port.  I put the Netopia in bridge mode and then put a D-Link router behind it.  That solved the problem.

I am using a hosted SBC for NAT traversal, however, I had to increase the rate at which the device re-registers (from 1800s to 240s) since the NAT mapping seems to disappear after about 5 mins.  I have seen this twice now with DSL broadband connections.  Cablemodems don't seem to have this problem.  I have set NAT keepalive messages to be sent every 120 seconds, but that doesn't do it.  I have to re-register.  Aside from irritating the service provider and loading the network a bit more, I don't see much downside to that, but I would like to know if that is the right way to go through NAT.
0
 
santiagokidAuthor Commented:
The system is stable, and calls are going through just fine.  I set the phones to re-register every 180s.  I am going to disable NAT keepalive, since that doesn't seem to make a difference.  It is the registration that makes it work.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now