Solved

trouble??? after installing crystal reports xi release 2 --- HELP !!!!

Posted on 2006-07-13
5
2,860 Views
Last Modified: 2009-06-29
I have ... installed on my local workstation (the programs are not installed on the server...)
crystal reports XI developer edition (sp2)
visual studio 2005

I downloaded & installed & re-registered the "CRXI release 2"

and NOW... ouch... EVERY TIME i open crystal reports (from the ~Start \ Programs...) it tries to configure release 2 AGAIN ???
"Please wait while windows configures Crystal Reports XI Release 2"

I also get another message during this process ... the one that says:
"Server Busy... switch... Retry"

HELP... i have so much work to do & it's taking forever to get over these problems
0
Comment
Question by:myBabyDBA
  • 2
  • 2
5 Comments
 
LVL 42

Accepted Solution

by:
frodoman earned 500 total points
ID: 17102544
I don't know about this exact circumstance, but often problems similar to this may occur if there is a previous version of Crystal on the workstation.  There is sometimes a conflict in the registry if the older version isn't first removed; however, you'll usually see an error message during the installation that will indicate a partial installation failure.  Did you see any error messages during the install?

Another general (non-Crystal) possibility is that you don't have rights to write to the registry on your workstation.  If the registry settings aren't saved then every time the application launches it 'thinks' it's the first time.
0
 

Author Comment

by:myBabyDBA
ID: 17102771
was i supposed to uninstall crystal XI first?
can i check something in the registry? what should i look for?

i don't recall any error during install, only AFTER restart & opening it for the first time (AND every time there after)

I downloaded the files to the server & ran the installation by double-click on the crxir2.part1.exe file... did i do something wrong there? OH... by-the-way... what is the 2nd file for? crxir2.part2.rar
0
 

Author Comment

by:myBabyDBA
ID: 17130439
thanks frodoman... it was an installation error, but since i felt you left me hanging, i gave you a "good" rating...

with no solutions, i decided to go back & re-install crystal release 2. still nothing. so i did it again. then finally... the 3rd time (after days of frustration) i DID get an installation error (as you suggested, but i had not noticed).

"Error 1719 The windows installer service could not be accessed...."  

just thought i'd let you know what happened.
Thanks for push in the right direction!!!
0
 
LVL 42

Expert Comment

by:frodoman
ID: 17130599
Glad you've got it working.  Sorry about leaving you hanging - I only participate in this forum when my schedule allows so I sometimes disappear for a while when I'm bogged down.

Cheers,

frodoman
0
 
LVL 38

Expert Comment

by:Jim P.
ID: 24739767
I found a resolution for this. The Crystal Reports XI Release SP2 installer 914-00806-085.part1.exe) is missing a reg key installer for the [HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.0\Crystal Reports\Keycodes\CR Pro] key. Copy off a 10.5 version or from a working machine and edit to match the 11.0 version keys.

Then you should be good.
[HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.0\Crystal Reports\Keycodes\CR Pro]

"THX1138"=dword:hexnum

"Version"="11.#.#.######"

@="1

REG-KEY-####-#####3

#########

#########

"

"Serial"="#########"

Open in new window

0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now