Solved

Cannot connect with VNC.  Likewise, other machines cannot conect to my machine via VNC

Posted on 2006-07-13
9
2,262 Views
Last Modified: 2008-01-09
Hello Experts.  Here is my issue.  (I'll get this out of the way - windows firewall is not on)  When trying to connect to a machine via VNC I am receiving this error:  unable to connect to host: An invalid argument was supplied. (10022)  Can anyone help?  It's driving me nuts!  Thanks!
0
Comment
Question by:ibiquity
  • 2
  • 2
  • 2
  • +3
9 Comments
 
LVL 43

Expert Comment

by:zephyr_hex (Megan)
ID: 17103155
10022 "invalid argument" is a standard TCP/IP error code.
are you trying to connect to a machine inside your network?  i would start there so as to rule out firewall issues on the router, or port forwarding issues on the router.
also, are all computers involved fully patched?
0
 

Expert Comment

by:moistowelet
ID: 17103679
Try running VNC in service mode
then restart the VNC service and try and connect


also, make sure both ends are using the same version of VNC
0
 
LVL 1

Expert Comment

by:PugnaciousOne
ID: 17103962
I've had alot of problems with this type of connection. Some more information is needed to accurately answer this question.  First, are the machines connected on a local network?  If not, what types of connections do they use.  Second, How is VNC setup on each machine?  To clarify that, which one runs the server, and which the client, and how are they configured.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 44

Expert Comment

by:scrathcyboy
ID: 17105045
is this connect across the internet or just the local lan?  That is crucial info before we can give a solution.
0
 
LVL 3

Expert Comment

by:waqaswasib
ID: 17106345
for example, specifying an invalid level to the setsockopt function). In some instances, it also refers to the current state of the socket - for instance, calling accept on a socket that is not listening.
install any other version of VNC
check if all connection are open
firewall is also a probability but u have mentioned it's off
hope it might help you
bye
0
 

Author Comment

by:ibiquity
ID: 17107742
The machine(s) are inside a local LAN.  VNC is set up with both server and client on everymachine.  My counter part in Maryland (I am in NJ - but on the same network) can connect to many machines but not mine.  I cannot connect to any machines.
I just tried to run VNC - Run Listening VNC Server and got this error:  unable to set socket to listening mode.  An invalid argument was supplied (10022)
All your help is, as usual, much apprciated!
0
 
LVL 1

Expert Comment

by:PugnaciousOne
ID: 17107774
I'm fond of a version of VNC called UltraVNC which has a repeater function ( http://www.uvnc.com/addons/repeater.html )  Have you tried that type of connection?
0
 
LVL 44

Accepted Solution

by:
scrathcyboy earned 500 total points
ID: 17109904
It is possible that you are confusing the VNC terms -- they are exactly backward to what a "normal" person would expect.  The server is actually the listener for an incoming connection, and the "listener" is actually the "server" that does the active connecting.  So without arguing terms, if you are trying to connect to anyone, you need to run what they call the "listener" and they run the "server".  Make sure their server is set to accept a connection by default, and they have the ports at 5900 5800 and auto.

Now when you connect to them you type in "computer1" if you are on the lan (use their computer name).  If someone is connecting to you over the net, they need " 107.43.25.131:0 " i.e. your WAN IP and :0 for the first person on the network running the port settings on "0" -- not auto.  If calling in, the "server" needs to have a fixed IP -- and here is the problem, the router needs to forward ports 5900 and 5800 to a fixed IP number, but if more than 1 person is running VNC, then you need to forward ports 5901 and 5801 to the NEXT person with a fixed IP, and set their server port setting to "1", not "0".
0
 

Author Comment

by:ibiquity
ID: 17141214
After a fix here and there it all boiled down to McAfee.  McAfee Total Protection for small businesses was blocking not only VNC and Remote Desktop but a whol array of connections.  It kept on blocking even after 1) Turned the McAfee firewall off and 2) Completely unistalling McAfee.  Had to format and rebuild machine.  No McAfee now and everything is running smoothly!
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

827 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question