Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 431
  • Last Modified:

Latest PHP version for Plesk 7.5.4

I would like to know which is the latest PHP version supported by PLesk 7.5.4. Thanks
0
s_federici
Asked:
s_federici
  • 6
  • 4
  • 2
1 Solution
 
Richard QuadlingSenior Software DeverloperCommented:
I've sent an email to sales@swsoft.com. You could try the same. Maybe I'll get the response first!
0
 
s_federiciAuthor Commented:
It is not urgent. I can wait for the answer they will send you.
0
 
Richard QuadlingSenior Software DeverloperCommented:
Plesk is fully compatible with PHP 4, it will work with PHP 5 but there are applications in the Application Vault that are not compatible so the core Plesk software will work but the AV applications will not work. PHP 6 is not supported at all.

Or so I'm told by Jennifer Thompson at swsoft.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
s_federiciAuthor Commented:
What I need to know is: is Plesk 7.5.4 compatible with PHP 4.3.10 for usage on production server? Jennifer should know it :-)
0
 
floorman67Commented:
yes it is compatible
0
 
s_federiciAuthor Commented:
Ok, could you give me (or ask Jennifer) a URL showing this spec so that my provider can look at it and accept my request of upgrading my PHP version without having to worry about server stability?
0
 
floorman67Commented:
it should be in your providers documentation.

a decent provider would peruse this documentation before asking you to request it, since they are the party who licensed the product, then sold the serrvice to you, their customer.

Seems they dont even know their own responsibilities.

However ... here you go ...

Plesk 7.5.4 reloaded now supports php5 and because of php's backwards compatability, it means that previous versions will work.

You can find this (took me 30 seconds) at the Plesk Knowlegebase.

http://kb.swsoft.com/search.php?qtext=7.5.4&qprod=any&qtype=EV&qusing=AllWords&Submit.x=6&Submit.y=8

I am currently running Plesk 7.5.4 (with PHP 5) and previously used php4 .3.1.0, so I know it work ..becasue i have used them on procuction servers.

Tell your provider todo their own leg work.

thats a real pet peave and would piss me off If I was paying them for service.

I would be looking for another provider LOL
0
 
s_federiciAuthor Commented:
Thanks a lot. I awarded only fllorman67 (I didn't notice it was a different person). Please, RQuadling, go to new "Latest PHP version for Plesk 7.5.4" to get the points you deserve.
0
 
s_federiciAuthor Commented:
0
 
Richard QuadlingSenior Software DeverloperCommented:
Is the App Vault a different product?
0
 
Richard QuadlingSenior Software DeverloperCommented:
In reply to another email to Jennifer ...

There is nothing specifically indicating PHP versions. The rule of thumb is that Plesk supports a version of PHP that comes with OS.  It is indicated in the release notes for each Plesk supported OS:
ftp://download1.swsoft.com/Plesk/Plesk8.0/FedoraC4/psa-8.0.1-fc4.build80060713.16.i686.html

Also, you can take a look at our knowledge base articles about PHP:
http://kb.swsoft.com/article_19_1122_en.html
http://kb.swsoft.com/article_37_378_en.html

 
0
 
s_federiciAuthor Commented:
Thanks
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now