How to check which services are running on suse linux

How do i check which services are running on suse linux 9.1 via the interface and not the command line.
akt-ukAsked:
Who is Participating?
 
DonConsolioConnect With a Mentor Commented:
YaST Control Center->System->Run level editor+Runlevel properties
0
 
rindiCommented:
What do you mean with "The Interface"?

You could install webmin, a webbased administration tool for linux. If it isn't included in the SuSE installation, you can download it from http://webmin.com

This tool is very usefull and includes a module which allows you to view what processes are running.

You can also check if KSysGuard is installed, this is similar, but more powerfull than the windows taskmanager. You might be able to find it under "System" in KDE. If not, I'm sure it is included with SuSE, then you will just have to install it using Yast.
0
 
nedvisCommented:
SuSE 9.1 utilize the SysVinit ( originally Unix SysV init GUI tool)  which contains a group of processes that control the very basic functions of your system. SysVinit includes the init program, the first program started by the Linux kernel when the system boots. Init then controls the startup, running and shutdown of all other programs.
You can install SysVinit package fro SuSE 9.1 CD #1 or download the packagehere:

http://mirror.eacoss.org/software/suse/9.1/CD1/suse/i586/sysvinit-2.85-20.i586.rpm

Once SysVinit is launched you will have full graphical interface at your disposal to review, manage and configure
system services on your SuSE 9.1 Linux box.

good luck
nedvis

0
 
akt-ukAuthor Commented:
i have rsync installed and want to know if the rsync is running, when i run the command in the shell console it says it's not running but rsync is still backing up. Very strange.
0
 
DonConsolioCommented:
some services are not started at boot time, but run from xinetd

check /etc/xdinetd.d/rsync

# default: off
# description: rsync file transfer daemon
service rsync
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/sbin/rsyncd
        server_args     = --daemon
        disable         = yes <---- make this a "no"
}

and then restart xinetd (rcxinetd restart)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.