Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 298
  • Last Modified:

Mail not being routed between two Exchange 2003 servers

I recently added a second Exchange 2003 server and have run into a snag with getting them to communicate with one another.  Both show up under my organization servers and I can move mailboxes from one to the other without a problem.  However, users who have mailboxes on the new servers cannot send or receive e-mail to users with mailboxes on the original server.  The new server mailboxes can also send mail out to the internet but cannot receive mail from the outside.

I have made sure that the original server does not have Smart Host configured and I have added the new server to the bridgeheads on the routing group connector.  Both have an SMTP Virtual Server configured identically.  The internet mail issue may be firewall related (though I thought mail would be delivered to the original server and then routed to the new one?) but can't figure out why the two servers cannot mail each other.

In a possibly related issue, I am unable to get Public Folder replication to work at all.  I have configured replication for "Always".  The original server shows "In Synch" but the new one shows "Local Modified".  Following other advice I read on here I compared the actual message counts and there seems to be no replication at all happening.  This has been about 24 hours.  Not a huge amount of time but I should see something I think.

Any advice would be greatly appreciated!

Edit:  I should add that I have also completely removed antivirus from both Exchange servers for the time being so as to make sure it wasn't isolating messages or causing a problem.  Thank you!
0
KCATA
Asked:
KCATA
  • 7
  • 5
  • 3
2 Solutions
 
xqsCommented:
try to telnet the first server from the second server using port 25 and see if you can connect and do the same from the first server to the second server. This will tell you if SMTP traffic is allowed between the two.

http://support.microsoft.com/?kbid=153119


0
 
KCATAAuthor Commented:
Thanks for the reply.  I was able to telnet between them on post 25, but there still seems to be some sort of SMTP error.  Mail sent from the new server to the old comes back undeliverable with the following:

 There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <kcataex.kcata.org #5.5.0 smtp;553 Terminating connection as the sender is spoofed.>
0
 
kristinawCommented:
"I have made sure that the original server does not have Smart Host configured"

does the new server have a smarthost configured on the virtual server? if it does, it should not.

kris.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
KCATAAuthor Commented:
No, it does not either, the two virtual servers are configured identically.
0
 
xqsCommented:
What version of Exchange are you using (including Service Packs) and what is configured as Anti-Spam protection?
0
 
KCATAAuthor Commented:
Both servers are running Exchange 2003.  The original is on SP1 and the new one is on SP2. The original box is Win2k and the new server is Windows 2003 for OS.

On the original box is SurfControl Spam Filter.
0
 
xqsCommented:
Is there a whitelist functionallity on the first Exchange server to allow (trust) the ip of the second Exchange server?
0
 
KCATAAuthor Commented:
The spam filter is set to only look at inbound and outbound traffic, nothing inter-office.  I am now able to receive e-mails on the 2nd exchange server from people on the first, but not the other way.  Inbound and outbound mail to the internet is now working normally on both servers.

So, sending mail from the new server to people on the old server is the only remaining issue (not counting replication of public folders).
0
 
kristinawCommented:
"I am now able to receive e-mails on the 2nd exchange server from people on the first", did this just start working by itself?

what did you do to fix it?

how do you tell the spam filter to only look at inbound and outbound traffic?
have you tried turning off the spam filter and checking functionality?

kris.
0
 
KCATAAuthor Commented:
Here's what I did, and I appreciate everyone's comments so far as they've helped put me on the right track anyway.  Basically the SPAM Filter demands the use of port 25 so that it receives the SMTP traffic to filter before passing it on.  The Virtual SMTP server in the original Exchange box has been configured for port 26 and that's been working fine for the last year or so.  The new Exchange server naturally defaulted to Port 25 initially.  What I changed was to put it to port 26 like the original.  I think someone above mentioned that Exchnage will automatically listen on port 25 as well as an additional configured port?  So by having it this way it was receiving the telnet requests on both 25 and 26.

This being the case I'm still not sure why I can send and receive outbound and receive from the original server, but still not send internally from the new server.  Also, as near as I can tell Replication is still not working, which is a little surprising since it's going from the original to the new, a direction that seems to be working currently for mail traffic.
0
 
KCATAAuthor Commented:
Oh... with all that I forgot your other questions.  

The SPAM Filter configuration is an option in the setup.  Just check whether you want Inbound/outbound, Inbound only and whether or not to filter internal mail.  And I did initially disable the Spam filter but had no improvements as a result.

Thanks again for your continued interest and advice all.
0
 
kristinawCommented:
well, now it makes sense.

there are two places to change the default port in exchange. you have the listening port, and you have the outbound port.

have a look at the following and make sure you've changed it in both places:
http://support.microsoft.com/kb/274842/

kris.
0
 
kristinawCommented:
btw,

i'm assuming you're sending all mail through exchange 1 to go outbound?

kris.
0
 
kristinawCommented:
looks like what was happening, is when you were telnetting from exchange 2 to exchange 1, you were actually telnetting to the spam filter. that's why you were getting the odd 553 response.

if exchange 1 is listening on port 26, exchange 2 will need to send it's outbound on 26 if it want's to talk to exchange 1.

personally, i would never have something on my exchange server that caused me to have to change the default port that exchange listens on. i would try and get that filter moved somewhere else, then configure an smtp connector for exchange that has the filter configured as a smarthost.

as for your current setup, you may want to call surfcontrol, as i would call this a 'non-standard' setup for sure.

kris.
0
 
KCATAAuthor Commented:
I agree and part of the exchange server move does involve moving the SPAM filter to a different server as well.  We were having space issues overall which was how it got stuck there to begin with.  We have now implemented a SAN solution and upgraded several key servers to go along with it so the Exchange server and the SPAM filter will soon be on two different machines.

I'll try the port changes when I go in sometime this weekend but even if that fails I should be able to do everything I need by disabling the SPAM filter and then reverting the port on both servers back to the default of 25 so I'll go ahead and close this out.

Many thanks to both Kris and xqs for all your help with this.  If I can figure out how to do it right (new to this forum) I'll split the point between you.  
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

  • 7
  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now