[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Internet Gateway Icon Missing

Posted on 2006-07-14
10
Medium Priority
?
1,564 Views
Last Modified: 2008-01-09
Hi All,

I'm having a problem with getting the Internet Gateway icon to show up in Windows XP SP2, and so far have only been able to find solutions for how to get rid of it.  A few things I've tried:

1. Turning on DHCP in the router (Linksys);
2. Turning on DHCP in the local system (currently set up to use a static ip);
*Note: the above two used to work before something I'm unaware of happened*
3. Checking to make sure that upnp is enabled in the router;
4. Turning off the Windows firewall altogether;
5. Temporarily disabling the firewall in the router;
6. Checking to make sure that the unpn and SSDP services are running in the services;
7. Turning on Internet Connection Sharing;
8. Checking all of the items in Windows Add/Remove Components that pertain to networking...

Unfortunately the application I'm working on needs to use the port forwarding functions that the Internet Gateway icon provides for.  In many cases the users of the system don't even have access to their office routers, and have no clue as to what the usernames/passwords are (and even if they did, guiding them through the port forwarding configuration isn't the best solution and is usually time consuming)...

Thanks in advance for the help!
0
Comment
Question by:cmjwebservices
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
10 Comments
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17110079
I am not very familiar with the service but a couple of thoughts:
-Make sure the SSDP service is started and set to automatic in the Services control panel (enter services.msc in the start/Run box) This is the service that discovers the UPnP devices
-Are you looking in the "network connections" window or the "My Network Places" windows. It does not show up in the latter by default.
-Also verify UPnP is installed on the PC, see:
http://support.microsoft.com/kb/821371/
0
 
LVL 2

Author Comment

by:cmjwebservices
ID: 17110184
RobWill,

I've verified the above services are installed and running and have set them to "Automatic" (number 6 in my first post).  I'm not sure that it's possible to have a static ip and retain the icon, but was wondering if there's a workaround or something I could install that would bring it back into view (or at least allow me to use the same port forwarding code that I wrote previously which relies on its availability)...
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17110465
Sorry I missed #6 above. Seem to be doing that a lot lately, must be an age thing <G>
As mentioned, I'm not familiar with this feature but looking at a list of related services you might want to "tinker" with the following.
Application Layer Gateway Service
Universal Plug and Play Device Host (assume this is the UPnP you verified already, above)

Also, are you in a domain environment or workgroup. I only deal with domains, and only vaguely remember this feature, but thought it was an interesting question. The fact that I haven't seen it on any domain makes me wonder if it might be disabled in that scenario, as it could cause some security concerns. Just a thought.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 2

Author Comment

by:cmjwebservices
ID: 17112832
Actually I have yet to try it in a domain either ;).  The network I'm testing from is actually just using a standard Linksys router and the workgroup option.

However, there may have been a breakthrough to a certain extent.  I took my desktop computer to my home and connected it there, and immediately the icon reappeared (!?).  There are only a few differences I can think of between the two setups:

- My home computer connects directly into the router, whereas the office setup involves traversing through multiple switches before reaching the router (a possibility).

- My home router configuration has the following differences (the exact same model and make): MAC Address clone is disabled, DDNS is disabled, and under "Advanced Routing" the operating mode is set to Gateway.  I believe the office setting is "Router".

In all other aspects they are virtually identical (we even use the same ISP).  Tomorrow I'll check it out and change some of the settings so that they match my home network more closely.

Thanks for the continued input.
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 2000 total points
ID: 17112864
I don't think the switches should make a difference but it is a good point and if possible to bypass them as a test it might be a good idea. If there were a basic router between the PC and the Linksys gateway/router connecting 2 subnets, it might be more apt to block some traffic such as the gateway discovery feature.

The " "Advanced Routing" the operating mode is set to Gateway.  I believe the office setting is "Router"." sounds more likely to me as the possible culprit.

Also is the firmware version the same on the 2 routers?

Let us know how you make out. I am very curious. It is not a feature you hear a lot about, but Vista I think will be promoting it more. It has a similar utility, which is a little more polished, called; "Internet Gateway Device Discovery and Control"
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 17112869
>>>Internet Gateway icon

forgive me for sounding stupid but what is that?
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17112914
Hi James. I only have seen it once or twice, and I was just questioning whether it will even work in a domain environment such as yours, but.... There is a feature in Windows that will make use of the UPnP functions of XP, and UPnP enabled devices, such as many residential routers, that "discovers" the device, and allows you to configure some basic features of the device, within Windows. So the "Internet Gateway icon" would  effectively be your router.
SBS 2003 can even use it, though I don't think the icon shows up, to automatically configure the router for features such as SMTP, remote web work place and such. I think it is still a little finicky, but Vista is supposed to elaborate on it.
One week off snowboarding and you are already behind with technology.  :-)
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 17113195
ha! its true, the new zealand air has broken me..... thanks for the explanation, i havent dealt with it before so was somewhat confused :)

Cheers Rob! Behave........
0
 
LVL 2

Author Comment

by:cmjwebservices
ID: 17161331
I tried using the same settings as my router for the office router, but could not get the icon to reappear.  I guess I'll have to find a workaround for the problem that will allow me to forward the ports on the router without requiring the user to login and do it manually.

Thanks for the help.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17161342
Thanks cmjwebservices, sorry we are not more help. Anything I have read about this feature indicates it doesn't work 100%, however the fact that you are not getting the same results on 2 identical units does sound odd. Perhaps when we are all Vista-cated it will be more of an asset.
--Rob
0

Featured Post

What’s Wrong with Your Cloud Strategy ?

Even as many CIOs are embracing a cloud-first strategy, the reality is that moving to the cloud is a lengthy process and the end-state is likely to be a blend of multiple clouds—public and private. Learn why multicloud solutions matter in this webinar by Nimble Storage.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever set up your wireless router at home or in the office to find that you little pop-up bubble in the bottom right-hand corner of Windows read "IP Conflict - One of more computers on the network have been assigned the following IP address"…
Trying to figure out group policy inheritance and which settings apply where can be a chore.  Here's a very simple summary I've written which might help.  Keep in mind, this is just a high-level conceptual overview where I try to avoid getting bogge…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question