Solved

Trouble getting VPN client to work with PIX 515e

Posted on 2006-07-14
5
438 Views
Last Modified: 2010-03-19
I am trying to accomplish two things on my PIX 515e firewall.

I have configured it to accept VPN connections while authenticating to IAS RADIUS

I am able to connect to the PIX with the Cisco VPN 3.5 client and am able to authenticate using AD through IAS RADIUS

However, the PIX is able to assign my DNS and WINS server to my client while I am connected but it will not assign me an IP address out of the ippool I setup in my PIX. Therefore I am unable to actually do anything once I am connected to the PIX from the outside. I have the proper DNS server (10.1.19.4) but my IP address stays the same (192.168.1.112).

I am also trying to route port 443 to our mail server(10.1.19.5) for OWA and have been unable to successfully accomplish that as well.

Here is my config file

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 10baset
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XCbZD7hp/.NcVa5C encrypted
passwd XCbZD7hp/.NcVa5C encrypted
hostname phorad-515-mdf1
domain-name nid.us.ecc.ads
clock timezone Arizona -7
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_in permit tcp host 10.1.19.5 any eq smtp
access-list inside_in deny tcp any any eq smtp
access-list inside_in permit ip any any
access-list inside_in permit tcp host 10.1.19.5 any eq https
access-list outside_in permit icmp any any echo-reply
access-list outside_in permit icmp any any time-exceeded
access-list outside_in deny icmp any any
access-list outside_in permit tcp any host 206.***.***.*** eq smtp
access-list 101 permit ip 10.1.9.0 255.255.255.0 10.1.20.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 206.***.***.** 255.255.255.0
ip address inside 10.1.19.253 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.19.175-10.1.19.200
no pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 10.0.0.0 255.0.0.0 0 0
static (inside,outside) tcp 206.***.***.** smtp 10.1.19.5 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 206.***.***.*** https 10.1.19.5 https netmask 255.255.255.255 0 0
access-group outside_in in interface outside
access-group inside_in in interface inside
route outside 0.0.0.0 0.0.0.0 206.***.***.*** 1
route inside 10.0.0.0 255.0.0.0 10.1.19.1 1
route inside 10.11.19.0 255.255.255.0 10.1.19.1 1
timeout xlate 4:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 4:00:00 absolute uauth 0:30:00 inactivity
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth max-failed-attempts 3
aaa-server partnerauth deadtime 10
aaa-server partnerauth (inside) host 10.1.19.4 ****** timeout 5
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
http server enable
snmp-server host inside 10.0.20.84
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication partnerauth
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 10.1.19.4
vpngroup vpn3000 wins-server 10.1.19.4
vpngroup vpn3000 default-domain us.ecc.ads
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 15
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
username admin password O68Yn/LPDoD3PiBu encrypted privilege 15
terminal width 80
Cryptochecksum:5440f0a04fd83155403c2ce981d8ab02
: end
[OK]
phorad-515-mdf1#
0
Comment
Question by:ditobot
  • 3
5 Comments
 
LVL 2

Expert Comment

by:just-one-it
ID: 17111197
Have you looked the log to see if there are any errors?  Once you are connected, from the cisco client, click on Status->Statistics.  What do you see under Address information for the client and server?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 17111308
Here's some issues that will affect what you're trying to do:
This acl looks like your're on the right track to bypass nat for inside - > VPN clients
>access-list 101 permit ip 10.1.9.0 255.255.255.0 10.1.20.0 255.255.255.0
>nat (inside) 0 access-list 101

BUT, that acl 101 does nothing because your internal LAN is 10.1.19.x not 10.1.9.x
>ip address inside 10.1.19.253 255.255.255.0

AND, your ip pool is not 10.1.20.0 that I would expect looking at the no-nat acl above
>ip local pool ippool 10.1.19.175-10.1.19.200

This route entry will hinder your ability to use any 10.x.x.x IP address as your VPN client pool
>route inside 10.0.0.0 255.0.0.0 10.1.19.1 1

Suggestions:
no ip local pool ippool 10.1.19.175-10.1.19.200
ip local pool NEWPOOL 172.16.20.175-172.16.20.200
vpngroup vpn3000 address-pool NEWPOOL

no access-list 101
access-list 101 permit ip 10.1.19.0 255.255.255.0 172.16.20.0 255.255.255.0
nat (inside) 0 access-list 101

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17111323
>Cisco VPN 3.5 client
HIGHLY suggest upgrading to latest 4.8 VPN client to work with XP/SP2 and all the latest MS updates
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17111335
>I am also trying to route port 443 to our mail server(10.1.19.5) for OWA

Just add new acl entries for it:
access-list outside_in permit tcp any host 206.***.***.*** eq http
access-list outside_in permit tcp any host 206.***.***.*** eq https

and re-apply the acl to the interface
 access-group outside_in in interface outside

0
 

Author Comment

by:ditobot
ID: 17111716
That did the trick,

Thanks lmoore
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Join & Write a Comment

I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now