Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 322
  • Last Modified:

FreeBSD 6.0 restore issues

I backed up my hard drive with the following commands to my second hard drive mounted as /backup (/dev/ad1s1d):

dump -0 -a -L -f /backup/root.dump /
dump -0 -a -L -f /backup/var.dump /var
dump -0 -a -L -f /backup/usr.dump /usr

Then I attempted to restore my system using these dump files by booting off of the CD, redoing the partitions, and running "fixit." In fix it I ran the following commands:

mount /dev/ad1s1d /tmp
cd /mnt
restore -r -f /tmp/root.dump
cd /mnt/var
restore -r -f /tmp/var.dump
cd /mnt/usr
restore -r -f /tmp/usr.dump

But for each restore I got an error like this,
for root.dump it was:

expected next file 16454, got 578

var.dump showed:

expected next file 23566, got 5

usr.dump gave the error:

expected next file 359, got 356

I am using virtual machines and had a backup of this machine that contained the same dump files and ran the restore on it as well. I came up with the exact same errors that contained the same numbers as well. Is there something wrong with the restore? When I restart the computer it runs fine and everything seems to be restore. The only difference I notice is that the /tmp permissions have changed and that there is now a file called "restoresymtable" that is . I am worried that these errors may have caused loss of information that won't be detected until later. I am a novice and would greatly appreciate a down to earth explanation on what is going on and any step-by-step way to fix the problem if it needs to be fixed.

Thanks,
Jerry
0
jerrykobes
Asked:
jerrykobes
  • 3
  • 2
1 Solution
 
TeRReFCommented:
From the restore man page:

- expected next file , got
          A file that was not listed in the directory showed up.  This can
          occur when using a dump tape created on an active file system.
0
 
jerrykobesAuthor Commented:
Shouldn't the "-L" on "dump -0 -a -L -f /backup/root.dump /" fix that problem?
0
 
TeRReFCommented:
Yes, but only if you created a .snap dir in the root of the filesystem BEFORE the dump as root.
If not, the -L option is ignored. Did you create that dir?
0
 
jerrykobesAuthor Commented:
Nope, I didn't. Is there anything special I have to type when creating the .snap directory? Or is the command just "mkdir .snap"?
0
 
TeRReFCommented:
Well, follow these steps (as root):
cd /
mkdir .snap
chown root:operator
chmod 770

That should do it. But like I said, unfortunately, it should have been done before the dump...

Don't get me wrong, things might just work fine in your current situation since you said that things are working, but I cannot guarantee it.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now