How do I change the language?


I hope I don't get flamed in here for this... but... I am a Windows XP user... and a beginner Linux user.

I have just started renting a dedicated server to run a website, however when I SSH to it it's all in German... is there any way to change the language?

As far as I can tell it is SUSE... but don't know anymore than that

Thanks for your help
Who is Participating?
DonConsolioConnect With a Mentor Commented:
read "Suse 9: Shell initialization" for more infos:

SUSE is not really my subject , but .....

Have a look in your home directory for file


look for a section [Locale]

if you find you have:

  - Country=de
  - Language=de

try changing them to 'en' or even 'us'

log out and back in - see what happens

antumAuthor Commented:
Is that just for the GUI environment?

I need something for the command line... all the messages I get are in German
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

ppfoongConnect With a Mentor Commented:

Look into /etc/profile, change this:


to this:


Also, look into /etc/rc.config, change the LANGUAGE to:


antumAuthor Commented:

I had a look into that file and it said I should be making changes in the profile.local but that file doesn't exist... should I create it and put your code in there?

DonConsolioConnect With a Mentor Commented:
From my /etc/profile:

# PLEASE DO NOT CHANGE /etc/profile. There are chances that your changes
# will be lost during system upgrades. Instead use /etc/profile.local for
# your local settings, favourite global aliases, VISUAL and EDITOR
# variables, etc .

simply create "/etc/profile.local" with vi or your fav. editor and write your settings there

to create user specific settings use ~/.bash_profile,  ~/.bash_login,  or ~/.profile.
antumAuthor Commented:

I ended up finding a document on the SUSE site that tells you to create a .bash_profile in the root/ directory and type in

export LANG=

I used en_US.utf8 and it seems to be working fine now.. .and to get the changes to take effect straight away I type source .bash_profile.

Thanks for all your help
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.