Remote desktop hanging after login when using RDP to connect to another XP machine

I set it up so that my client could work from her home computer (Sony Vaio running xp home, sp2) using remote desktop to connect to her work (Dell optiplex with xp pro sp2) computer. When she tries to connect she can login but after that she cannot click on anything and eventually that red x icon shows up in the top right corner indicating that the connection is lost. Usually though, the connection stays active and sometimes after a few minutes I can start clicking on icons. The computer can connect to any other machine with no issues, and any other machine can connect to the work PC. Both locations are using a broadband connection and I can do a persistent ping at the same time without losing one packet.

I tried connecting from my own network and still the same problem. It worked fine in safe mode so I disabled antivirus, windows firewall, and everything else I could find in startup but no luck. Finally I decided to format the client machine with a fresh copy of XP and the problem is still there. I switched the nic card, upgraded bios, tried different resolutions and video drivers but this problem will not go away.

This is one of the wierdest problems I have ever troubleshooted. and can't find anything wrong in either computers event viewer. I think I have eliminated software by formatting machine.

Just wondering if by chance anyone has run into anything like this?
Who is Participating?
MereteConnect With a Mentor Commented:
I think your problem is the fact its windowsxp home
Her Del is xp pro.
Home Edition does not support Remote Desktop
best solution is to upgrade the xp home to xp pro that will solve it.

Differences between the XP Home and Professional Edition !

Set Up Remote Desktop Web Connection with Windows XP

Windows XP Pro Remote Desktop
configuration, use and troubleshooting help and tips
On work PC, do you have any VPN client OR software firewall installed, if so, try removing it.
you can remote THAT WIERD PC from WORK fine -> no problems with the WIERD.
you can remote other computers from home -> no problems with the broadband.
I suggest : first, use your home computer to remote any other machine (call m1) in the office. After, from m1 (remote session), try to remote the WIERD. If okay ( I guest it would be okay), there's some problem with the MODEM/firewall forwarding rule to the WIERD -> On the modem/firewall, try to delete the rule to the WIERD, change the IP of the WIERD, and recreate the rule map to the new IP.
You could change the default listening port of Remotedesktop(3389) in WIERD to other value and test. See Windows help.
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

hindsightAuthor Commented:
I have already tested using ports 3391 3390 3392 3393. No effect. I was assuming it could be the NC card on the work machine, but if that were true I would have the same problem when remoting into it from other PCs. I may try formatting the work machine but if that don't work I'm not sure what else to try other than using PCanywhere ir something
hindsightAuthor Commented:
I actually found a crazy fix

I decided to run etherreal to see what is happening when remote desktop freezes.
All the packets destined for the remote machine on port 3389 are showing as black indicating a problem.

 It turns out for some reason that the packets have the "do not fragment" bit set and the remote office is using dsl with an MTU size of 1492 for whatever reason.

Even though I tried different NIC cards on the client machine it didnt matter. I did a registry fix to limit both workstations mtu size to 1492 and everything started working.

I have no Idea why no other machines had an issue using rdp to get to the same machine but I'm just glad its working.

Merete I will give you credit for the helpful links
cool well done yourself. Thanks for the feedback too.
Cheers Merete
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.