Solved

remote dektop

Posted on 2006-07-15
18
955 Views
Last Modified: 2013-11-21



  Hi experts

 got a small problem if u can solve it for me .

 I have a network of 3 computers and on one of the computers i want to access it remotely from the web
using the port 5800 from the browser of the any computer outside the intranet. I have installed VPN tight on one of the machines which i want to acess.i have taken the static ip adress from the broadband  internet service provider and the
static ip adress they say is activated.

i am using the router dick smith  model DSE-XH1169 and i can aceess the router using the adress
deafult gateway http://192.168.1.2  and can go into it using admin. when i install the vpn it shows the ip adress that is there when i take  the mouse over the vpn icon at the tool bar as 192.168.1.5 which is the internal network ip adress of the computer.
i am not able to acess the computer from outside as the vpn is not showing the  static ip adress .

now guys can u tell me what all settings in the router i need to change so the vpn can point to the static ip adress
and i can aceess the computer remotly.
i am not intrested in the windows remote desktop.

thanks

Ayoub


 

0
Comment
Question by:rauf_pats
  • 7
  • 7
  • 2
  • +1
18 Comments
 
LVL 30

Expert Comment

by:ded9
ID: 17114217
You can try this software

www.hamachi.cc


Ded9
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 250 total points
ID: 17114748
If you simply want to forward port 5800 to a particular computer, the following instructions should be quite similar to your unit:
http://www.portforward.com/english/routers/port_forwarding/DSE-DickSmithElec/XH1169-REL10v2/VNC.htm

However, your description is a little confusing. You mention VPN Tight and port 5800. Do you  mean Tight VNC which uses port 5800 ? If using port forwarding and VNC and you wanted to connect using a browser you would enter http://<external static IP>:5800  such as  http://66.66.123.123:5800

You do also mention VPN a couple of times, but there is no port forwarding required with a VPN. If you connect to a computer using a VPN all ports are open and all services are available using the local IP of the computer/s to which you have connected. Over the VPN if you want to connect to a computer using a browser you would enter http://192.168.1.5:5800

Perhaps you could better explain your configuration.
0
 
LVL 17

Expert Comment

by:jasonsbytes
ID: 17118054
Go to your port forwarding section of the router...

Input the external port you want to forward and the internal port to forward too and also the internal IP of your computer that it should forward to.
0
 

Author Comment

by:rauf_pats
ID: 17120707

hi jason

 can you explain what you mean by internal port and external port and the internal ip.i need to forward only one port 5800 .am thinking either to change the router may be it is old or else can i use any software which can automaticaly forward ports .
 did try this link also .but still cant work wid vpn .
 http://www.portforward.com/english/routers/port_forwarding/DSE-DickSmithElec/XH1169-REL10v2/VNC.htm


Ayoub
0
 
LVL 30

Expert Comment

by:ded9
ID: 17121424
Check windows firewall allow ports.

Also check device manager if there is any conflict

Ded9
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17121946
>>"did try this link also .but still cant work wid vpn "
rauf_pats, are you using a VPN? If so you do not need to do any port forwarding. The advantage of a VPN is there is no port forwarding required.
You would connect using the local IP of the computer, not the public IP such as: http://192.168.1.5:5800

However, if there are any software firewalls such as the Windows firewall, ZoneAlarm, McAfee, Symantec, etc. they should be disabled for testing as they will not allow access on the machine to which you are connecting.
--Rob
0
 
LVL 17

Expert Comment

by:jasonsbytes
ID: 17122127
You may not have internal and external port options...

Look for something on your router that lets you specify a PORT and an IP address.  I would assume this is your port forwarding.  What it is doing is opening that port on the router to the internet.

When the router gets a request on that port, it forwards the request to the IP of the machine you have set up.

You should have a web interface or maybe telnet interface into your router to do this.  Try connectiong to http://192.168.1.1/  (just a guess).

0
 

Author Comment

by:rauf_pats
ID: 17143394




Hi Rob

 I have brought new router that is Dynalink RTA1335 and have done all what is here at the link
http://www.portforward.com/english/routers/port_forwarding/Dynalink/RTA1320/VNC.htm  for this router .

i mentioned my staic adress where it says forward to internal Host IP adress <203.89.165.11>
and my computer internal ip is <192.68.1.4 >

it still dosnt work .i have opend both TCP and UDP ports and also have given the these ports for the port triggering link as well .but still when i go to browser and give adress http:203.89.165.11:5800 i still cant acess the port .
i have forwarded all three ports 5500,5800,5900

i was checking wid the firewalls .windows firewall was there but then i put kerio firwall and i have given kerio permission for the static ip adress .even when i shut down the firewall .i cant access this computer remptly using
the http://203.89.165.11:5800

how ever at all times i can acess the browser on this computer using the internal ip adress of machine that
192.168.1.4:5800  but for acessing this computer remotly from other computers which are not in the local network i need to go for this link http://203.89.165.11:5800 which i cant acess  from any computer .

 what do u suggest here .where do u think i am making mistake

waiting for ur reply .

Ayoub
 
0
 

Author Comment

by:rauf_pats
ID: 17143404


i havent done one thing which i didnt get which is there at the last of the page on the link

You should see another page of settings that need to be entered into one of the blank lines on your routers Add New Port Forwarding Rule page. Go ahead and enter those settings and then click Apply.

And that is it! You are done!
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 77

Expert Comment

by:Rob Williams
ID: 17151354
-Where it says "forward to internal Host IP address " did you use the local IP 192.168.1.4 ? you should have.
-You don't need to use, and shouldn't, port triggering for this
-Have you tried using the VNC viewer, rather than a web browser? Should only need the WAN IP (203.89.165.11:5800) in the viewer
-Try connecting from the PC (192.168.1.4) to  http://www.cayouseeme.org  and testing for the appropriate ports, to see if they are open and traffic is being forwarded. By the way listens on the port number + the display number. So if the application is set with a display number of '0' it would be 5800/5900, but if display number is 2 then it would be 5802/5902
--Rob
0
 

Author Comment

by:rauf_pats
ID: 17151492


Thanx for ur reply .
i used static ip adress not local ie 203.89.165.11 .anyway i will change it today to the local ip adress.
and then let u know what happens .when i try connecting from browser using 192.168.1.4:5800 i am getting connected .

Ayoub
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17151504
>>" i will change it today to the local ip adress."
Yes because you are forwarding to the "inside".

>>"when i try connecting from browser using 192.168.1.4:5800 i am getting connected "
Is this when you are at a remote site or on the same LAN as the computer you are connecting to. It shouldn't work if you are off site.
Also if you are trying to connect to the public IP address http:203.89.165.11:5800 from the same site, it will not work. You have to be on the "outside" of the router.

Let us know how it goes

0
 

Author Comment

by:rauf_pats
ID: 17151918


whenm i am at the same computer on the lan .it doesnt work outside the lan.

0
 

Author Comment

by:rauf_pats
ID: 17159758

hi Rob

today i had a networking guy to check for the router settings and he said i need to upgrade the windows home to
windows xp professional becos IIS service should be there which is  not in XP home and he told me then you dont need to do anything in the router becos u have static ip given by internet service provider.what u have to say.shall i upgrade the xp home edition.

Ayoub
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17159974
If you wish to use Windows built-in Remote Desktop you need to upgrade to XP pro, however VNC does not require you update at all. VNC will work on Win95/98/ME/2K/XPhome/XPpro and even Linux. Remote desktop, if you are not using a VPN, is more secure and is easier to use, and has better performance, so it does have advantages. As a note it uses port 3389, but again requires forwarding on the router.

Could you confirm the following:
Are you using a VPN ? If so how is the VPN created (hardware, software?)
Did you test as suggested with http://www.canyouseeme.com as suggested above?
Which version of VNC are you using, RealVNC, TightVNC, UltraVNC, or another.

Another option you may wish to consider is Log Me In. They after a free version that allows secure remote connections to your computer, that requires no port forwarding.

--Rob
0
 

Author Comment

by:rauf_pats
ID: 17172950


 Hi  Rob

 Thanks for your support i have forwarded the ports on the router and now it is working .i can access it from outside the network using the browser .and should be giving you the ponits .
just one last thing .I cant access it from my computer outside the network .i am having ie 6 and optima and netscape
and some times i can access on netscape but otherwise i cant access even after i turned off the firewall also .can you tell me what can be the reason with my browser .
also on some computers if the java run time is not there .it should promt for the java runtime which it is not on some computers with xp operating system .can you tell what can be the reason .

regards

Ayoub
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17173036
In order to connect using a browser you must use  http:203.89.165.11:5800 (or the correct port number) and Java must be installed and enabled. You can verify if enabled in IE6 by going to: on the menu bar; tools, Internet options, advanced
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17183967
Thanks rauf_pats,
--Rob
0

Featured Post

Shouldn't all users have the same email signature?

You wouldn't let your users design their own business cards, would you? So, why do you let them design their own email signatures? Think of the damage they could be doing to your brand reputation! Choose the easy way to manage set up and add email signatures for all users.

Join & Write a Comment

Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now