TrueCrypt Installation Problem

I am trying to install TrueCrypt and get the following message:

Installation of 'C:\Program Files\TrueCrypt\TrueCrypt.exe' has failed.
The system cannot find the path specified.

I am running WinXP SP2 with F-Secure.
I have 2 SATA 76gb drives is a Raid0 config.
The processor is AMD 64 3500.

Has anyone else come across this?

Thanks in advance.
Cepolly
LVL 1
cepollyAsked:
Who is Participating?
 
kleinfelterkConnect With a Mentor Commented:
Here are a few ideas:
1. If one *runs* TrueCrypt.exe and it can't find the truecrypt.sys driver, you get a dialog box with "TrueCrypt" as the title and the message "The system cannot find the path specified."  Have you looked to see if it created C:\Program Files\TrueCrypt?  Perhaps it only 'thinks' it failed.
2. If one *runs* TrueCrypt from a virtual drive (e.g. one created by the SUBST command), TrueCrypt doesn't locate the truecrypt.sys driver and it gives the same message as above.  Are you running the setup from a real, local drive and installing to a real, local drive?
3.  You don't actually have to install TrueCrypt via "TrueCrypt Setup.exe" in order to use it.  When you unzipped the ZIP archive to get the setup program, it created a subdirectory named "Setup Files". Copy the contents of this directory to any folder on a real drive.  Then run TrueCrypt.exe from that folder. It works just fine, so long as your Windows account is in the Administrator group.
0
 
sphinx000514Connect With a Mentor Commented:
i use truecrypt....and i have not come across this.  The first thing that i would try, is creating the directory yourself.  usually, installers do that...but if it cannot find that directory and cannot make it itself, try making it manually.  make the folder C:\Program Files\TrueCrypt\ and then try running the installer again.

Let me know if that works
0
 
cepollyAuthor Commented:
Yeah that was the 1st thing I tried.

I am wondering if it is due to the sata RAID 0.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
TolomirAdministratorCommented:
Take a look at http://www.sysinternals.com/utilities/filemon.html

It can tell you precisely what went wrong:

FileMon monitors and displays file system activity on a system in real-time. Its advanced capabilities make it a powerful tool for exploring the way Windows works, seeing how applications use the files and DLLs, or tracking down problems in system or application file configurations. Filemon's timestamping feature will show you precisely when every open, read, write or delete, happens, and its status column tells you the outcome. FileMon is so easy to use that you'll be an expert within minutes. It begins monitoring when you start it, and its output window can be saved to a file for off-line viewing. It has full search capability, and if you find that you're getting information overload, simply set up one or more filters.

Tolomir

0
 
cepollyAuthor Commented:
Lol that sounded like an advertisement.

Then I went to the site and confirmed. It IS an advertisement.

I don't think sysmon will help here, but I will check it out and let you know.

I think I still have sysmon somewhere on my server.
0
 
cepollyAuthor Commented:
Ok I tried filemon and it showed everything and I was hopefule that it was F-Secure. But I uninstalled F-Secure in hopes of that. But it still will not install.
0
 
Phil_AgcaoiliCommented:
I have not seen this either.
This may be a dumb question, but are you running the most current version for Windows?

I believe that you may be right that the problem is somewhere between the SATA drives and/or Raid.

0
 
cepollyAuthor Commented:
Yes Win XP SP2
0
 
Phil_AgcaoiliCommented:
For TrueCrypt? 4.2a?

I have it loaded on a system with Raid and no issue installing it for me.
0
 
cepollyAuthor Commented:
I know it's weird. It just won't install.

I did not reboot after the f-secure uninstall. let me try that.
0
 
cepollyAuthor Commented:
tried the reboot and still no go.
0
 
TolomirAdministratorCommented:
Well of cause this was a fast c&p from their website, still filemon is a great tool to monitor such problems.

Another tool is regmon, http://www.sysinternals.com/Utilities/Regmon.html 

Maybe you got an registry issue.

Tolomir
0
 
callitConnect With a Mentor Commented:
You've probably already tried these things, but I'll mention them anyway -
-Are you running the install as an administrator?
-Are you sure you've got a good copy of truecrypt?  Have you tried downloading it again? http://www.truecrypt.org/downloads.php
-Have you tried changing the installation location?
-Have you tried running the TrueCrypt.exe file from the setup files folder included in the download?  If that works, you may not need to do a complete install.
0
 
KZ06M1Connect With a Mentor Commented:
Remove the folder created by the setup program ("TrueCrypt" folder under C:\Program Files\ by default) and create the folder manually.  Run the setup program again.  Worked for me.

HTH,

Scott
0
 
cepollyAuthor Commented:
Callit, thanks but I have tried all of those options.

Kz06m1, tried it and no go.

0
 
cepollyAuthor Commented:
Kleinfeltrek,

I think we are starting to get somewhere.

1 and 2 don't apply as they are not the issue.

However, #3 shows promise.

I ran TrueCrypt.exe from the sub-folder "Setup Files" and here are the errors I received.:

Error #1:

"The service already exists."

I click ok and then get:

"Unable to connect to the TrueCrypt device driver. TrueCrypt cannot work if the device driver is not running."

That's as far as I get.

Thanks.

0
 
cepollyAuthor Commented:
Woot!

It is fixed.

Here is the fix:

I created a sub-folder under Program Files called "TrueCrypt".

I unzipped the "truecrypt-4.2a.zip" so that only the files "readme.txt", "TrueCrypt Setup.exe" and the sub-folder "Setup Files" are in "C:\Program Files\TrueCrypt".

I ran "TrueCrypt Setup.exe" and it worked.

The key is to have the "Setup Files" folder in the "C:\Program Files\TrueCrypt" folder with the "TrueCrypt Setup.exe" and then run the setup if you are facing my particular issue.
0
 
cepollyAuthor Commented:
I split the points because everyone gave me places to look.

Thanks again.
0
 
brentbordelonCommented:
I started recently having the same problems.  I run TrueCrypt in "travelling mode", from a flash drive.  It worked fine, then started giving me the same errors mentioned above:

"Unable to connect to the TrueCrypt device driver. TrueCrypt cannot work if the device driver is not running."

I reformatted the flash card, re-downloaded, etc.  Nothing worked.

What DID finally work was to copy all the files that were in the TrueCrypt folder of my Flash drive to the Root of my flash drive.

This leads me to believe that it's a permissions thing that's recently changed somewhere.

If it is permissions related, the first answer of using filemon probably would have resulted in a fix.  Filemon is a util that's been around a long time and can uncover file permission problems on NTFS systems very well - It's saved my butt many times.  And no, this isn't an ad for a product (filemon is and always has been free, anyway)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.