• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 448
  • Last Modified:

How can I use a Wireless Router where I have a Cable Modem attached by USB to a PC?

I have Cox Cable
I have a Cable Modem connected by USB to a desktop.
I have an open NIC on the desktop.
I have a Wireless Router I would like to hook up so a notebook can be used downstairs.

Which direction should I or can I go (keeping the modem as a USB connection).
0
jimmysupport
Asked:
jimmysupport
1 Solution
 
Rick HobbsRETIREDCommented:
If the modem has an ethernet port, connect that port to the wireless routers WAN port.  If the modem can handle both connections at once, you should then be able to connect to it through a wireless connection.
0
 
grsteedCommented:
You could set up ICS (Internet Connection Sharing) since you already have a NIC available.

Here's a few links that tell you how.

http://www.microsoft.com/windowsxp/using/networking/expert/crawford_02july01.mspx
http://www.homenethelp.com/ics/ics-install-netxp.asp
http://www.homenethelp.com/ics/ics-install-sxp.asp  (for XP)

Cheers,

Gary
0
 
Rob WilliamsCommented:
Hi Jimmy, it is a bit "messy" but you can do it.
You enable ICS (Internet Connection Sharing) on the PC, and then use the router as an access point rather than a router, keeping in mind the PC must be on at all times.
Similar to second diagram in the following:
http://www.homenethelp.com/ics/ics-install-arch.asp

To enable ICS you can follow the wizard in the help files in XP, have a look at the following site below, complete with video, or, simply right click on the USB connection in control panel / network connections, choose advanced, and enable ICS. It will configure it's own DHCP server, NAT (Network address translation) functions, and set the available NIC to 192.168.0.1  If you have a 3rd adapter you might want to disable while doing this. More than 2 adapters sometimes confuses ICS during the set up.
http://support.microsoft.com/default.aspx?scid=kb;en-us;306126&sd=tech

Then on the router:
-do not configure the WAN section, leave at factory defaults
-on the LAN page assign the router an IP in the same subnet as the 2nd NIC on the PC. Make sure it doesn't conflict with the PC's DHCP range by assigning the router something like 192.168.0.254
-disable DHCP on the router
-configure the wireless settings on the router as normal
-connect the NIC on the PC to a LAN (not WAN) port of the router and you should be done.

Now all users should be in the same subnet, get a DHCP address from the PC, and connect to the Internet through the router and PC.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Rick HobbsRETIREDCommented:
Another option would be to enable Internet Connction Sharing on the desktop and connect the wireless routers WAN port with a crossover cable to the NIC in the desktop.  You should then also be able to connect through wireless.  You might have to, initially, connect the laptop to the Wireless with a cable to check the settings and set it up for some type of security (WEP, WAP, MAC filtering, whatever).  This step would also be be necessary on my initial post.
0
 
Rick HobbsRETIREDCommented:
Great minds stink alike?
0
 
Robin888Commented:
Hi Jimmy,

Connect the modem to your wireless router is the best way. If your modem does not support Ethernet connection, request your cable company for a new modem. Couple reasons:
Simplicity; set up modem to wireless router once only, notebook will work via wireless, desktop will work via your Ethernet cable.
Less bottleneck/better data speed; both notebook and computer data comes directly from your wireless router
Hardware firewall; hardware(router) firewall is much easier to manage and do not use software(computer) resources

ICS would be my last option.
R


0
 
jimmysupportAuthor Commented:
ics WORKED LIKE A CHARM
0
 
grsteedCommented:
Thanks Jimmy,  Glad I could help.

Gary
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now