Solved

Reading EXT3 formatted drives in Windows XP

Posted on 2006-07-16
15
10,692 Views
Last Modified: 2012-08-14
My Linksys NSLU2 recently died and I currently do not have a Linux box... uggh need help. :-\

So far I have tried two different programs:

Explorer2fs (1.07) - Reads the volume but only allows me to copy files one at a time. It cannot delete or move whole folders.

Ext2IFS_1_10b - From the description, this program seemed very promising. Unfortunately it will not mount the drive. Instead, I see a "not formated" warning.

Mount diag displays the following:
The volume has an Ext2/Ext3 file system, but the Ext2 IFS 1.10 software did not
mount it because there is at least one incompat feature flag set. The Ext2
IFS software does not implement:
* needs_recovery *
Here we have an Ext3 file system which has transactions left in its journal. A
pure Ext2 driver must not access such a volume which is in that state (to
prevent data loss!).
You may solve it by mounting it on Linux (which has a kernel with Ext3
support). Be sure that you cleanly dismount it, before you shutdown Linux.
After that the Ext2 IFS software should be able to access the volume.

Well that isn't too helpful. LOL

Any suggestions other than just be happy I can read the files with Explorer2fs?

BTW, I would be happy just to have the ability to copy whole folders (and never mind deleting).

Thank you,
Shawn
0
Comment
Question by:sconnell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
15 Comments
 
LVL 22

Expert Comment

by:pjedmond
ID: 17118205
Although perhaps not an ideal approach, you could use a Live Linux CD such as Knoppix:

http://www.knoppix.org/

Version 5.0.1 enables you to write to NTFS partitions....or if you prefer a different Live CD.

http://www.frozentech.com/content/livecd.php

This will enable you to boot into Linux without installing anything onto you hard drive - It all runs from your CD. Although there are performance penalties doing this, it would enable you to copy your files en mass to a FAT32/USB stick all at once. You can then work with the files in your Windows environment.

(   (()
(`-' _\
 ''  ''

0
 
LVL 4

Author Comment

by:sconnell
ID: 17118233
Thanks, I thought of a similar approach using VMWARE and one of those Linux boot disks like Knoppix.

Perhaps I can at least correct the journalling problem so that Ext2IFS_1_10b will mount?

If I can get Ext2IFS_1_10b to work than my problems are solved.

0
 
LVL 22

Expert Comment

by:pjedmond
ID: 17118243
VMWARE won't help as you are working with an isolated file system which is 'ring-fenced' from the outside world.

Any of a fairly large range of the live CDs should be able to correct the journalling issue.

(   (()
(`-' _\
 ''  ''
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 4

Author Comment

by:sconnell
ID: 17119506
I ran live Knoppix but it I had a lot of trouble with the 'jerky' motion. The software was continuously pausing for brief periods making typing and mouse positioning very difficult. The GUI looked great however. :-)  I wonder what the problem is? I have 512MB of memory and plenty of CPU power.

Anyhow, I discovered that my DLINK DSM-G600 will read/write the drive.... except there are some folders that only have directory access! There is no particular reason why some folders seem protected yet others are fine. I originally set both the DLINK and the LINKSYS with the same permissions.

Even more mysterious, the folders/files with directory access *only* can be moved anywhere within the volume, renamed, or even deleted. I just cannot copy nor read the files. Changing permissions within Windows XP Pro or from the DLINK seems to have no affect.

Any thoughts on how I can fix this problem?

Upping the ante.... more points for a workable answer (short of getting the Linksys working again).  
0
 
LVL 1

Expert Comment

by:antoxa
ID: 17120140
You could use Total Commander http://www.ghisler.com/download.htm and Ext2+Reiser plugin Main->Addons->Plugins->File system extensions (plugins)->Ext2+Reiser (http://ghisler.fileburst.com/fsplugins/ex2fs.zip)
For security reasons, this plugin is read-only.
This plugin support Ext3 too, because Ext3 is the same Ext2+logging, but in reading mode logging don't used.

WBR
0
 
LVL 22

Expert Comment

by:pjedmond
ID: 17120554
Knoppix can be jerky, because it often has to read the necessary data from the CD drive, which is not the fastest of devices! I've customised a version to remove most of the 'nice gui' stuff and make it perform instead. It makes a significant difference!

As root, you should have access to the whole file system without restrictions. Worth looking at some of the the extended ext2 functionality, and whether it is involved:

lsattr /dir/file
chattr /dir/file

Use man to get further information about these extended attributes.

(   (()
(`-' _\
 ''  ''

 
0
 
LVL 4

Expert Comment

by:bobgunzel
ID: 17120635
0
 
LVL 40

Accepted Solution

by:
noci earned 200 total points
ID: 17121609
Can this help you?

It should be possible to read & write in the lates version.

http://sourceforge.net/projects/ext2fsd
0
 
LVL 88

Expert Comment

by:rindi
ID: 17121732
Look in the knoppix menu, utilities, "Harddisk/CD/DVD DMA Acceleration", there you can make sure the drives are running in DMA mode and not PIO mode. This should make it run faster and it could get rid of the jerkiness.
0
 
LVL 4

Author Comment

by:sconnell
ID: 17122244
Nope. Did that. :-(
0
 
LVL 4

Author Comment

by:sconnell
ID: 17654118
Actually Venabili,

I guess I lost track of this question.

I don';t believe I ever tried  noci's suggestion (on 07/17/2006 07:56AM CDT)

It turns out that the latest edition to ext2fsd (http://sourceforge.net/projects/ext2fsd) is dated, 01-Jun-2006.

I will try this update in the evening.
0
 
LVL 20

Expert Comment

by:Venabili
ID: 17697936
Any update here?
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question