Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

XPPro Home network connectivity issues

Posted on 2006-07-16
4
Medium Priority
?
220 Views
Last Modified: 2010-03-18
So what am I missing?

I have 2 x XP Pro boxes fully patched with onboard lan connected to a linksys gateway router for broadband. The router provides the lan addresses via DHCP.

Box 1 - "mine" and box 2 "hers" are both in the "home" workgroup and are both in the same address range with the same subnet mask. Windows firewall enablesd on both with SAV Corporate AV on both.

Both boxes happily connect to the internet and can print to a usb printer via a lindy autoswitch..

The system drive (c:) and a data drive (d:) on both boxes are shared and file & printer sharing is enabled on both. ICS not enabled.

"mine" can ping "hers" and can see c: & d: on "hers" via mappings that were made some while ago. On "mine" I can still map any folder on "hers" either by machine name or ip address. "mine" can ping the router.

My Network Places>Entire Network>Microsoft Windows Network on "mine" brings up the "home" workgroup, but clicking that only shows "mine" not "hers".


On "hers" I cannot ping "mine" and cannot see c: & d: on "mine" and cannot map any shares either by machine name or ip address. "hers" can ping the router.

The "home" workgroup on hers shows both "mine" and "hers" but cannot access "mine", getting the usual "not found on the network" error.  Obtaining the workgroup listing is very slow.

I have tried searching for and setting all permissions to allow full access to everybody but still cannot get the 2 boxes to fully communicate

As far as I know the 2 nics are configured the same.

Don't know where to go from here, but it's driving me mad.

Christopher
0
Comment
Question by:chrisatwork
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 17118472
Here's a bunch of things to check. Sounds like a user issue (identical username/passwords on both boxes?), or some type of firewall on "mine"

First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, PC-cillin (yes, some AV products have built-in firewall), VPN client (Raptor Mobile, Cisco VPN), et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP (Pro only) machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
For complete explanation, see here:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;304040

----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP

   Click Start, click Control Panel
   Click Network Connections.
   Right-click "Local Area Connection", and then click "Properties".
   Click on (highlight) "Internet Protocol (TCP/IP)", and then click "Properties" button
   Click the General tab, and then click "Advanced" button , bottom right.
   Click the WINS tab.
   Under "NetBIOS setting" section, click Enable NetBIOS over TCP/IP, and then click OK two times, the "close".
     ( ) Default
     (*) Enable NetBios
     ( ) Disable NetBios

   Reboot the computer.


Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.
--------------------------

Windows XP (at least PRO) defaults a setting in Local Security Settings to something very unhelpful.
If all this does not solve your problem, check Local Security Settings, Network access: Sharing and security model for local accounts.  This may be set to (default) Guest only - local users authenticate as Guest.  Change this to Classic: local users authenticate as themselves.

Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"

FOR HOME USERS ONLY WHEN ALL ELSE FAILS:
Look for and set these properties as shown also

Network access: Allow anonymous SID/Name translation     ==> Enabled
Network access: Do not allow anonymous enumeration of SAM accounts     ==> Disabled
Network access: Do not allow anonymous enumeration of SAM accounts and shares          ==> Disabled
Network access: Let Everyone permissions apply to anonymous users     ==>      Enabled

Now you may disable the Guest account as recommended for improved security (for the XP box).  Without this set properly nothing will work for XP!

--------------------------
There's a different Guest account setting that controls networked access to XP's shared disks and folders when simple file sharing is enabled.

To enable networked access, enter this line at a command prompt:

   net user guest /active:yes

To disable networked access, enter this line at a command prompt:

   net user guest /active:no
0
 

Author Comment

by:chrisatwork
ID: 17122536
Thanks for your help. Working through your comprehensive reply, so far I have managed to get both xp pro boxes to see each other on the network and I can map shares on both, BUT: the "hers" box cannot open a share on "mine" - the permissions aren't right allegedly.

In getting it partially going  the gpedit stuff did the trick, so i have now disabled the guest accounts on both, and re-enabled the windows firewalls.

I thought I had set folder permissions to allow everyone full access but I must be missing something still.

Could you give me some further pointers on this - we are getting there!

The only firewalls are the windows ones and one in the router to the outside and one in the cisco vpn client which cannot be turned off.

Christopher
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17126414
>one in the cisco vpn client which cannot be turned off.
Actually, it can....
Open the VPN client, Options
Is Stateful Firewall (always on) checked? - UN-check it.
*or*
Open Task Manager, and find Process - cvpnd.exe and kill it.... [ End Process  ]


0
 

Author Comment

by:chrisatwork
ID: 17128210
Solved! I fiddled around with permissions on Documents & Settings and now can see/do what I want.

I am certain now that a recent w/update is to blame, because at the same time as I lost the network connections part of my ftp stopped working (I couldn't get Lists from a couple of servers) It's now back, so I'm doubly happy.

The cisco vpn I'm using is v3.5.1 (E) and doesn't have a tick, but as itr appears to be ok I won't meddle with it, but thanks for the cvpnd.exe info, I shall file that...

Grade A with many thanks for a very complete diagnosis/solution.

Christopher
0

Featured Post

Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes you might need to configure routing based not only on destination IP address, but also on a combination of destination IP address (or hostname) and destination port number. I will describe a method how to accomplish this with free tools. …
We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question