Solved

RAID PROBLEM!  DELL PERC

Posted on 2006-07-17
13
2,502 Views
Last Modified: 2007-12-19
I have a dell precision workstation.  There is a RAID 5 array on a Dell PERC controller.  One drive failed, the crazy beeping started.  The system still booted into W2K just fine.  Replaced the failed drive with an IDENTICAL drive.

Went into the PERC webbios.  It said something to the effect of:

blah blah blah MISMATCH, load configuration from DISK or from NVRAM.

I selected DISK

Put new drive ONLINE

Restarted machine.

Boot failed.  

Realized my ARRAY had to be recreated, I did so....
Went back into webbios, did a REBUILD (Manual) on the new drive....

Restarted

Book failed!

I figured oh ok, maybe I need to do a FIXMBR and FIXBOOT, so I inserted my W2K CD, hit F6 to load additional SCSI drivers, before it got to the RECOVERY console, I got an error, no hard disk found.

PLEASE TELL ME I DIDNT LOOSE MY DATA!  I'm hoping there's just some small configuration piece I missed to say hey windows boot from this SCSI adapter, and this ARRAY.  

There's one ARRAY, 3 DISKS, Raid 5, W2K.  

Please help me!
0
Comment
Question by:TheBrothaULuv2H8
  • 4
  • 4
  • 2
  • +2
13 Comments
 
LVL 4

Expert Comment

by:starstruckgeezer
Comment Utility
Hi
    Is your system set to boot from the array in bios, worth checking as i had a system where it deafaulted back to the ide drive after the array went down.
0
 
LVL 11

Expert Comment

by:knoxzoo
Comment Utility
Did you initialize the new disk?
0
 
LVL 34

Expert Comment

by:jamietoner
Comment Utility
By recreated you dont mean you deleted and recreated the array right? when you told it to load the config from the disks did you check it to make sure it was showing the correct drive offline? If the disk config showed all 3 drives online including the new one(that was blank) and that config was saved its very likly the array is hosed and will need to be recreated and reintialized. what you may want to try is removing tyhe neww hdd and see if it will still boot to the other 2 hdds if it still wont boot to the hdds that where working there is a good chance you will be reinstalling the os and recovering the data from your backups.
0
 
LVL 3

Expert Comment

by:Robin888
Comment Utility
Did you try using the Server Assistant dell cd? Go to raid configuration, check if your container still exist.

Then try boot with windows cd, recovery console, fixboot and fixmbr, reboot and test it.

R
0
 
LVL 2

Author Comment

by:TheBrothaULuv2H8
Comment Utility
(starstruckgeezer)  I checked the BIOS because it also seemed to me the boot device wasn't set to the SCSI card, it says boot DRIVE C first, it doesn't say anothing about IDE or SCSI.

(knoxzoo) I did initialize the drives

(jamietoner)  I never deleted anything to be honest.  Once the new drive was installed, I got a prompt about something mismatch, restore from DISK or NVRAM.  I said restore from DISK.  Then there was no actual array anymore.  I had to recreate the array.  One option mentioned you would loose all data.  I choose the other option which was like re-create the array again or something.  I would think if I was going to loose data a nice notification would warn me before hand.  The only notice I saw was choosing this option to create the array would loose data, I didn't choose that option.

(Robin888)  I'm going to do that right now.  And if it does exist?  Then what....if it doesn't exist I can assume I'm fu**ked?  I already tried to boot with windows CD, recovery console after hitting f6 to load SCSI drivers, guess what....NO HDD DETECTED, or NO HDD INSTALLED.  

Which is  why I think it's more of a matter of telling the system where to look for the drives, I believe my data is still there somewhere.  I can't even install windows again (obvious by the fact that I cant even do a repair because it doesn't detect a disk at all).  

Any suggestions?

0
 
LVL 2

Author Comment

by:TheBrothaULuv2H8
Comment Utility
(robin888)  hmmmm...since it's not a server, there is no dell server assistant CD.  Any other suggestions?
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 3

Assisted Solution

by:Robin888
Robin888 earned 100 total points
Comment Utility
Use another os to detect and salvage remaining files. I would suggest using ubuntu linux, http://www.ubuntu.com/. burn it to cd and boot up from cd, locate the drive and copy it out to usb drive/jump drive or to another network computer through samba.

once in ubuntu, assuming it finds the drive, list out the file and copy it out mount -t ntfs /dev/hda1 /mnt/tempfolder, ls /mnt/tempfolder
0
 
LVL 4

Expert Comment

by:starstruckgeezer
Comment Utility
when you enter the controllers settings is the array set to bootable?
if not enable it then check motherboard bios to see if you can now select it
0
 
LVL 2

Author Comment

by:TheBrothaULuv2H8
Comment Utility
Oddly enough there's no option in the SCSI bios (PERC webbios) to make it bootable.  The Dell BIOS doesn't have a SCSI option either/still.  
0
 
LVL 4

Expert Comment

by:starstruckgeezer
Comment Utility
when you say you a rebuild do you mean you rebuilt the array configuration or do went on to the physical drive and told it to rebuild its data or both?

as you say there was no array so you redifened your array but after doing that did you tell your new drive to rebuild its data.
if you then do a Check Consistency on the drives and it should the redudant data on each drive correcting as it goes.

i belive there is a setting in there somewhere asking which logical drive to boot, being your array.
0
 
LVL 2

Author Comment

by:TheBrothaULuv2H8
Comment Utility
starstruck:  I highlighted the new drive and said rebuild.  Is that bad/wrong?  The array itself or "logical" config seemed to be missing, so I had 3 options, 2 of which said I would loose data, so I chose the 3rd which was recreate the array but it wouldn't loose my data (so it said).  Then I had my logical drive, and 3 drives back.  I forgot the order now since I've done so many things.  But I brought the disk ONLINE (the new one), still no boot, then did the REBUILD of the new drive.  No luck.
0
 
LVL 4

Assisted Solution

by:starstruckgeezer
starstruckgeezer earned 200 total points
Comment Utility
did you run a consistency check? think it is labeled as "chk cons" if you highlight array then run this.

think the option for booting is called force boot in adapter proerties but run the cocsisancy check first to check all the data matches.

was the option you selected when you redifened the array " add configuration"

on the logical drives screen you should be able to display properties of your logical drive , note the number as some where round there is "bootfrom logical driver number" field.
0
 
LVL 34

Accepted Solution

by:
jamietoner earned 200 total points
Comment Utility
From the sounds of it i would say the array is unrepairable, after re-read the desciption it sounds like after you loaded the config from the disk you forced the new drive online(instead of rebuilding) and if so as soon as you restarted and tryed to access(boot) to the array that would have irrevisably damaged the parity on the array. Even if thats not the case when you recreated the array if the new drive was online and you rebooted the same issue would occur. In any case if you force the drive that was offline in the begiing bacl offline and it still wont boot. The only way to recover data would be to send all 3 orginal hdds to a data recover center like drive savers to see if they could recover the data. If the data has been backed up then you'll need to delete the array, recreate it, reinialize, reinstall and restore the data from backup. Also in the future to prevent possible data loss in a situation like this (besidesd always having a backup), when your prompted with an nvram mismatch you can choose nvram or disk but dont save the changes untill after you veiw the array if the info is incorrect esc ape back do not save changes and try the other option, and usually if your replacing a drive the correct cofig is usually on the nvram.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Hello to users to the new age of computers. There are so many products to choose from nowadays that you maybe confused to understand which product is the correct product for you. Let me explain briefly what should be the idea product for your best n…
The Rasberry PI is a low cost piece of hardware that you can have a lot of fun with through experimenting and building/working on projects like media players, running a low cost computer, build data loggers etc. - see: https://www.raspberrypi.org
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now