Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

OWA issues since Windows 2003 Server upgrade

Posted on 2006-07-17
3
Medium Priority
?
173 Views
Last Modified: 2010-04-18
Ever since upgrading the server from Win2K Server to Win2003 SP1, Outlook Web Access is acting strange (EX2003 was already installed and has been running fine for years.)

When a user tries logging into OWA, the login prompt comes back and the "User name" field is filled in with the external server name as a prefix to the user id.  For example,

"mail2.domain.com\myusername"

Of course, the user keeps hitting OK and gets "access is denied" after 3 attempts.

The only workaround I've found is to have them enter their full email address for the user id, and this lets them in just fine.

It appears that the 2003 upgrade made some directory security modifications, but I haven't been able to figure this one out.

Thanks in advance.
0
Comment
Question by:Elmo_Oxygen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 6

Expert Comment

by:glennbrown2
ID: 17123978
go into IIS Manager....Start/Run type "inetmgr" and press enter.

Now, not sure how OWA is setup for you but mine is under the "default site", "exchange".

- Right click exchange and select properties
- Click directory security
- under "authentication and access control" clcik edit.
- in this window, i only have "integrated windows auth" and "basic auth" checked
- under default domain, I have our NETBIOS domain name...
- click ok

restart IIS and try again
0
 

Author Comment

by:Elmo_Oxygen
ID: 17124416

Yup, this is exactly how mine is configured too.

Interesting to note that a user informed me that FireFox gets them in without requiring the full email address for the user name.

0
 
LVL 104

Accepted Solution

by:
Sembee earned 1000 total points
ID: 17125108
The default behaviour for OWA on Exchange 2003 is that the login required is

domain\username

If you don't enter it in that format then the server automatically presumes that you are authenticating to the local machine, so prepends its name to the authentication process.

Two options.

1. Set the default domain and default realm on the /exchange virtual directory.
2. If you are using SSL (if not, why not) enable forms based authentication. There was an undocumented change in SP2 for Exchange 2003 where the domain\ is no longer required, despite what the page says.

Simon.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question