• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 652
  • Last Modified:

FTP server behind actiontec DSL modem and Linksys router running winXP

I have Qwest DSL service at a friends shop.  He is using a black actiontec DSL modem and a Linksys router.

On the DSL modem I have forwarded ports 21, 5000-5100 to 192.168.0.2 (the Linksys router)
On the Linksys router, I have forwarded ports 21, 5000-5100 to 192.168.2.5 (the FTP server)
I am running Blackmoon FTP Server on 192.168.2.5.
The IP address of the DSL router is 71.39.226.55.
Login: plans
pass: plans

I can FTP via CLI to the server fine.  It also works from an FTP client fine.  When I try to connect via IE it hangs and times out.  It appears to be having problems with the PASV functions.

Anyone have any suggestions?
0
zaph1
Asked:
zaph1
1 Solution
 
b0lsc0ttCommented:
zaph1,

Make sure that you have IE set to use Passive FTP.  Go to Internet Option (choose Tools at the top of IE or go to Control Panel to access Internet Options) and scroll down to the setting for Use Passive FTP.  Check the box to have IE use passive.  Does that fix the problem?

Let me know if you have any questions or need more information.

b0lsc0tt
0
 
zaph1Author Commented:
doesn't fix the problem, since it is a server side issue, not a client side issue.
0
 
zaph1Author Commented:
I can't convice my friend to have his customers use an FTP client either, he states they all use IE to connect.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
zaph1Author Commented:
convince, not convice.  Sorry.
0
 
Rick HobbsRETIREDCommented:
Try changing the modem to bridge mode if it support it and then enter your ADSL login info in the Linksys.  Then there will be only one nat and port translation involved and probably will solve the problem.
0
 
Robin888Commented:
hi zap,

Set dmz to the ftp server on linksys router, that should solve 50pct of the guessing.
If it works, linksys needs some tweeking.. if it still doesnt work, too many forwarding, we should try rick's suggestions.

R
0
 
zaph1Author Commented:
Well, I'm not sure about setting it to bridge mode.  I switched the modem to DMZ forwarding to the 192.168.0.2.  This hasn't seemed to help.  Rick, can you elaborate on switching to bridge mode?
0
 
Rick HobbsRETIREDCommented:
I can try.  What model DSL modem and what model and version Linksys?
0
 
zaph1Author Commented:
Actiontec GT701 and unsure on the linksys.  I can't look until Monday, so I will post then.
0
 
Rick HobbsRETIREDCommented:
Attach to the Actiontec through Internet explorer.  http://192.168.0.1
Click Setup/Configuration
Click Advanced Setup on left side
ClickBegin Advanced Configuration
Select WAN IP Address
Select Transparent Bridging
Click Next
Then you have to do the Linksys.  I need the Model # to help on it.
0
 
zaph1Author Commented:
Linksys BEFSR41 V2
0
 
Rick HobbsRETIREDCommented:
On page 45 of your manual, set up PPOE.   Start by opening IE.  Enter http://192.168.1.1 and hit enter.  If you haven't configured a password, leave the username field empty, enter admin in the password field. Select PPOE.  Enter your username and password for your DSL connection.  Click Apply to save your settings.  It should now be able to make the connection to your DSL provider.  
0
 
zaph1Author Commented:
Alright, that's done.  Can you see if you can login?
0
 
zaph1Author Commented:
My internet seems fine, but I can no longer log in to the Actiontec modem/gateway.  Is this normal?
0
 
Rick HobbsRETIREDCommented:
Yes.  It is now just a bridge.
0
 
Rick HobbsRETIREDCommented:
When I try to open 71.39.226.55 I get a login prompt.  Looks like you are in busines!!
0
 
Rick HobbsRETIREDCommented:
Your FTP works perfectly.  I just checked it out.
0
 
Rick HobbsRETIREDCommented:
Sorry about the comment spam, but I connected, downloaded a file, and uploaded a file using Internet Explorerv6.0.2900.2180.xpsp_sp2_gdr.050301-1519 after enterind 71.39.266.55 and the username and password you supplied.
0
 
zaph1Author Commented:
yep, seems to work for me, also.

Thanks for the help
0
 
Rick HobbsRETIREDCommented:
Glad to be of assistance.  Thanks!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now