Solved

trouble after upgrading Pix firewall software

Posted on 2006-07-17
12
288 Views
Last Modified: 2013-11-16
Hello,

I upgraded our Cisco Pix 506e firewall software from version 6.3.1 to 6.3.5 over the weekend.

After the upgrade, all of our non-Microsoft email clients were unable to send or receive email. After changing their POP and SMTP settings from MAIL.OUTDOMAINNAME.COM to x.x.x.x (our Exchange server's internal IP address), we were able to get and send mail.
However, now we cannot get to our web based outlook email (at least internally, i haven't checked it outside the LAN yet).

I checked the Exchange server, and everything looks OK.

So then I checked the Pix software, went to the Pix Device Manager 3.0, Options/ Show Commands Ignored by PDM on Firewall. & found this:

fixup protocol dns maximum-length 512
fixup protocol tftp 69
access-list 100 permit udp any host xx.xx.xx.xx eq www
access-list acl_outside permit tcp any host x.x.x.x eq https
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10

(where xx.xx.xx.xx = our MX record IP address
and
x.x.x.x = the internal IP address of our Exchange server)

Any help will be greatly appreciated!

Best Wishes,
Kristin
0
Comment
Question by:forcedexposure
12 Comments
 
LVL 32

Expert Comment

by:rsivanandan
Comment Utility
Posting the full configuration would help. Also while masking out, don't mask out the entire ip address (just hide the first 2 octets).

Cheers,
Rajesh
0
 

Author Comment

by:forcedexposure
Comment Utility
Having problems responding to this!

this is an EE test.
0
 

Author Comment

by:forcedexposure
Comment Utility
Hello Rajesh,

Here's our configuration:

Building configuration...
: Saved
0
 
LVL 32

Expert Comment

by:rsivanandan
Comment Utility
?? What does it mean ?

Cheers,
Rajesh
0
 

Author Comment

by:forcedexposure
Comment Utility
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname firewall
domain-name ourdomain.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
0
 

Author Comment

by:forcedexposure
Comment Utility
names
access-list 100 permit tcp any host x.x.196.66 eq telnet
access-list 100 permit tcp any host x.x.196.66 eq www
access-list 100 permit tcp any host x.x.196.66 eq https
access-list 100 permit tcp any host x.x.196.66 eq smtp
access-list 100 permit tcp any host x.x.196.66 eq ftp
access-list 100 permit udp any host x.x.196.66 eq 25
access-list 100 permit tcp any host x.x.196.66 eq pop3
access-list 100 permit tcp any host x.x.196.66 eq ident
access-list 100 permit udp any host x.x.196.66 eq 113
access-list 100 permit udp any host x.x.196.66 eq www
access-list inside_outbound_nat0_acl permit ip any x.x.1.16 255.255.255.240
access-list outside_cryptomap_dyn_20 permit ip any x.x.1.16 255.255.255.240
access-list acl_outside permit tcp any host x.x.1.5 eq https
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside x.x.196.67 255.255.255.0
ip address inside x.x.1.1 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool FEPool x.x.1.21-x.x.1.24
pdm location x.x.1.5 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) x.x.196.66 x.x.1.5 netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.196.65 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:forcedexposure
Comment Utility
http x.x.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup FEGroup address-pool FEPool
vpngroup FEGroup dns-server x.x.1.5 x.x.16.67
vpngroup FEGroup wins-server x.x.1.5
vpngroup FEGroup default-domain ourdomain.com
vpngroup FEGroup idle-time 1800
vpngroup FEGroup password *
telnet timeout 5
ssh timeout 5
management-access inside
console timeout 0
username x password x encrypted privilege 15
username x password x.x encrypted privilege 15
username x password x encrypted privilege 15
terminal width 80
Cryptochecksum:x
: end
[OK]

Thanks! Kristin
0
 

Author Comment

by:forcedexposure
Comment Utility
Sorry, Rajesh!
For some reason I couldn't post the entire configuration to EE.
I was getting a "Question Not Found" error message!

So I broke it up over several posts.


Apologies for the confusion.


: )   Kristin
0
 
LVL 9

Expert Comment

by:Pentrix2
Comment Utility
Try to accessing your web mail externally and look at your hit count to see if it's increasing on the access list?

show access-list 100

David
0
 

Author Comment

by:forcedexposure
Comment Utility
Hi David,

I'm able to access my web mail externally.

Thanks! Kristin
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 250 total points
Comment Utility
6.3(1) to 6.3(5)
What changed? support for Alias command? "New" support for "dns" keyword in static statement as the replacement for alias?
Internal users should *never* associate web or email servers by their public IP's, only by the private IP addresses.
External users should *always* associate www or email servers by their public IP's...
0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 250 total points
Comment Utility
I don't see any problems and as per the description it is working properly.

If you want to access the web-based email internally then use it with internal ip address, that will work. For exchange;

http://<internalipofexchangeserver/exchange

Cheers,
Rajesh
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

How to configure Site to Site VPN on a Cisco ASA.     (version: 1.1 - updated August 6, 2009) Index          [Preface]   1.    [Introduction]   2.    [The situation]   3.    [Getting started]   4.    [Interesting traffic]   5.    [NAT0]   6.…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now