problems playing sound object in a loaded swf

Senerio

I have a swf file that loads another swf file using the loader component. The swf file loaded is called "postBlog" and the instance name givien to the loader control is "loaderblog"

In the loaded swf "postBlog" i have the following sound object defined on the first frame of the movie

firstSound=new Sound();
firstSound.attachSound("intro01");

then on frame 30 i tell the time line to play this sound object using the following action script

_root.firstSound.start()


This works fine when the movie clip is run alone however the sounds does not play when the clip is loaded into another clip

I have tried changing the action script to as follows but have had no luck

_level1.firstSound.start(0,0);

and

this.firstSound.start(0,0);

But these do now work. I am obviously targeting this sound object incorrectly but am at aloss on the correct syntax to target sounds objects defined in loaded movie clips using the loader component

any insite would be greatly appreciated
mediatimebombAsked:
Who is Participating?
 
ZefferConnect With a Mentor Commented:
these should work..

_root.loaderblog.firstSound.start();

or

this._lockroot = true;
firstSound= new Sound();
firstSound.....etc

Z
0
 
mediatimebombAuthor Commented:
what's going on in the second method?

i would like to find a solution that would allow the sound to play from the original swf or from the loaded swf
0
 
mediatimebombAuthor Commented:
ok i tried the first method with no success.  What is happening in the second suggestion i am confused on what

this._lockroot = true is doing

0
 
mediatimebombAuthor Commented:
ok figured it out thank you for your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.