Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

problems playing sound object in a loaded swf

Posted on 2006-07-17
4
Medium Priority
?
179 Views
Last Modified: 2010-04-03
Senerio

I have a swf file that loads another swf file using the loader component. The swf file loaded is called "postBlog" and the instance name givien to the loader control is "loaderblog"

In the loaded swf "postBlog" i have the following sound object defined on the first frame of the movie

firstSound=new Sound();
firstSound.attachSound("intro01");

then on frame 30 i tell the time line to play this sound object using the following action script

_root.firstSound.start()


This works fine when the movie clip is run alone however the sounds does not play when the clip is loaded into another clip

I have tried changing the action script to as follows but have had no luck

_level1.firstSound.start(0,0);

and

this.firstSound.start(0,0);

But these do now work. I am obviously targeting this sound object incorrectly but am at aloss on the correct syntax to target sounds objects defined in loaded movie clips using the loader component

any insite would be greatly appreciated
0
Comment
Question by:mediatimebomb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 23

Accepted Solution

by:
Zeffer earned 1000 total points
ID: 17125646
these should work..

_root.loaderblog.firstSound.start();

or

this._lockroot = true;
firstSound= new Sound();
firstSound.....etc

Z
0
 

Author Comment

by:mediatimebomb
ID: 17126020
what's going on in the second method?

i would like to find a solution that would allow the sound to play from the original swf or from the loaded swf
0
 

Author Comment

by:mediatimebomb
ID: 17126118
ok i tried the first method with no success.  What is happening in the second suggestion i am confused on what

this._lockroot = true is doing

0
 

Author Comment

by:mediatimebomb
ID: 17126161
ok figured it out thank you for your help
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article is primarily concerned with ActionScript 3 and generally specific to AVM2.  Most suggestions would apply to ActionScript 2 as well, and I've noted those tips that differ between AS2 and AS3. With the advent of ActionS…
While working over numerous projects I often had the requirement for doing a screen capture in AS3.0. Unfortunately I found no "ready made" solutions in google search that suited my requirements. But I did come across some great resources which help…
The goal of the tutorial is to teach the user how to how to load their YouTube profile onto Flash Media Live Encoder.
The goal of the tutorial is to teach the user how to how to record live broadcast.
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question