Solved

Pix 501 VPN tunnel not allowing windows shares

Posted on 2006-07-17
4
338 Views
Last Modified: 2010-04-12
I have a PIX 501 Versin 6.3(5) and Cisco Client Software version 4.6.00.0045.  I have configured a VPN tunnel and it is working fine, I can RDP, FTP, and ICMP to remote computers.  The problem I am having is when I try to access the windows shares on the remote computers, it doesn't work.  When I am physically in the network I can access them by \\192.168.1.50\share, but this doens't work through the VPN.  I have looked everywhere and cannot figure this one out...

Here's my network:
Laptop(cisco client)-->internet-->DSL--transparent bridge-->PIX 501-->server

Any help would be greatly appreciated, I have been at this for days!

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list VPN_GROUP_splitTunnelAcl permit ip any any
access-list outside_cryptomap_dyn_20 permit ip any 10.10.10.0 255.255.255.240
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN_POOL 10.10.10.1-10.10.10.10
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup VPN_GROUP address-pool VPN_POOL
vpngroup VPN_GROUP split-tunnel VPN_GROUP_splitTunnelAcl
vpngroup VPN_GROUP idle-time 1800
vpngroup VPN_GROUP password ********
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname *******
vpdn group pppoe_group ppp authentication pap
vpdn username ******* password ********* store-local
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:*****
: end
[OK]

0
Comment
Question by:nan_brandon
  • 2
4 Comments
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 400 total points
ID: 17125416
You are missing some configurations. Add the following lines:

access-list nonat_acl permit ip 192.168.1.0 255.255.255.0 10.10.10.0 255.255.255.240
nat (inside) 0 access-list nonat_acl
access-list VPN_GROUP_splitTunnelAcl ip 192.168.1.0 255.255.255.0 10.10.10.0 255.255.255.240
no access-list VPN_GROUP_splitTunnelAcl permit ip any any
clear xlate

Try it out and let us know.
0
 
LVL 32

Assisted Solution

by:rsivanandan
rsivanandan earned 100 total points
ID: 17127476
Agreed. But I'm wondering without a 'nonat' acl how were you able to connect and do ftp and all ? Is this the running config on the PIX?

Cheers,
Rajesh
0
 

Author Comment

by:nan_brandon
ID: 17131727
Thanks for the info guys, as it turns out it was a firewall issue on the server.  What I had to do was reconfigure the scope on the windows firewall to not only allow the network that the server resides on, but also allow the VPN network.  It does work with the config I have on my previous post, just a firewall issue.

thanks, I'll split the points.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17131781
It is a mystery :-)

Cheers,
Rajesh
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

Preface Having the need * to contact many different companies with different infrastructures * do remote maintenance in their network required us to implement a more flexible routing solution. As RAS, PPTP, L2TP and VPN Client connections are no…
I've had to do a bit of research to setup my VPN connection so that Clients can access Windows Server 2008 network shares.  I have a Cisco ASA 5510 firewall.  I found an article which was extremely useful: It had a solution if you use ASDM to config…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now