• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 407
  • Last Modified:

Pix 501 VPN tunnel not allowing windows shares

I have a PIX 501 Versin 6.3(5) and Cisco Client Software version  I have configured a VPN tunnel and it is working fine, I can RDP, FTP, and ICMP to remote computers.  The problem I am having is when I try to access the windows shares on the remote computers, it doesn't work.  When I am physically in the network I can access them by \\\share, but this doens't work through the VPN.  I have looked everywhere and cannot figure this one out...

Here's my network:
Laptop(cisco client)-->internet-->DSL--transparent bridge-->PIX 501-->server

Any help would be greatly appreciated, I have been at this for days!

Building configuration...
: Saved
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list VPN_GROUP_splitTunnelAcl permit ip any any
access-list outside_cryptomap_dyn_20 permit ip any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN_POOL
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http outside
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup VPN_GROUP address-pool VPN_POOL
vpngroup VPN_GROUP split-tunnel VPN_GROUP_splitTunnelAcl
vpngroup VPN_GROUP idle-time 1800
vpngroup VPN_GROUP password ********
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname *******
vpdn group pppoe_group ppp authentication pap
vpdn username ******* password ********* store-local
dhcpd address inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
: end

  • 2
2 Solutions
You are missing some configurations. Add the following lines:

access-list nonat_acl permit ip
nat (inside) 0 access-list nonat_acl
access-list VPN_GROUP_splitTunnelAcl ip
no access-list VPN_GROUP_splitTunnelAcl permit ip any any
clear xlate

Try it out and let us know.
Agreed. But I'm wondering without a 'nonat' acl how were you able to connect and do ftp and all ? Is this the running config on the PIX?

nan_brandonAuthor Commented:
Thanks for the info guys, as it turns out it was a firewall issue on the server.  What I had to do was reconfigure the scope on the windows firewall to not only allow the network that the server resides on, but also allow the VPN network.  It does work with the config I have on my previous post, just a firewall issue.

thanks, I'll split the points.
It is a mystery :-)

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now