Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 395
  • Last Modified:

Suddenly can't change the task target in Scheduled Tasks

I use Scheduled Tasks extensively, generally using a task to launch a batch file.  Since you can't choose batch files from the list the painfully awful wizard provides you (is there any way to avoid using that?), I just pick some random application from the wizard, schedule it the way I want, and then edit the properties of the completed task (as shown here: http://www.iopus.com/guides/winscheduler.htm ).  Annoying, but it works great.

As of today, I can create tasks just fine, but now when I select the properties of any scheduled task the "Run:" and "Start In:" textboxes in the "Task" tab are grayed out and un-editable.  I checked the "Security" tab, and I'm still listed as possessing Full Control privileges.

This is a workplace computer, and a patch was pushed out over the weekend.  I figure there's a 50% chance the patch caused this problem, and a 50% chance I'm just doing something stupid.  Either way, I'd appreciate any assistance I can get in fixing it, please.
0
Rakafkaven
Asked:
Rakafkaven
1 Solution
 
danishtahirCommented:
I just pick some random application from the wizard, schedule it the way I want, and then edit the properties of the completed task (as shown here: http://www.iopus.com/guides/winscheduler.htm ).  Annoying, but it works great.

You don't have to. Click on the browse button and select your batch file.

As of today, I can create tasks just fine, but now when I select the properties of any scheduled task the "Run:" and "Start In:" textboxes in the "Task" tab are grayed out and un-editable.  I checked the "Security" tab, and I'm still listed as possessing Full Control privileges.

Remove and recreate the tasks.
0
 
netsmithcentralCommented:
The only alternative to using the "Tasks" folder is the "at" command.



The AT command schedules commands and programs to run on a computer at      
a specified time and date. The Schedule service must be running to use      
the AT command.
                                                           
AT [\\computername] [ [id] [/DELETE] | /DELETE [/YES]]                    
AT [\\computername] time [/INTERACTIVE]
    [ /EVERY:date[,...] | /NEXT:date[,...]] "command"

\\computername     Specifies a remote computer. Commands are scheduled on the
                   local computer if this parameter is omitted.            
id                 Is an identification number assigned to a scheduled      
                   command.                                                
/delete            Cancels a scheduled command. If id is omitted, all the
                   scheduled commands on the computer are canceled.
/yes               Used with cancel all jobs command when no further
                   confirmation is desired.
time               Specifies the time when command is to run.
/interactive       Allows the job to interact with the desktop of the user  
                   who is logged on at the time the job runs.
/every:date[,...]  Runs the command on each specified day(s) of the week or
                   month. If date is omitted, the current day of the month
                   is assumed.                                              
/next:date[,...]   Runs the specified command on the next occurrence of the
                   day (for example, next Thursday).  If date is omitted, the
                   current day of the month is assumed.
"command"          Is the Windows NT command, or batch program to be run.
0
 
LeeTutorretiredCommented:
Is the Task Scheduler service running?  Click Start -> Run -> type SERVICES.MSC and hit the Enter key -> scroll down to the Task Scheduler service.  If it is not running, then double click on it, change the Startup Type to Enabled and click the Start button.
0
 
RakafkavenAuthor Commented:
danishtahir - The wizard that I see looks exactly like the screenshot in the link, but there is no browse button.  It's the same on other machines in the office, and has been for as long as I've worked here.  That's why we had to do the editing of properties.  Removing and recreating changes nothing, unfortunately.

netsmithcentral - That workaround will solve the immediate problem.  I'd still like to know why I can't edit existing Scheduled Tasks, so I'll probably post that as a new question.

LeeTutor - Sorry, I should've been more specific.  Yes, it is running-- I have no problems getting my Scheduled Tasks to launch, I just have problems making those tasks be anything that isn't in the wizard's list.

Thanks, everyone!
0
 
RakafkavenAuthor Commented:
For posterity, it turns out that the missing browse button and uneditable targets were a result of a Policy pushed in a security patch.  It's fixed by going into regedit and following this path:
HKEY_LOCAL_MACHINE --> SOFTWARE --> Policies --> Microsoft --> Windows --> Task Scheduler5.0 and setting the value of the "Allow Browse" key to 0.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now