Solved

Citrix connection problems with Windows CE thin clients.

Posted on 2006-07-17
7
1,756 Views
Last Modified: 2011-10-03
Recently, a DSL modem install shut off the DHCP service on a Windows 2000 SBS and messed up printing and Citrix terminal logins. I fixed this by disabling its DHCP function and reenabling the server. All of the "dumb" thin clients and full blown workstations can connect now and printing works fine, but 2 of the thin clients will not reconnect. They are HP Compaq t5000's and are running Windows CE (the only ones with an OS). The Citrix management console shows these 2 as "connected" but they never go "active". The Citrix services are running on the server, and I have even tried resetting the server once. The ICA administrator toolbar is in the systray, but it cannot be accessed. Any suggestions would be great.
0
Comment
Question by:SaratogaTech
  • 3
  • 2
7 Comments
 
LVL 5

Expert Comment

by:centrepc
ID: 17130878
How far do the thin clients get when logging in.  do you get to a login screen or any errors come up.  Are the thin clients even getting an ip address from the dhcp server.  It sounds like they are not even getting an ip.  But can't tell from the info above.  Can the thin clients connect using rdp.  This may help narrow down if it is a server problem or citrix problem.  If you can't even connect using rdp then it won't be a problem with citrix.  

Let me know the ip configuration of the thin client and there is a ping utility in the t5000's.  Make sure you can at least ping the server.....
0
 
LVL 1

Author Comment

by:SaratogaTech
ID: 17137788
The clients do get an IP from the server. In fact I can RDP into the server from the CE clients with no problems. I look at terminal services manager, and the RDP connection shows active while an ICA connection from the same machine shows Connected  (the other ICA terminal sessions show Active from the dumb terminals). Pinging all other IPs on the network also works fine from the CE clients. Internet access also works, so all other network related functions appear to be fine.

As for logging in, they at least authenticate far enough to connect to the session, but nothing ever launches, they just kind of sit there.
0
 
LVL 5

Expert Comment

by:centrepc
ID: 17140823
sounds like it is having a problem mapping back an attached printer or other device attached to the thin client.  Are you trying to run a published app or just a desktop from the thin client.

So you do get a login screen and you get to the point of typing in your user name and password and then do you just get a blue screen.

Need to try logging in as the administrator to a citrix desktop.  Disable client printer and drive mapping in the administrators profile.  

This may also have to with TS Licensing.  Check in the ts licensing if these thin clients have a temp license or have been given a real ts cal.  workstation running 2000 or higher wouldn't need licensing and that maybe why they are working.  

Just curious about what you are calling a dumb thin client.  All thin clients have to have an o/s even if it is a linux kernel or something.  If it were a licensing issue these shouldn't be working either unless they have a temp license that hasn't expired.  

do you have another citrix server you can try logging into with the ones that aren't working.  I have found in the past that if it is a licensing issue you can log into a server that is working and after that it will let you log once into a server that the ts licensing is not.  

Hope this helps!  
 
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 1

Author Comment

by:SaratogaTech
ID: 17175149
It is just a desktop from the thin client, not a published app. After the login, it acts like another desktop is opened up, but there is nothing to click on or run, it just sits on the other desktop. As for the curiosity, by dumb thin client, I meant an OS you can't really do anything with other than launch the Citrix client.

I do not have another citrix server on site to try to hook up with. I have yet to go back onsite and try the licensing suggestions or the administrative login.

Thanks for the suggestions so far.
0
 
LVL 1

Author Comment

by:SaratogaTech
ID: 17195872
We have ended up resolving this issue ourselves by using an RDP connection into the server. We actually never really solved this issue, but the solution we came up with is acceptable. Moderator - please close this topic.
0
 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 17633496
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

After several days of searching and hunting for limited documentation, I wanted to share this guide to hopefully save someone the hassle of trying to figure this out on their own. I have tested this on Xendesktop 7.1 and PS 4.5 running simultaneous…
CITRIX XENAPP 6.5 FARM CUSTOM POLICY - CHANGE MANAGEMENT WINDOW REBOOT SCHEDULE
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now