Solved

Microsoft VPN PPTP & IP

Posted on 2006-07-17
22
1,150 Views
Last Modified: 2008-02-01
Hi, I have a problem with MS VPN - PPTP. I a Win2003 SBS server I need to connect to remotely. I've set up the router with TCP port 1723 for PPTP, and IP Protocol 47 (GRE). The remote connection works fine, establishes the connection, and registers the computer on the network. All good so far. However, it sees this address 192.168.1.207 at BOTH ends of the VPN (ie the 2003 SBS server and the remote PC) as the local address. This looks wrong to me, (but I only have experience in router-router VPNs) Is this normal? How do I then map a drive from the client to the remote? If I map a drive to \\192.168.1.207\C$ I get a mapped drive OK, but it is the local C drive of the workstation!!! Any help would really be appreciated...
Thanks
Matt
 
0
Comment
Question by:mattpaulin
  • 8
  • 4
  • 3
  • +5
22 Comments
 
LVL 9

Expert Comment

by:NYtechGuy
ID: 17127166
Can you please post an IPCONFIG /ALL from both the remote PC and the server?

Thanks,

justin
0
 
LVL 8

Expert Comment

by:photograffiti
ID: 17127173
Your PC should have two IP addresses. The local IP address of the workstation before it even connects to the VPN server and the IP address the VPN server hands out. What is the IP address of the workstation? Is it in the same range as the IP address that is handed to it or is it in the same range as the server you're trying to map to?
0
 

Author Comment

by:mattpaulin
ID: 17127352
Nope. Normal IP address for remote workstation is on the 192.168.0.X subnet, automatically assigned. It gets the 192.168.1.207 address on the PPP adapter only when connected to the VPN. As it should as far as I can see... The remote servers "real" address on it's ehternet adapter is 192.168.1.10... but it to picks up 192.168.1.207 on it's PPP adapter when connected to the VPN.....

Thanks
Matt
0
 

Author Comment

by:mattpaulin
ID: 17127382
Ipconfig /all From the Workstation;
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : mattswkstn
        Primary Dns Suffix  . . . . . . . : qcomp.co.nz
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : Yes
        WINS Proxy Enabled. . . . . . . . : Yes
        DNS Suffix Search List. . . . . . : qcomp.co.nz
                                            co.nz

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
        Physical Address. . . . . . . . . : 00-0E-A6-05-83-2F
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.0.37
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.1
        DNS Servers . . . . . . . . . . . : 192.168.0.2
                                            202.27.184.3

Ethernet adapter Local Area Connection 3:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Windows Mobile-based Device #2
        Physical Address. . . . . . . . . : 80-00-60-0F-E8-00
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 169.254.2.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :
        DHCP Server . . . . . . . . . . . : 169.254.2.1
        Lease Obtained. . . . . . . . . . : Tuesday, July 18, 2006 2:29:34 PM
        Lease Expires . . . . . . . . . . : Thursday, August 17, 2006 2:29:34 PM


PPP adapter GuthrieBHO:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
        Physical Address. . . . . . . . . : 00-53-45-00-00-00
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.1.207
        Subnet Mask . . . . . . . . . . . : 255.255.255.255
        Default Gateway . . . . . . . . . : 192.168.1.207
        DNS Servers . . . . . . . . . . . : 192.168.1.254
                                            202.27.184.3
        Primary WINS Server . . . . . . . : 192.168.1.11

C:\>
From the server;
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : gb2
   Primary Dns Suffix  . . . . . . . : GB.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : GB.local

PPP adapter RAS Server (Dial In) Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
   Physical Address. . . . . . . . . : 00-53-45-00-00-00
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.207
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Disabled

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0E-0C-4A-DF-94
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.11
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.254
   DNS Servers . . . . . . . . . . . : 192.168.1.254
                                       202.27.184.3
   Primary WINS Server . . . . . . . : 192.168.1.11

C:\Documents and Settings\Administrator>

Thanks for your help
0
 

Author Comment

by:mattpaulin
ID: 17127453
sorry, slight error in my other post - does not effect the problem though. The server address (ethernet adapter) is 192.168.1.11, not 1.10...
Cheers
Matt
0
 
LVL 9

Expert Comment

by:NYtechGuy
ID: 17127502
Matt-

It looks like you should be able to map a drive (from the workstation to the server) by using the IP address 192.168.1.11.  What happens if you do the following:

- start
- run
- type:  \\192.168.1.11\c$

I admit the Wan ppp/slip IP Address looks the same on both - but the server's actual NIC does have a different address.

Please try the test and let us know.

Thanks,

Justin
0
 

Author Comment

by:mattpaulin
ID: 17127578
Yep, thats what I thought! But nothing happens.. and if I try to map the drive from explorer, eventually I get;

The network path \\192.168.1.11\c$ could not be found

Pings to 192.168.1.11 don't work either. It's like there is something missing from the routing table.....

Cheers
Matt
0
 
LVL 12

Expert Comment

by:r_naren22atyahoo
ID: 17127733
after connecting the PPTP, type this at command promt and try the above command on the client machine

route add 0.0.0.0 mask 0.0.0.0 192.168.1.207 255.255.255.255

192.168.1.207, i expect this is the pptp ip address on the client.

let us know the results

also just a question??? did you disable the option on pptp connection "Use this as the default gateway"????
or just enable it, make the connection again and try this  \\192.168.1.11\c$


regards
naren
0
 
LVL 8

Expert Comment

by:saw830
ID: 17127742
Hi,

Interesting question.  Firstly, MS PPTP is not done the same way as router to router VPNs.  As you probably know, router to router VPNs are basically managed like a physical link where both ends are in their own subnet and have IP addresses from that subnet.  In PPTP, the client end gets assigned an address from a pool that resides on the server end, much like DHCP.  I've not played much with using Windows Server to be the PPTP server, but I have played with the client end a fair amount.

Make sure you don't have a firewall (XP, Norton Internet Security, Secure Remote, etc) getting in the way.

The client end also doesn't look quite right.  I believe that the mask on the client end needs to be set to 255.255.255.0.  With it set to 255.255.255.255 the client thinks it's in a subnet by itself.  It is trying to send a packet to another address, which according to the mask is not in the same subnet, and therefore sends it out the default gateway, which isn't the correct way.

After fixing the mask, have a look at the advanced settings of the PPTP adapter on the client and turn off the default gateway setting.

-Alan
0
 
LVL 12

Expert Comment

by:r_naren22atyahoo
ID: 17127761
PPTP client offcource will get DHCP address
The pptp client will always get the subnet mask as 255.255.255.255

>>>>route add 0.0.0.0 mask 0.0.0.0 192.168.1.207 255.255.255.255
this has to be like this
route add 0.0.0.0 mask 0.0.0.0 192.168.1.207



0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 7

Expert Comment

by:nttranbao
ID: 17127829
I see. This is because the IP address of the PPP adaptor on windows XP is STATIC configured ( see DHCP enable = NO below). That's will cause a ip address colision and you can not do anything.

PPP adapter GuthrieBHO:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
        Physical Address. . . . . . . . . : 00-53-45-00-00-00
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.1.207
        Subnet Mask . . . . . . . . . . . : 255.255.255.255
        Default Gateway . . . . . . . . . : 192.168.1.207
        DNS Servers . . . . . . . . . . . : 192.168.1.254
                                            202.27.184.3
        Primary WINS Server . . . . . . . : 192.168.1.11

Solution : if your Server has DHCP , then configure your xp to use DHCP.
If  Server has not DHCP server, then configure other STATIC IP address  

IP 192.168.1.xxx ( differ from 207)
default gateway : your server internal ip ( 192.168.1.207)
DNS : whatver

And see if the problem gone or not.
0
 
LVL 12

Expert Comment

by:r_naren22atyahoo
ID: 17127875
Dhcp Enabled. . . . . . . . . . . : No ????
good point nttranbao
0
 
LVL 33

Expert Comment

by:Busbar
ID: 17128319
nttranbao eagle eye :)
0
 

Author Comment

by:mattpaulin
ID: 17134206
I tried manually changing the Client PPP IP address to 192.168.1.206. No Change. If I do a status screen on the PPP from the client end when the VPN is up I get;

Device Name                  WAN Miniport (PPTP)
Device Type                   vpn
Server Type                    PPP
Transports                     TCP/IP
Authentication               MS Chap V2
Encryption                     MPPE 128
Compression                 MPPC
PPP Multilink Framing    Off
Server IP address          192.168.1.207
Client IP Address          192.168.1.207

Can some one with a working system tell me if it is normal to see both the server and the client having the same IP address??? Looks odd to me....

Thanks
Matt
0
 
LVL 12

Expert Comment

by:r_naren22atyahoo
ID: 17135050
Here is what you need to do,

1) Make the server to assign ip address to the PPTP clients.
2) you have to check the box use this connection as the default gateway in PPTP TCP/IP properties
3) type this on client after connecting to the VPN, i mean at command prompt
"route print"
this will give you the routing info in the PC
4) if the server is not assigning the IP address, make sure you wont assign the duplicate ip address and us the connection as default gateway
also do the route print and put the details here

regards
naren
0
 
LVL 7

Expert Comment

by:nttranbao
ID: 17135918
It is  likely because your server settings FORCE IP assign to client. That's why even if you change the IP of the WAN connection at client, the client is still assigned 192.168.1.207. Check the configuration of the WAN Server, make sure it leases available addresses.
0
 

Author Comment

by:mattpaulin
ID: 17143108
OK Naren,

1/ I presume you mean in Prop of the VPN connection IP to assign "obtain IP addresses automatically" same 4 DNS. Done that.

2/ Ticked the "use default gateway on remote network

3/ Here is the Ipconfig, & route print;

Windows IP Configuration


Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : qcomp.co.nz
        IP Address. . . . . . . . . . . . : 192.168.0.179
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter Local Area Connection 3:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 169.254.2.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

PPP adapter GuthrieBHO:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.1.207
        Subnet Mask . . . . . . . . . . . : 255.255.255.255
        Default Gateway . . . . . . . . . : 192.168.1.207

C:\Documents and Settings\matt.000\Desktop>ping 192.168.1.11

Pinging 192.168.1.11 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.11:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\matt.000\Desktop>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 0e a6 05 83 2f ...... Realtek RTL8139 Family PCI Fast Ethernet NIC
acket Scheduler Miniport
0x330004 ...80 00 60 0f e8 00 ...... Windows Mobile-based Device #2
0x340005 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.0.1   192.168.0.179       21
          0.0.0.0          0.0.0.0    192.168.1.207   192.168.1.207       1
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      169.254.2.0    255.255.255.0      169.254.2.2     169.254.2.2       30
      169.254.2.2  255.255.255.255        127.0.0.1       127.0.0.1       30
  169.254.255.255  255.255.255.255      169.254.2.2     169.254.2.2       30
      192.168.0.0    255.255.255.0    192.168.0.179   192.168.0.179       20
    192.168.0.179  255.255.255.255        127.0.0.1       127.0.0.1       20
    192.168.0.255  255.255.255.255    192.168.0.179   192.168.0.179       20
    192.168.1.207  255.255.255.255        127.0.0.1       127.0.0.1       50
    192.168.1.255  255.255.255.255    192.168.1.207   192.168.1.207       50
   210.54.238.117  255.255.255.255      192.168.0.1   192.168.0.179       20
        224.0.0.0        240.0.0.0      169.254.2.2     169.254.2.2       30
        224.0.0.0        240.0.0.0    192.168.0.179   192.168.0.179       20
        224.0.0.0        240.0.0.0    192.168.1.207   192.168.1.207       1
  255.255.255.255  255.255.255.255      169.254.2.2     169.254.2.2       1
  255.255.255.255  255.255.255.255    192.168.0.179   192.168.0.179       1
  255.255.255.255  255.255.255.255    192.168.1.207   192.168.1.207       1
Default Gateway:     192.168.1.207
===========================================================================
Persistent Routes:
  None

I appreciate your time...
Thanks
Matt
0
 

Author Comment

by:mattpaulin
ID: 17144201
OK solved the problem. Threefold issue. I changed the  incoming server connections to supply the IP address for PPTP, and gave it a range of 10 addresses. Then I turned off the firewall on the server NIC.  Then I set the workstation end to "automatically assign" IP & DNS addresses.  Now it all functions. I'll look at restricting the firewall again for security, but it is now working....

Thanks for your help everyone who replied.
Matt
0
 
LVL 7

Expert Comment

by:nttranbao
ID: 17146595
see what I told you before. it's the server assigning the static address to the client.
Anyways, glad it's solved :)
0
 

Author Comment

by:mattpaulin
ID: 17149453
Yes, that was part of the problem, but it still did not work when I manually assigned IP at both ends. The main prob was that I had not realised that you have to turn off (or filter) the windows firewall on both the "incoming connections" AND the local ethernet NIC - although now it's working that seems obvious!
Thanks for your help
Matt
0
 
LVL 1

Accepted Solution

by:
DarthMod earned 0 total points
ID: 17479394
PAQed with points refunded (250)

DarthMod
Community Support Moderator
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now