Solved

NTP Client & Server doesn't synchronise!

Posted on 2006-07-17
14
2,032 Views
Last Modified: 2013-12-27
Hi experts,

I'm trying to configure NTP Server and Clients on Solaris 5.8, but it doesn't synchronize when i test to change time clock in NTP Server.

In NTP Server i copy ntp.server to ntp.conf in /etc/inet/ and add below lines:

server 127.127.1.0
fudge 127.127.1.0 stratum 10

broadcast 224.0.1.1 ttl 4

peer main-ssp
peer spare-ssp2

enable auth monitor
driftfile /var/ntp/ntp.drift
statsdir /var/ntp/ntpstats/
filegen peerstats file peerstats type day enable
filegen loopstats file loopstats type day enable
filegen clockstats file clockstats type day enable

keys /etc/inet/ntp.keys
trustedkey 0
requestkey 0
controlkey 0

and in NTP Clients I copy ntp.client to ntp.conf and add below lines:

root@m2000svr # cd /etc/inet/
root@m2000svr # less ntp.conf
server 127.127.1.0 prefer
fudge 127.127.1.0 stratum 10

broadcast 224.0.1.1 ttl 4

After then i issue cmd -> ntpdate ip-of-ntpserver from ntp clients. as the result the time clock is adjusted to be the same ntp-server. but when i test to change time clock in Ntp-server, the cient doesn't change follow ntp-server.
How to do it?

Here is the result of my query(both server and clients show the same result)
ntpq> peers
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*LOCAL(0)        LOCAL(0)        10 l   41   64  377    0.000    0.000  10.010
 224.0.1.1       0.0.0.0         16 -    -   64    0    0.000    0.000 16000.0
ntpq> association
ind assID status  conf reach auth condition  last_event cnt
===========================================================
  1 33604  9614   yes   yes  none  sys.peer   reachable  1
  2 33605  8000   yes   yes  none    reject

thanks,

iKhmer
0
Comment
Question by:ikhmer
  • 7
  • 6
14 Comments
 
LVL 38

Expert Comment

by:yuzh
ID: 17128051
For Solaris 8, please have a look at the answer in http:Q_20879113.html

You can also use cron to run rdate to synchronise time.
see http:Q_21648501.html
0
 

Author Comment

by:ikhmer
ID: 17129028
Dear Yuzh,

I follow your quide line on both NTP server and client, but when i issue ntpq -p from ntp clients i
always get " 127.0.0.1: timed out, nothing received " .

that mean it can't find the ntp server, right?  what should i do next?

thanks,

iKhmer

0
 
LVL 38

Expert Comment

by:yuzh
ID: 17129513
Please have a look at the NTP trouble shooting doc:
8.2.1.1.2. 127.0.0.1: timed out, nothing received, ***Request timed out

No response was received within the timeout interval. Either the network did drop the request or the answer, or it delayed it considerably, or the server did not respond. One reason for the latter would be a configuration line like this:[3]

restrict default ignore

http://www.ntp.org/ntpfaq/NTP-s-trbl-general.htm

also http:Q_21190841.html

Good night!
0
 

Author Comment

by:ikhmer
ID: 17130079
Hello Yuzh,

I add this line once on ntp server but it doesn't work and ntp client also the same...

what is the next step?

thansk,

iKhmer
0
 
LVL 20

Expert Comment

by:tfewster
ID: 17130794
> and in NTP Clients I copy ntp.client to ntp.conf and add below lines:
> server 127.127.1.0 prefer
> fudge 127.127.1.0 stratum 10

The IP addresses here should be the address of your NTP _server_; As it is, the client thinks it is its own NTP master
0
 
LVL 38

Expert Comment

by:yuzh
ID: 17135390
You need to specify your NTP server in your NTP client config files, have a look
at the following doc to learn more details:
http://www.itworld.com/Comp/3380/nls_unixntp3041028/pfindex.html
0
 

Author Comment

by:ikhmer
ID: 17136065
Great!!! It work now. Many thank Yuzh!
and one more question, I am also required to install ntp client on Window to synchronize with NTP Server(above solaris). how can i do it? do i need to install any package?

Best Regards,

iKhmer
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 38

Expert Comment

by:yuzh
ID: 17136806
0
 

Author Comment

by:ikhmer
ID: 17137140
Dear Yuzh,

I try with NetTime, but it is always one hour ahead! I mean if NTP server is 1:00PM it show 2:00PM in client side :-(

Do i need to change something else?

kind regards,

iKhmer
0
 

Author Comment

by:ikhmer
ID: 17137796
From Client Window is "Arabic Daylight Time" zone. but i already change the time zone to be the same GMT. How can i know in Solaris is "Arabic Daylight Time" ?
how to enable it and wake it up without reboot server?
0
 

Author Comment

by:ikhmer
ID: 17143798
Well, from Window Box if i uncheck "Automatically Adjust Clock For DayLight saving changes" it work correctly. but i am required to keep this option.
what is ur idea? do i need to enable or disable in Solaris? how to check it status? and how to change without reboot server?

B.Regards,

iKhmer
0
 
LVL 38

Expert Comment

by:yuzh
ID: 17143996
>>How can i know in Solaris is "Arabic Daylight Time" ?

In your Solaris box, type in:
date
The output sould give you the timezone infor.
To change the TIMEZONE for your box:

1. For a list of the TIMEZONE you can use have a look at:
   ls /usr/share/lib/zoneinfo
2. edit /etc/TIMEZONE file, change the TZ variable (I've done this)
  you might need to change the LC_TIME var if required

3.reboot

You can use "date" command to change the time to the local time.
man date
to learn more details.

PS: Not sure Solaris has "Arabic Daylight Time" zone, I have not work with the
      Arabic TIMEZONE before, it might comes with the Language support CD,
      You might endup need to use "Egypt" instead.

     To be fair, you should post new question instead of adding questions to
     this one. For Windows PC, the questions should go to the M$ Windows
     TAs, thank you.
     
Good luck!
     


 
0
 

Author Comment

by:ikhmer
ID: 17144149
Thank again Yuzh,
Now it work, i use NetTime to install on the Window platform and uncheck "Automatically Adjust Clock Daylight saving".
Solaris server is on production, can't boot in anyway!!!

B.Regards,

iKhmer
0
 
LVL 38

Accepted Solution

by:
yuzh earned 500 total points
ID: 17151234
Good to know you it is working, question close?

Have a nice weekend!
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
I have been running these systems for a few years now and I am just very happy with them.   I just wanted to share the manual that I have created for upgrades and other things.  Oooh yes! FreeBSD makes me happy (as a server), no maintenance and I al…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now