Solved

Using PF to rdr all http/https traffic to a web-scanning proxy

Posted on 2006-07-17
8
455 Views
Last Modified: 2013-12-23
I want to redirect all the outgoing traffic on port 80 to force it to go through the proxy held at messagelabs.  At the moment the rdr rule looks like

rdr on $int_if proto tcp from any to any port http -> 216.82.251.227 port 3128

This doesn't work.  I actually am a bit confused by what that does - if the proxy is not in the browser configuration then all pages fail.  If the proxy is in the configuration then it works.

Can anyone suggest how this ought to work with pf on openbsd?
0
Comment
Question by:chemwatch
  • 3
  • 2
8 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 17131387
sorry I'm not used to pf, but is it a full statefull inspection firewall which handles the way back automatically?
If not you probably need a rule for the packets back from the proxy to your clients.
0
 

Author Comment

by:chemwatch
ID: 17135803
The beauty of a redirect is that there should actually be no need to treat the return path specially.  Redirect will rewrite the destination of each outbound packet to be the web-proxy, but the source of the packet will still be the IP of the nat host that is sending it.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 17136212
do you see the requests at your proxy? If so, does it send the response back to the client?
I'd use tcpdump on the proxy host.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:chemwatch
ID: 17136251
We don't house the proxy - it is run by an outsourced company in singapore, to which we have no access.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 17136554
ok, then use tcpdump on your firewall, if you see the outgoing packets but no corresponding incomming, then the problem is at the proxy site
0
 
LVL 1

Accepted Solution

by:
robbak earned 250 total points
ID: 17229787
Transparent Proxying - which is what you want to do - should be allowed to talk to the firewall to work out where the request came from. At the very least, it needs to know that it is supposed to be a transparent proxy. In squid, this is a compile-time option.

It seems that the remote proxy is not set up to act as a transparent proxy.

The best option I can see is to run a proxy on the local system. You don't need to give it a large cache - Indeed, none at all will work - and then have it use the other proxy as a parent. If you wish to go this way, then post back and we'll help you.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Let’s list some of the technologies that enable smooth teleworking. 
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question