Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1166
  • Last Modified:

How to get rid of the Open File - security warning message when my exe runs

I have a exe that was created using Visual Basic 6. whenever I run that, ( windows 2003 server ) I get a message called

"Open File  - Security warning"

with two buttons "Run" and "Cancel" . If I choose run, the exe runs as normal. But I do not want my users to have the hassle of clickng this button, my exe is supposed to be run behind the scene. ( they are all terminal server clients )

However I do not want to change the entire security policy of the windows 2003 machine. I only need to set some security level so that this exe will run without this message box.

Thanks,
Indika.

0
indikad
Asked:
indikad
  • 3
  • 2
2 Solutions
 
glennbrown2Commented:
i found this was happening to me when users tried to execute an .exe file from the server or a local,  redirected folder that was mapped via DFS.  not sure if it happens both on a DFS share or not, but.....I resolved it by adding the path to the trusted websites in Internet explorer.

so if your path was \\domain.local\dfs\companyshare\ add domain.local to the trusted websites in IE.
in my case, users had redirected desktops \\domain.local\dfs\profiles\....i added domain.local and it was sorted.

I guess you can add the local machine, server name, etc if you don't use DFS.

I believe this was a security "enhancement" in Windows 2003 SP1....this started happening to me immediately after installing that
0
 
budchawlaCommented:
Right-click the file in question, and at the bottom of the general tab click the Unblock button...
Windows now automatically applies this extra layer of security (if you can call it that) to executable files that have come from other computers...
0
 
glennbrown2Commented:
any feedback on this indikad
thanks
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
indikadAuthor Commented:
Hi  glennbrown2  and  budchawla ,

sorry I was unable to reply to these messges as I had been drawn to other projects.

Now with glennbrown2 s solution, I added the path to the exe in the IE explorete trusted sites list. However it appared as a mac address. ( the exe is in a shared, drive in the same server and the pathe I set is in a mapped drive - as this is the same scenario my cleint uses ).

ia have the file in c:\programfiles\test
and mapped the c:\programfiles\test to z srive and set the z drive as a trusted path in IE

I still have the same issue when I run the exe from z drive. However if i simply run the file from the local folder that is c:\programfiles\test , then no problems.

0
 
glennbrown2Commented:
OK, try these...i think I may have misunderstood you.

http://windowsxp.mvps.org/networkfile.htm

and/or

ensure that you have added the FQDN as a trusted intranet zone...this is important to resolving this

0
 
indikadAuthor Commented:
Method 1 from the site
http://windowsxp.mvps.org/networkfile.htm

helped. It worked without having to set the FQDN. I was trying on the trusted sites before, and not the local intranet.

thanks.

thanks to you too budchawla , as your comments gave me some insight in to windows security too, however I could not find the Unblock button ( even loggen in as administrator ).  I would appreciate if you can elaborate on this when you can, as it may come in havdy sometimes.

i will split points much in favour of glennbrown2  as his method solved the problem.

Thanks,
Indika.
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now