Solved

OWA and OMA Failure - Exchange 2003 Enterprise

Posted on 2006-07-18
14
464 Views
Last Modified: 2010-03-06
Exchange 2003 Enterprise (Backend) Service Pack 1, One Exchange server only.

OWA has completely failed, error message is "Page Cannot be Displayed - HTTP 500 Internal Server Error", this also applies to OMA.

Apart from OMA and OWA Exchange is working fine, no modifications to the server have taken place.

I would be very grateful if anyone can shed some light on the situation, I am fairly new to Exchange, so please take it easy.


0
Comment
Question by:Darren454
  • 7
  • 5
14 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17129369
Any reason why the server hasn't been taken up to Exchange 2003 SP2?
That would be the first thing I would suggest as it will probably reset the OWA folders to their correct settings.

Simon.
0
 

Author Comment

by:Darren454
ID: 17129415
Hi Simon

I have been using Microsoft Baseline Security Analyzer 2.0 and Best Practices Analyzer Tool to keep the server updated, perhaps it would be a good idea then to update to service pack 2, is there anything I should watch out for with SP2?

Darren
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17129428
Do you have the original release of intelligent message filter (IMF) installed? If so, it needs to be removed as that is now built in Exchange.
Otherwise read the readme file that comes with the service pack - it covers any major issues. However the service pack is rock solid and shouldn't cause too many problems.

Simon.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:Darren454
ID: 17129854
Many thanks for you advice, I will give it a go.

Darren
0
 

Author Comment

by:Darren454
ID: 17130702
Hi Simon

I have installed service pk 2, it has improved the situation some what, I can now use OMA.  OWA now loads but with errors on the page, I have sent you an e-mail with a print screen, I hope you don't mind.

Darren
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17131510
Check the authentication settings on the Exchange virtual folders in IIS Manager:

/exchange - integrated and basic only
/exchweb - anonymous only
/exadmin - integrated only
/public - integrated and basic only.

Simon.
0
 

Author Comment

by:Darren454
ID: 17131569
Hi Simon

Just checked out the settings, all are as you listed.

Darren
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17131740
Do make sure that you have flushed out temp internet files before trying again.

Check the application pool settings as well.

/exchange - ExchangeApplicationPool*
/exchweb - ExchangeApplicationPool*
/exadmin - ExchangeApplicationPool*
/public  - ExchangeApplicationPool*
/oma - ExchangeMobileBrowseApplicationPool
/Microsoft-Server-ActiveSync - ExchangeApplicationPool

* will probably show ExchangeApplicationPool but greyed out.

Simon.
0
 

Author Comment

by:Darren454
ID: 17136513
Hi Simon

/exchange - ExchangeApplicationPool* Greyed Out
/exchweb - ExchangeApplicationPool* Greyed Out
/exadmin - ExchangeApplicationPool* Greyed Out
/public  - ExchangeApplicationPool* Greyed Out

/oma - ExchangeMobileBrowseApplicationPool* Execute Permissions = Scripts Only, Application Pool = ExchangeMobileBrowseApplicationPool

/Microsoft-Server-ActiveSync - ExchangeApplicationPool* Execute Permissions = Scripts and Executables, Application Pool = ExchangeApplicationPool

Darren
0
 

Author Comment

by:Darren454
ID: 17138585
Hi Simon

Problem solved

Authentication problem, ExchWeb changed to Intergrated and Basic

Thanks for your help

Darren
0
 
LVL 104

Accepted Solution

by:
Sembee earned 250 total points
ID: 17141077
While that would appear to resolve the problem, those authentication settings are actually incorrect.
On a correctly working Exchange server the authentication settings on /exchweb should be anonymous only - no other authentication settings should be applied.

If you made those changes and it started to work then that would indicate the problem is with authentication. I would probably suspect the anonymous user account.

Simon.
0
 

Author Comment

by:Darren454
ID: 17144326
Hi Simon

Thanks for that, I will have a look.

Darren
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question