Unable to share ProgramFiles directory with WinXP clients

running WinXP professional on all PC in office.  I am unable to share the "program files" directory.  I am sharing the root successfully, and all directories except the program files are sharing OK.  I have seen other similiar questions, but none have a clear solution.
pnakasoAsked:
Who is Participating?
 
scrathcyboyCommented:
Program files can only be shared at the Administrator level, because when a lot of programs install themselves, they do so with admin-only priveleges, so NON-admin people cannot acces them.  Now if you had a FAT32 drive, you would not have this problem, it is one of those annoyances with NTFS file permissions.
0
 
hladamjrCommented:
1. Disable simple file sharing: go to Control Panel, Folder Options, View tab, untick "Use simple file sharing (Recommended)".

2. Share "Program Files" folder (with a name with no spaces if you are going to share with PCs with Win9x): go to Windows Explorer, navigate to "Program Files" folder, right-click, Sharing and Security, tick "Share this folder", write a "Share name".

3. Add "Everyone" group name to Security (if not done yet): Security tab, Add, Advanced, Find Now, select Everyone, OK, OK.

No other action (as activate Guest account) is needed
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.