Solved

OWA Shows correct Graphics internally, but Not Externally

Posted on 2006-07-18
14
255 Views
Last Modified: 2010-03-06
Exchange 2003 Standard on Server 2003 SP1

OWA works brilliantly from inside.  After several calls to our Provider and Firewall Admin, got things working outside.  To a certain extent.  I can authenticate by going to http://server.domain.com/exchange and it accepts my credentials, but the graphics don't load up.   I get what others have described as the boxes with the x's down the left and no emails loading up.  I searched around but couldn't find anyone who had it working inside, but not outside.  

Any ideas?  Thanks,
0
Comment
Question by:NDRIAdmin
  • 7
  • 6
14 Comments
 
LVL 104

Accepted Solution

by:
Sembee earned 350 total points
ID: 17133046
It usually works everywhere or not at all.

The boxes down the side is usually an indication that the content isn't loading correctly from the /exchweb virtual folder. As it works internally the first place I would look is the firewall.

Simon.
0
 
LVL 2

Expert Comment

by:jlprasadreddy
ID: 17133285
may be the pictures are not getting loaded, try right clicking on the "x" and select show picture

JLP
0
 

Author Comment

by:NDRIAdmin
ID: 17133542
Ports 80, 110, 443 are opened on the firewall to the exchange server.  

What else could the firewall be doing to keep my images from loading?  
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17134291
Blocking it, scanning it. Any number of things.
You have to look at what is different between an internal and external connection. The traffic flow, things like that.

Have you made any attempts to "secure" the server? Anything that might be restricting access to local IP addresses?

Simon.
0
 

Author Comment

by:NDRIAdmin
ID: 17146789
I havent found anything on the firewall that looks like its blocking anything.  I found another  question on this site that referenced article

http://support.microsoft.com/?kbid=280823

It suggested granting authenticated users permissions to the exchweb folder.  Which I have done.  Unfortunately I have no way of testing this while here in the office.  It works here, but not outside.  I'll have to wait until I get home.  Will keep you posted.

0
 

Author Comment

by:NDRIAdmin
ID: 17146817
FOrgot to mention.  The article also suggested checking the folders in the virtual directory for Exchweb.  

Verify that the following virtual directories are located in Exchweb: • Bin
• Cabs
• Controls
• Help
• Img
• Views

I have those, but the cabs folder isnt in the exchweb folder.  In exchweb, I also have a folder called 6.5.6944.0, which has a cabs and controls folder in it.  Is this okay?   Thanks again
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17150355
It works inside - you said so yourself.
Therefore there is nothing wrong with OWA.

Check the authentication settings on the Exchange virtual folders...

/exchange :  basic and integrated only
/exadmin: integrated only
/exchweb: anonymous ONLY
/public: basic and integrated only.

Simon.
0
Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

 

Author Comment

by:NDRIAdmin
ID: 17154217
All of my settings already match what you've laid out.  adding authenticated users to the exchweb folder didn't help.  I don't read firewalls well.   Here is my config.  Not shown, are the ports 80, 443, and 110 to my exchange server.  

NDRI-PIX# sho run
: Saved
:
PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd
hostname XXXX-PIX
domain-name xxxx.com
fixup protocol dns maximum-length 1024
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names        
access-list MS permit ip host 146.146.242.98 169.254.200.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 146.145.242.98 255.255.255.224
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 146.145.242.126
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 146.145.242.100 192.168.1.10 netmask 255.255.255.255 0 0
static (inside,outside) 146.145.242.99 192.168.1.2 netmask 255.255.255.255 0 0
conduit permit tcp host 146.145.242.99 eq smtp any
conduit permit tcp host 146.145.242.99 eq pop3 any
conduit permit tcp host 146.145.242.99 eq ldap any
route outside 0.0.0.0 0.0.0.0 146.145.242.97 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set NORMAL esp-des esp-md5-hmac
crypto dynamic-map 20 11 set transform-set NORMAL
crypto map MANAGED 10 ipsec-isakmp
crypto map MANAGED 10 match address MS
crypto map MANAGED 10 set peer 146.145.8.66
crypto map MANAGED 10 set transform-set NORMAL
crypto map MANAGED 20 ipsec-isakmp dynamic 20
crypto map MANAGED interface outside
isakmp enable outside
isakmp key ******** address 146.145.8.66 netmask 255.255.255.255
isakmp identity address
isakmp keepalive 10 5
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 169.254.200.0 255.255.255.0 outside
telnet 146.145.8.0 255.255.255.0 outside
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 30
ssh 146.145.36.0 255.255.255.0 outside
ssh 146.145.64.0 255.255.255.0 outside
ssh 146.145.65.0 255.255.255.0 outside
ssh timeout 30
management-access inside
console timeout 5
terminal width 80
Cryptochecksum:3d8dcbdeb3ec69992811e73303db7fc2
: end

Gee I hope it's not dangerous to post this.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17157459
The PIX doesn't cause these problems.
However you have used Conduits, which are depreciated. The modern format is Access Lists. Did you set that by hand or use PDM?

Simon.
0
 

Author Comment

by:NDRIAdmin
ID: 17167241
Our Provider manages the Firewall.  I make requests for changes.  I'm still boozled on whats wrong.  
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17167324
It could be something further upstream.
Have you asked the ISP if they are likely to be filtering anything?

As an internal test, create a new local account on a machine that doesn't match any username or password you have in your domain. Then login to that account and see if OWA loads correctly inside on that non-domain account.

Simon.
0
 

Author Comment

by:NDRIAdmin
ID: 17176571
OWA did load correctly internally logged into a pc using a local account, then using a domain account for the OWA log in.  I'll check with the ISP but I doubt they're filtering anything.   I'll get back as soon as I have more answers.  Thanks,

Neil
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17178104
The fact that a local account works rules out authentication as being the problem. I had a though that it could be something in that area.

Simon.
0
 

Author Comment

by:NDRIAdmin
ID: 17200854
Its working now.  It seems that removing the smtp fixup protocol from the PIX did the trick.  Eithe that or it was a huge coincidence.  Though I changed nothing else.  Thanks

0

Featured Post

Are end users causing IT problems again?

You’ve taken the time to design and update all your end user’s email signatures, only to find out they’re messing up the HTML, changing the font and ruining the imagery. What can you do to prevent this? Find out how you can save your signatures from end users today.

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now