Solved

rpc server is unavailable - trust

Posted on 2006-07-18
22
625 Views
Last Modified: 2008-01-09
i get this error when trying to remote to a member server "rpc server is unavailable", after entering my credentials.  i found a couple questions on here that say it might be related to a trust with the DC's.  apparently it is because when i run a netdiag, i cant get a list of DC's.

DC list test . . . . . . . . . . . : Failed
    'MyDomain': No DCs are up.

Trust relationship test. . . . . . : Failed
    'MyDomain': No DCs are up (Cannot run test).
    Secure channel for domain 'MyDomain' is to '\\DC2.MyDomain.com'.


ive tried using the netdiag /fix switch, but that doesnt change anything.  no other servers are having this problem and the DNS appears to be in perfect shape.  i thought it would work to unjoin and rejoin the server from the domain, but my boss doesnt want to do that unless it is our only option.  what else can we try?
0
Comment
Question by:WMIF
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 9
22 Comments
 
LVL 51

Expert Comment

by:Netman66
ID: 17134682
Are you remoting through ISA server?
0
 
LVL 22

Author Comment

by:WMIF
ID: 17134690
nope, this is straight from my workstation pc using microsofts remote desktop client.  the member server is in admin mode.  
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17134878
RPC issues are tough to troubleshoot.  

I would start with DNS.  Make sure all the SRV records are registered and you have no resolution issues.  
No ISP DNS addresses anywhere inside the LAN except on the Forwarder tab of the DNS server.

I had the same issues when attempting to connect to my server from one workstation here.  I played with numerous things - then one day it decided to work.

I did make an adjustment to my ISA server and even though the client and server were inside the ISA it seemed to make a difference.

If you use a Firewall you may want to look at the RPC filter and disable strict compliance.  

0
What Is Transaction Monitoring and who needs it?

Synthetic Transaction Monitoring that you need for the day to day, which ensures your business website keeps running optimally, and that there is no downtime to impact your customer experience.

 
LVL 22

Author Comment

by:WMIF
ID: 17134944
ive gone through the dns and it appears to be in good shape.  i ran netdiag and dcdiag on both DCs just to be sure and they came back clean.  
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17134988
There is a utility (I think in the Resource Kit - could be wrong) called RPCPING.  You could see if that helps point to something of value.

Is the RPC service running?
If the server has 2 NICs is the LAN side interface at the top of the binding order?

I'm still thinking.

In the meantime, here are some articles:

http://support.microsoft.com/kb/224370/en-us

http://support.microsoft.com/kb/837513/en-us
0
 
LVL 22

Author Comment

by:WMIF
ID: 17135013
RPC service is running and i thought about restarting it, but its greyed out and wont let me (on any of the other servers as well).  server has only one nic.  earlier today i installed new drivers, management configuration utility, and firmware from hp with a reboot after.

ive been to the first article and nothing came of it.  the second one is for the DC not functioning properly, but ive got 15 other servers that work properly as well as 300 workstations.  since dcdiag came clean as well, im leading away from the DCs.

im heading home for the night though, so dont think too hard. :)
0
 
LVL 22

Author Comment

by:WMIF
ID: 17135064
btw, i couldnt find rpcping in the support tools group, and a quick google only turned up articles on how to use it.  ill give it a shot to help troubleshoot this, but do you know where to pull it from?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17135098
You'll find it in the NT Res Kit (believe it or not!)

Here: http://support.microsoft.com/kb/206848/en-us

Here is (sort of) how to use this:  http://support.microsoft.com/kb/167260/en-us

It's kind of dated, but can yield some useful results.

0
 
LVL 22

Author Comment

by:WMIF
ID: 17135248
i will check it out tomorrow morning when i get into the office.  if you think of anything else in the meantime, be sure to post. :)
0
 
LVL 22

Author Comment

by:WMIF
ID: 17141770
the rpingdos utility couldnt bind, which is pretty much what i was expecting.  i think i need to attack this problem with the netdiag not being able to list the DCs.  any ideas on that?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17141834
Is there something in the middle that is blocking some ports?  or is everything on the same wire inside the firewall?

You could reset the Secure Channel:

http://support.microsoft.com/kb/260575/en-us

This should work the same for 2003.

Let me know.
0
 
LVL 22

Author Comment

by:WMIF
ID: 17141856
no hardware or software firewall between the 2.

am i reseting the machine account on the DC or the member server?
0
 
LVL 22

Author Comment

by:WMIF
ID: 17141945
well, i tried to reset the password from the dc pointing to the member server and from the member server pointing to the dc.  all times i have tried it cannot communicate with the domain.  says it does not exist.
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17142159
Is the Computer account in the Domain Controllers OU?  Can you recheck the NIC setting to make sure there are no ISP entries on it and that it points to a DNS server internally that is up and running?

If you need some eyes on this let me know.  My alias here at gmail.


0
 
LVL 22

Author Comment

by:WMIF
ID: 17142225
digging deeper, i found that the netbios helper service is not started.  from what i can search, its very much required in order for file sharing, web, network browsing, etc.  the problems i have found with having the service disabled, pretty much line up with what im facing.  problem is, the service is set to start automatically, but it wont start on bootup.  it wont startup when i manually try to start it either.  i cant find anything on problems of why it wouldnt start, just problems that happen when its not started.
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17142610
Mine is started, so I assume it should be on yours.

Is NetBIOS enabled on the NIC?  It's on the WINS tab.

There should be Event Logs for this not starting.  Can you find any?

0
 
LVL 22

Author Comment

by:WMIF
ID: 17142659
yup, it just says that the netbios service didnt respond in a timely fashion.  my boss got a call into microsoft a bit ago, and the tech had him remove a couple files and registry entries.  now the server is inaccessable completely.  
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17142815
Nice...

I suggest you find the case # and reopen it.  Tell them it's worse than when you started.

The $250 is per incident, so make sure you tell them it's the same incident.

0
 
LVL 22

Author Comment

by:WMIF
ID: 17147258
sorry, i should have mentioned that he was still on the phone with them.  it is finally resolved and back to normal.  he had him delete a winsock and winsock32 file then reboot.  that rebuilt those files and allowed the netbios helper service to start again.  netdiag shows everything passed now and we can remote desktop in again.

do you have any objections to a PAQ/refund?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 17147276
No.
0
 
LVL 1

Accepted Solution

by:
GhostMod earned 0 total points
ID: 17168652
Closed, 500 points refunded.

GhostMod
Community Support Moderator
0

Featured Post

Transaction Monitoring Vs. Real User Monitoring

Synthetic Transaction Monitoring Vs. Real User Monitoring: When To Use Each Approach? In this article, we will discuss two major monitoring approaches: Synthetic Transaction and Real User Monitoring.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, I had the need to build a standalone system to run a point-of-sale system. I’m running this on a low-voltage Atom processor, so I wanted a light-weight operating system, but still needed Windows. I chose to use Microsoft Windows Server 200…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question