Solved

Trouble moving mailboxes with blackberry accounts

Posted on 2006-07-18
9
519 Views
Last Modified: 2008-02-01
I'm having the same problem referenced in this thread:

http://www.experts-exchange.com/Programming/Wireless_Programming/Blackberry/Q_21692438.html?query=migrated+my+exchange+server+to+2003+and+my+blackberry+server&clearTAFilter=true

We don't have the budget for another service, so I was wondering if I could re-register the cdo.dll.  Currently the BES server has version 5.5 and tgh eexchange 2003 server has 6.+.  Additionally, how do I chack mapi versions?

Any experiences/advice would be appreciated.
0
Comment
Question by:PatGroupIT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 26

Accepted Solution

by:
Gary Cutri earned 500 total points
ID: 17135176
All you should need to do is update Exchange System Manager on the BES server to the same version as the mail server.  You can install the System Manager from the install CD that you used to install Exchange, just make sure if you updated Exchange to SP2 that you also run SP2 on the BES server to update the system manager.  

You can find out the mapi version by right mouse clicking on mapi32.dll and selecting properties, on this windows click the Version tab and it is listed at the top.

To manually register the CDO.dll
C:\Program Files\Exchsrvr\BIN\ or the directory in which the Microsoft Exchange administration tool is installed, type regsvr32 cdo.dll

Also how many users do you have on you BES?  If it is below 15 you should download a copy of BES express 4.1 with the 1 free CAL and import your existing CALS (If they are below 15).


0
 

Author Comment

by:PatGroupIT
ID: 17171581
I'm going to try the system manager install tonight.  I'm going to get a ghost image before the install in case everything blows up, but hopefully not.

0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 17173887
Post back if you need further help, I will check later on tonight (AUS time)
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 26

Expert Comment

by:Gary Cutri
ID: 17271208
How did you go?
0
 

Author Comment

by:PatGroupIT
ID: 17283814
We've been having a nightmare of a time using acronis true image and paragon drive backup to get a full backup/snapshot of the server.  I've actually created a standby BES server with exchange server manager for 2003 installed...we'll have this ready to go in case of catastrophic failure on the upgrade.  I should have a better idea tomorrow night.
0
 

Author Comment

by:PatGroupIT
ID: 17323303
OK, so I finally have System Manager for 2k3 installed on my production BES and the cdo & mapi DLLs match the versions on the new exchange server.  When I move a users mailbox over to the new server it still won't send email and gives a "Cannot access mailbox" error when I check the users properties in BES Manager.  This is after handheldcleanup.  I've given the BESAdmin account log on as a service rights to both exchange servers, checked the start-up accounts for the services, and still no go.

You did answer my question, so you deserve the points, but any further help woud be appreciated.  Thanks again.
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 17324208
Have you set the delegate control (Exchange Admin View Only) in system manager for the BESadmin account?  Also have you allowed BESadmin to administer the mailbox store, Send As & Receive As?
0
 
LVL 26

Expert Comment

by:Gary Cutri
ID: 17324742
Make sure you have the correct Exchange System Manager installed on the BES server.  If you still have an old version install the system managment tools from the Exchange 2003 disk, also make sure you run the same Exchange service packs on the BES server as you did on the main exchange server.
0
 

Author Comment

by:PatGroupIT
ID: 17330363
I tried all of your suggestions and none of them worked.  Since the problem is now out of the scope of the original question, I made a new post.  Thanks for your answer on this, and by all means, take a stab at the new question:

http://www.experts-exchange.com/Programming/Wireless_Programming/Blackberry/Q_21957223.html
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
BlackBerry Gal Lookup issue 7 196
Blackberry Calendar items dissapearing 3 476
BES10 - Crap 13 1,235
Blackberry Z10 & Outlook sync 2 308
This article will help those of you having problems with the Nextel Blackberry 8350i.  Recent Software updates cause the problems issues described below, and this article will help you revert back to the older software. As we know, Nextel has alw…
Last night I received a weird phone call, from a number I didn’t recognized.  I answered it and no one responded back so I hung up.   Didn’t look at my phone until my husband said “Your phone is doing something weird”.   I had what I’ll consider the…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question