Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 276
  • Last Modified:

web server to access MS Access database on a storage server !?!

I have a website (ASP) using data stored on another server (file-server) and both servers connected to a domain controller.

when i try to open the website I get the message

-----------------------------------------------------------
Microsoft JET Database Engine error '80004005'

The Microsoft Jet database engine cannot open the file '\\10.0.0.23\Databases$\school.mdb'. It is already opened exclusively by another user, or you need permission to view its data.

/include/dbsrecords.inc, line 3
-----------------------------------------------------------

I'm sure it's not under use by any one, so it's a permission case.

what do you think the solution is ?

Thank you for your help
0
Data-Base
Asked:
Data-Base
1 Solution
 
infolurkCommented:
I think the problem could be caused by any one of a number of issues. If you paste your error message into google and peruse the first ten pages that show up you will get a number of possible reasons and solutions, including a couple of microsoft knowledgebase articles. One link that showed up in my search was http://www.aspfaqs.com/aspfaqs/ShowFAQ.asp?FAQID=115 . It looked interesting.

My bet is you have the database set to exclusive, but that is a pure stab in the dark given the information you have provided.

cheers
Steve
0
 
Data-BaseAuthor Commented:
what kind of information you need!

I have a AD + Storage + Web servers

the access DB is on the Storage Server and the website is on the Web Server.

when I point the website to ms access db file (on the storage server).

I get this message.

is there any thing you like me to provide ?

if I know what is the problem then i would not ask here ;-)

I think it's a sharing permission. but I do not know how exactly i should start check and fix

Thank you
0
 
infolurkCommented:
From http://support.microsoft.com/default.aspx?scid=kb;EN-US;q306269

CAUSE
There are several causes for this error message: • The account that Microsoft Internet Information Server (IIS) is using (which is usually IUSR) does not have the correct Windows NT permissions for a file-based database or for the folder that contains the file.
• The file and the data source name are marked as Exclusive.
• Another process or user has the Access database open.
• The error may be caused by a delegation issue. Check the authentication method (Basic versus NTLM), if any. If the connection string uses the Universal Naming Convention (UNC), try to use Basic authentication or an absolute path such as C:\Mydata\Data.mdb. This problem can occur even if the UNC points to a resource that is local to the IIS computer.
• This error may also occur when you access a local Microsoft Access database that is linked to a table where the table is in an Access database on a network server.

RESOLUTION
The following items correspond to the previous list of causes: • Check the permissions on the file and the folder. Make sure that you have the ability to create and/or destroy any temporary files. Temporary files are usually created in the same folder as the database, but the file may also be created in other folders such as the WINNT folder. For additional information about how to identify which folder does not have the correct permissions and how to configure temporary files, click the following article number to view the article in the Microsoft Knowledge Base:
253604 (http://support.microsoft.com/kb/253604/) Microsoft Access 97 database connectivity fails in Active Server Pages
If you use a network path to the database (UNC or mapped drive), check the permissions on the share, the file, and the folder.
• Verify that the file and the data source name (DSN) are not marked as Exclusive.
• The "other user" may be Microsoft Visual InterDev. Close any Visual InterDev projects that contain a data connection to the database.
• Simplify. Use a System DSN that uses a local drive letter. If necessary, move the database to the local drive to test.
• Follow the instructions in the following article to work around this problem:
189408 (http://support.microsoft.com/kb/189408/) FIX: ASP fails to access network files under IIS 4.0 and IIS 5.0  

So, if you think its a permissions error, from the above information you should check that you can access the database from the logon and machine that you are trying to view the web page from.

cheers
Steve
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Data-BaseAuthor Commented:
"There are several causes for this error message: • The account that Microsoft Internet Information Server (IIS) is using (which is usually IUSR) does not have the correct Windows NT permissions for a file-based database or for the folder that contains the file."

------------------------------------------------------------------------------------

the IUSR is a local user account in the web server ?

do you think I just need to create IUSR Account in the AD server and then give him the full permission in the database file/folder (Storage Server) and make the Web Server use it instead of the local account ?
0
 
infolurkCommented:
Possibly, its worth a try anyway. Also check out the information at http://www.aspfaqs.com/aspfaqs/ShowFAQ.asp?FAQID=115.

Cheers
Steve
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
You must provide read/write/create/delete permissions on the folder (on the webserver) housing your Access database to the IUSR Account on the web server. I'm not sure about AD ...
0
 
BrianClark72403Commented:
Is the website using anonymous authentication or windows authentication?  If using windows authentication, then click on the properties of the webserver computer name in active directory and enable 'trust this computer for delegation.'  That way, when you client PC connects to say:

http://webserver/school/

If the /school directory is set to use NT authentication, the webserver authenticates the client accessing the page and connects up to the storage server AS THE USER CONNECTING TO THE PAGE, instead of connecting to the storage server AS THE IUSR_XXXX account on the webserver.
0
 
Data-BaseAuthor Commented:
thank you all for your help.

I solved the problem by copying the access files to the webserver and map the folder for the administration personals.

there is some settings problem with the webserver that need to be reinstalled.

"I got help" from a professional company and they said that I need to reinstall the webserver.

I knew that from before, but I hoped that i will not need to do it!

any way, now everything is working as it should be.

next summer I'll reinstall the webserver and try to make things work better.

now I'll go to my summer holiday :-)

Thank you all again
0
 
infolurkCommented:
Cheers
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now