Cannot Access CUPS Server- Brother MFC210C on Simply Mepis 3.3.1

Until recently, I have successfully used the .deb (lpr and "cupswrapper") drivers supplied by Brother on said MFC.

 The printing has stopped working, and I get the following error message when I  re-install the drivers:
"lpadmin: Unable to connect to server: Connection refused"

 Similarly when I try to "add" the printer again via the KDE Control Centre, I get the following:

 "An error occurred while retriving the printer list:
Connection to CUPS server failed. Check that the CUPS server is properly installed and running.
Error: connection refused."

 My current cupsd.conf file (comments stripped, some format lost in posting):

Classification none
DefaultCharset UTF-8
DefaultLanguage en
Printcap /var/run/cups/printcap
PrintcapFormat BSD
RemoteRoot remroot
SystemGroup sys
ServerCertificate /etc/cups/ssl/server.crt
ServerKey /etc/cups/ssl/server.key
<Location />
Encryption IfRequested
Satisfy All
Order deny,allow
Deny From All
Allow From 127.0.0.1
Allow From @LOCAL
</Location>
<Location /jobs>
AuthType Basic
AuthClass User
Encryption IfRequested
Satisfy All
Order allow,deny
</Location>
<Location /admin>
AuthType Basic
AuthClass System
Encryption IfRequested
Satisfy All
Order deny,allow
Deny From All
Allow From 127.0.0.1
</Location>
HostnameLookups Off
KeepAlive On
KeepAliveTimeout 60
MaxClients 100
MaxRequestSize 0m
Timeout 300
Listen *:631
AccessLog /var/log/cups/access_log
ErrorLog /var/log/cups/error_log
PageLog /var/log/cups/page_log
MaxLogSize 1m
LogLevel info
PreserveJobHistory On
PreserveJobFiles Off
AutoPurgeJobs No
MaxJobs 0
MaxJobsPerPrinter 0
MaxJobsPerUser 0
User lp
Group sys
RIPCache 8m
FilterLimit 0
DataDir /usr/share/cups
DocumentRoot /usr/share/cups/doc
RequestRoot /var/spool/cups
ServerBin /usr/lib/cups
ServerRoot /etc/cups
TempDir /var/spool/cups/tmp
Browsing On
BrowseProtocols CUPS
BrowseInterval 30
BrowseTimeout 300
BrowseOrder allow,deny
ImplicitClasses On
ImplicitAnyClasses Off
HideImplicitMembers Yes
BrowseShortNames Yes
LogLevel debug

 The problem seems to have occurred after I made some changes to my smb.conf file, so that could be related (can post this file too obviously). However, I have changed  back to the original smb.conf version, and the errors are still being reported ...

 I have also run /etc/init.d/cupsys restart with no apparent trouble, but no change to the above error reports either.


 Any suggestions/comments?

 






1111_____1111Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nociSoftware EngineerCommented:
What is in your logfiles...

AccessLog /var/log/cups/access_log
ErrorLog /var/log/cups/error_log
PageLog /var/log/cups/page_log
0
1111_____1111Author Commented:
   noci:

 There doesn't ssee to be page_log file.

 My distro seems to have saved both the access_log and error_log files in about 8 differently dated  "versions" in .gz form, the most recent ones being below respectively (unzipped obviously):

localhost - - [06/Jul/2006:18:43:59 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:18:43:59 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:03:43 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:03:43 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:05:06 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:05:06 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:07:41 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:07:41 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:07:59 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:07:59 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:08 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:08 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:21 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:22 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:36 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:36 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:45 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:45 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:45 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:08:45 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:01 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:01 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:26 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:26 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:43 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:43 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:46 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:46 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:49 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:49 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:55 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:09:55 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:10:06 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:10:06 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:10:09 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:10:09 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:13:12 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:13:12 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:01 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:01 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:09 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:09 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:13 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:13 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:18 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:18 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:18 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:18 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:27 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:27 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:43 +1200] "POST / HTTP/1.1" 200 129
localhost - - [06/Jul/2006:19:14:43 +1200] "POST / HTTP/1.1" 200 129



I [06/Jul/2006:06:43:29 +1200] Loaded configuration file "/etc/cups/cupsd.conf"
I [06/Jul/2006:06:43:29 +1200] Configured for up to 100 clients.
I [06/Jul/2006:06:43:29 +1200] Allowing up to 100 client connections per host.
I [06/Jul/2006:06:43:29 +1200] Full reload is required.
I [06/Jul/2006:06:43:30 +1200] LoadPPDs: Read "/etc/cups/ppds.dat", 251 PPDs...
I [06/Jul/2006:06:43:30 +1200] LoadPPDs: No new or changed PPDs...
I [06/Jul/2006:06:43:30 +1200] Full reload complete.
I [06/Jul/2006:19:17:44 +1200] Scheduler shutting down normally.


 These were both dated 8 July my time, and it was not longer after this that the printer stopped working ...




0
nociSoftware EngineerCommented:
OK access log is normal, with the regular status check.
Pagelog is only on request when accounting information should be kept.
Error log just says that the system stopped at 19:17

In the cupsd.conf can you change the entry to LogLevel debug
and the try a "/etc/init.d/cupsd start"

btw what are you actual using cups or lpr..?

can you show 'netstart -antp | grep 515'
and 'netstat -antp | grep 631' ?

what scripts are run through startup:
- /etc/init.d/lpr
- /etc/init.d/cupsd?

Has the system been rebooted between the installation of the Brother driver and the
shutdown at July 6th ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

1111_____1111Author Commented:

  Firstly, about lpr vs cups:
From the Brother website solutions.brother.com/linux/sol/printer/linux/cups_drivers.html :
 " Brother have prepared a CUPS driver (For BR-Script Models Users) and a CUPS wrapper driver (For Non-BR-Script Models Users) package. The CUPS driver automatically copies the relevant driver files to your Linux distribution, and the CUPS wrapper driver makes LPR drivers work with CUPS."
  So it looks as though I am actually using lpr AND cups. There were two .deb files installed, as I mentioned above.
 
 There were two LogLevel entries in my cupsd.conf. One was debug, and the other was info, so I commented the "info" one out.

 Started cups  OK (apparently). I get "Starting Common Unix Printing System: cupsd."*
 
"netstat -antp | grep 515" result:

tcp        0      0 0.0.0.0:515             0.0.0.0:*               LISTEN     4006/inetd

"netstat -antp | grep 631" result : no screen output


 *The script I am using is /etc/initd/cupsys. I don't see any lpr (or similar) scripts in the /etc/init.d directory.
 
 
 The system was rebooted numerous times between the installation of the Brother driver and the
shutdown at July 6th. The last driver installation as I recall was several months before July 6.
0
nociSoftware EngineerCommented:
lpd protocol is served by the inetd. And cups doesn't seem to be running.

Ok, now debug is enabled.., is there new output in the cups logfiles, or maybe
cups messages in one of the syslog files (daemon or so)
0
nociSoftware EngineerCommented:
And yes as far is the cupsys script is concerned the daemon started, but if it died seconds later, the cupsys script won't know that.
That why there must be a reason being logged somewhere....
0
1111_____1111Author Commented:

 There areno new entries to the access_log and error_log entries or new .gz files created). There are now cups_log and cups-pdf_log files in the /var/log/cups directory, but they are both empty.
 
 This was in /var/log/daemon.log (after a reboot I think).


ul 21 09:12:55 mepis1 smbd[4023]: [2006/07/21 09:12:55, 0] printing/print_cups.c:cups_cache_reload(85)
Jul 21 09:12:55 mepis1 smbd[4023]:   Unable to connect to CUPS server localhost - Connection refused
Jul 21 09:12:55 mepis1 smbd[4023]: [2006/07/21 09:12:55, 0] printing/print_cups.c:cups_cache_reload(85)
Jul 21 09:12:55 mepis1 smbd[4023]:   Unable to connect to CUPS server localhost - Connection refused
Jul 21 09:18:40 mepis1 nmbd[4022]: [2006/07/21 09:18:40, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
Jul 21 09:18:40 mepis1 nmbd[4022]:   *****
Jul 21 09:18:40 mepis1 nmbd[4022]:    
Jul 21 09:18:40 mepis1 nmbd[4022]:   Samba name server MEPIS1 is now a local master browser for workgroup WORKGROUP on subnet 192.168.1.2
Jul 21 09:18:40 mepis1 nmbd[4022]:    
Jul 21 09:18:40 mepis1 nmbd[4022]:   *****



 Also saw the first 4 of the above lines in /var/log/syslog (see below)
 
[...edited...]
 
Jul 21 09:12:51 mepis1 kernel:   Vendor: Brother   Model: MFC-210C          Rev: 1.00
Jul 21 09:12:51 mepis1 kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
Jul 21 09:12:51 mepis1 kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0161
Jul 21 09:12:51 mepis1 kernel: usbcore: registered new driver usblp
Jul 21 09:12:51 mepis1 kernel: drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver

[... going further down ...]

 
Jul 21 09:12:55 mepis1 smbd[4023]: [2006/07/21 09:12:55, 0] printing/print_cups.c:cups_cache_reload(85)
Jul 21 09:12:55 mepis1 smbd[4023]:   Unable to connect to CUPS server localhost - Connection refused
Jul 21 09:12:55 mepis1 smbd[4023]: [2006/07/21 09:12:55, 0] printing/print_cups.c:cups_cache_reload(85)
Jul 21 09:12:55 mepis1 smbd[4023]:   Unable to connect to CUPS server localhost - Connection refused

0
1111_____1111Author Commented:
To rephrase: There are no new entries to the access_log and error_log FILES (or new .gz files created)...
0
nociSoftware EngineerCommented:
And everythings tells us that cups is starting and dies immediately afterwards...

the samba problem is simple cannort connect to port 631, netstat -antp shows there is no one servicesing that port.
I need to look some things up.
0
nociSoftware EngineerCommented:
can you start the cupsdaemon (from the commandline) with the following options and tell what you see?

/usr/sbin/cupsd -f -c /etc/cupsd/cups.conf

(assuming cups is installed in /usr/sbin and the cups config directry is /etc/cupsd)
Maybe this will tell us more.

The -f will prevent cups from daemonizing, so ane messages to stdout/stderr
will show up on the terminal.

you should be able to kill it again with CTRL/C
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
1111_____1111Author Commented:
Yep!
 Result:

 /usr/sbin/cupsd: symbol lookup error: /usr/sbin/cupsd: undefined symbol: cups_strlcpy

 BTW: I should mention that  I recently installed swat, and had to update some libraries for dependency reasons- this MIGHT be affecting cups also.

0
1111_____1111Author Commented:
Solved!

 Found I had to update the cups (ie "cupsys" ) driver to version 1.2. Was able do this without too many more dependency updates.

 Thanks noci for your efforts- some of those commands could come in handy.  Am adding points because this got quite a lot harder than it should have ...

 
0
nociSoftware EngineerCommented:
Also dont forget to disable the the LogLevel debug to something less,
'info' or even 'error' should normally be sufficient.

Unless you do something with those logfiles I'd say set it to error.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.