Solved

Why does Computer Management/Storage/Disk Management report "You do not have access rights to Logical Disk

Posted on 2006-07-19
8
485 Views
Last Modified: 2013-12-03
No one has any more rights on this system than than I do (unless
someone is hiding in the closet).

I've got two 250 GB backup disks, one IDE backing up my RAID system, and one externam on firewire but they seem to be competing for the same driver. With both disconnected, I can't look at my primary disks in XP's Storage window anymore, because it reports that I do not have access rights. ???

[I've been in deep yogurt with an unstable system for several weeks
now, due to bugs MySoSoft says are Symanyech's, and Symanyech says are
MySoSoft's. Have lost everything and rebuilt system several times, but
things are still weird.]

[I've paid for MS "Professionsl Help" and they've charged my credit card, but no one has responded in five days. Wonderful people.]


0
Comment
Question by:mcsuman
  • 4
  • 4
8 Comments
 
LVL 44

Accepted Solution

by:
scrathcyboy earned 500 total points
Comment Utility
First things first -- refuse to pay the charge with your Visa company.  MS doesnt need your money.

Second, give yourself access rights to everything.  DO this -- windows explorer, tools, folder options, view tab, last checkbox, UNCHECK "use simple file sharing".  Shut down windows explorer, reopen it, and now go to the drive you want to access -- right click on the drive letter, choose "take ownership".

Now do this for every drive on the system.  You should now have access rights to them all, now go into computer management, disk management, and do you see all drives, and can you access all of them?  If so, what more do you need to do?
0
 

Author Comment

by:mcsuman
Comment Utility
I've posted two comments so far, but neither seems to have been attached. I must be doing something wrong. Will try again.
0
 

Author Comment

by:mcsuman
Comment Utility
Well, I must have done something right finally, 'cause my last comment was accepted.

Okay, thanks for the kind reply.

I've done what you suggested but ... Disk Management opens with a blank window and reports "Unable to connect to Logical Disk Manager service.

Advanced Security settings reports that I have full control. Device Manager shows the disk and reports that it is working properly. Disk Manager service is running.

What now?
0
 
LVL 44

Expert Comment

by:scrathcyboy
Comment Utility
If you have lost rights to the system, even though you have them, and disk managment is non functional, then it is almost certain you have lost some key system DLLs or essential registry entries.  This means rebuilding windows basic files and some registry settings.  You can run " sfc /scannow ", but I have never had any success with that command actually fixing anything.  I find the best, quickest and simplest way to replace/update/fix the OS files is to do a repair install.  You dont lose any data or program settings, it rebuilds the system files.

Insert the windows XP CD and boot from that, go through the choices are if you are going to do a new install, but do not.  At the screen where it finds the existing windows installation, press "R" at this point (do NOT press enter) -- and the routine will build the system files back to origiinal.  After that, you reapply service pack 2 (or whatever one you have) -- and in about 30 mins, you are done, and it should fix it.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:mcsuman
Comment Utility
I managed this last week -- the suggestion appears elsewhere on the exchange in related topics -- but it doesn't seem to work work anymore. Now the install reports that it can't find a previous system (we have only an XP upgrade from a previous NT) and after inserting the NT disk to continue the "R" choice doesn't come up, and we seem to be stuck with a fresh install.

[After doing that last week it took me 16 hours to reinstall all the software that got unhooked, and then our major development project, into which we've got 7 man-years, wouldn't run on this machine anymore, because the new registry was still munged up (there IS some problem with Norton Internet Security and XP, believe me). I'm fighting hard to keep from taking this computer outside and dropping it into the river. My partner just said, "Wasn't it nice in the Good Old Days when we had a 360 running CMS and a DEC running UNIX? I said, "Yeah, but it was also nice when we had hot-rods and knew how to change the spark plugs; I look under the hood of my car now, and I can't even find them!" <g>]
0
 
LVL 44

Expert Comment

by:scrathcyboy
Comment Utility
I can help you rebuild an application back to fully functioning on a TOTALLY clean install.  All you have to do is --

1.  Export the ENTIRE registry out to a text file on the system where the application was working, and save that in a totally new folder, called "ORIGINAL".

2.  Under original, make a directory called OLDXP.  Copy everything in the windows directory and under it to this OLDXP directory.  Make another called OLDPF - copy all subdirectories containing apps that you want under this OLDPF directory (including anything in Common Files).

3.  Copy your profile, using xcopy,  with the /r/s/h/c/k/e/ switches, from the documents and settings directory to a directory under original called OLDPROFILE.  Do the same for everything in My documents.

4.  Now you are ready to do a clean install, which will wipe out Windows, Program Files, Doc&Set, and My documents.  Boot from the CD and do a clean install.

5.  When it is done, you copy back everything you want to save from the ORIGINAL directory, but only what you want to keep, recover or reconstruct.  Even the destktop and Programs-start menu items you want to restore.

Please, DO NOT use Norton or Symantec internet security, it is a seriously defective program, will always foul up the system.  Use McAfee antivirus instead.  Keep the Registry clean of that stuff.

When you are there and ready to piece back your application, I will still be here.
0
 

Author Comment

by:mcsuman
Comment Utility
scathcboy!

I want to thank you specially for your posts. Not so much because they solved my whole problem, but because their care and clarity helped me to move on. I think I ought to accept your posts so far as answering my original question.

[What you wrote caused me to do a little study. I have to confess that being long experienced with NT, I never bothered to read any technical information on XP. You led me to get and read some. ]

A world of wonders:

1. After saving the registry, profile, etc., I still had trouble getting a clean install.
Symantec detritus kept hanging around. After screaming at Symantec they gave me some proprietary tools to eliminate all Symantec stuff from my main disk (actually, it didn't get everything, though).

2. Then, for reasons more related to my gut than brain, I removed XP Svc Pack 2. After that, strangely, I had all my access rights back and was able to do a full backup again.

3. I took your comments to heart and downloaded McAfee without a hitch.

[Back in the 80's I ran a company in silicon Valey, and someone loaded a game they had been given and infected one of our machines with a virus. McAfee, who was just down the street, gave us an anti-virus disk. We ran it on everything, and within an hour it had infected all fifty machines in the plant. I've stayed away from McAfee since then, but things do change. <g>]

4. This machine looks like it is stable right now. So I'm going to reinstall Svc Pack 2 and try to reinstall MS Office again. We'll see how that goes...

5. It didn't go. System hung during SVC Pack 2 install. Retry went through, but access rights lost again. McAfee throws same kind of errors Norton used to. Svc Pack can't be uninstalled. McAfee can't be uninstalled. Previous XP reinstalls have left over 100GB of trash in old profiles.

Time to clean the HD and start over.

Thanks again for your help.

Mike Suman


0
 
LVL 44

Expert Comment

by:scrathcyboy
Comment Utility
"After that, strangely, I had all my access rights back and was able to do a full backup again."

Actually, that makes a lot of sense.  I had a system where symantec had totally fouled it up, and once SP2 was installed, all networking was totally unrecoverable.  Not even an SP2 removal would work in this case, I had to hack about 20 registry keys that Symantec had corrupted, and networking was on again.

I would suggest to stay with SP1a, it is all I use, because all systems are behind a router firewall, and I have never had an infection (except from mail).  If you run IE outlook, you will need SP2, but if you run Mozilla/FF, you will not.  Anyway, glad you solved it, and good luck.

PS  McAfee went from bad to VERY good, and now is getting poor again (but nowhere near as bad as symantec-Norton, which I keep away from like the plague).  If you want a free virus scanner that is supposed to be better than all of them look at -- NOD32 -- it is supposed to be the best and free.  Its interface is as illogical as you can get, but it works, and is very robust.   Good luck....
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Most of the time we are in fix when all of sudden our systems behave weirdly.  Such problems cost time and effort... so it's best to take some preventive actions so that we can avoid such issues or overcome such problems more easily. Preventive M…
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now