[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 430
  • Last Modified:

Help - Outbound Emails Stuck In Queue

Hi,

Since yesterday afternoon all outbound emails are stuck!

When looking at the queue it says:

Additonal Queue Information:
The connection was dropped due to an SMTP protocol event sink

I cant see anything unusal in the event logs.

What should I do?

No settings have been changed...

I have tried:

alternative SMTP addresses, the ISP have given me a few.

Emptying the queue

Re-runnning the CEICW

Selected "use a smarthost" and entered the SMTP address in

Emails are coming inbound fine which is good but for the outbound im very stuck
0
JackHodson
Asked:
JackHodson
  • 6
  • 5
1 Solution
 
JackHodsonIT ManagerAuthor Commented:
Hello,

I never did solve my SMTP issues, no idea what is wrong but could not afford to be with out the ability to send email.

A techy I know advised me to change the setting in the SMTP connector to send the email via DNS instead of my ISPs SMTP server.

This seems to be working, some messages seem to queue but then send on the 3rd try - Is this normal behaviour?

I have 2 sets of DNS servers (4 IPs in total) entered in the SMTP Virtual Server | Advanced | Configure I believe this should help.

What are the implications of routing email in this way, is it reliable? Does anyone else setup their exchange in the same way?

Lastly, only error so far is when sending to my home SBS which is set up in the same way as the work one, I get this bounce message:

----------
Your message did not reach some or all of the intended recipients.

Subject:

Sent: 20/07/2006 14:22
The following recipient(s) could not be reached:

name@receivingdomain.co.uk on 20/07/2006 14:32

There was a SMTP communication problem with the recipient's email server. Please contact your system administrator.

sendingdomain.co.uk #5.5.0 smtp; 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
------------------------

Iv been told its a problem with my home SBS - any ideas? I have not restricted anything.

Thanks
Jack
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You should just run the CEICW (Configure Email and Internet Connection Wizard) to set the SMTP Virtual Server settings.  You should select  "Use DNS to route e-mail" on the Exchange screen.  Running the CEICW on both of your SBS machines would refresh the configurations properly.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Ok, Thanks Jeff, will give that a go,

in your experience, is it just as reliable as using an ISPs SMTP?

It has been ok so far, although some emails sit in the queue until it finally sends after a few retrys
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
>>>"is it just as reliable as using an ISPs SMTP?"

The reason emails sit in the queue is because the receiving server can't be found.  As long as you've configured your DNS correctly (having your ISP's DNS IPs as Forwarders) then essentially there shouldn't be any difference in reliability.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Must be that it takes a while to send it cus eventually it gets through

I have 4 DNS IPs entered in the SMTP Virtual Server | Advanced | Configure

I guess this is the right place.

Jack
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
No, you shouldn't have anything configured in that setting.  That's for Reverse DNS lookup on incoming messages, and unless you have a very specific reason to configure that, it should be left alone.

At this point, can you please post a complete IPCONFIG /ALL from the server for me to take a look at?  Once I make sure you have that set right, you will need to delete the SMTP Virtual Server and rerun the CEICW to get it configured properly.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Here the IP config - only using one NIC btw - i know it should be 2 but lets igonore that for the minute.
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : quay
   Primary Dns Suffix  . . . . . . . : INFOMEDOM.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : INFOMEDOM.local

PPP adapter RAS Server (Dial In) Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
   Physical Address. . . . . . . . . : 00-53-45-00-00-00
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 10.37.37.11
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Disabled

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Embedded Broadcom NetXtreme 5721 PCI-E Gi
gabit NIC
   Physical Address. . . . . . . . . : 00-12-79-55-9A-F8
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 10.37.37.1
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . : 10.37.0.254
   DNS Servers . . . . . . . . . . . : 10.37.37.1
   Primary WINS Server . . . . . . . : 10.37.37.1

C:\Documents and Settings\Administrator>
0
 
JackHodsonIT ManagerAuthor Commented:
The server sent over 200 emails on Friday faultlessly it seems so im quite happy with this configuration but if you think we can run a proper setup of DNS email I am very interested.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Y'know, I apologize that I somehow misread your initial question and for some reason thought that it was a different error you were getting.

The error received was from the recipient's server which is not allowing email from your server.  The problem is really on their end and you should contact them to find out why it won't accept mail from you.

Just in case, you should check to make sure that your server hasn't found it's way onto any Blacklists.  Check that at www.robtex.com.

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Oh... wait... I know why I thought I misread this... that's because the error message is in the second part not the initial question.

If your outbound emails are stuck, get rid of your smarthost setting and DO send via DNS.  The only reason you could have trouble is if either your ISP blocks port 25 or if you are on a blacklist as mentioned above.

I would delete your SMTP Virtual Server, and then run the CEICW again to restore it properly.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Hi Jeff, I deleted the SMTP server and re-ran the CEICW

Emails seem good, I can even now send to the domain (my SBS box at home) causing problems before, I no longer get the "553 sorry, that domain isn't in my list of allowed rcpthosts" error message

Thanks once again for your help :)

Now to chase some security problems! Will post a new Q...

Jack
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now