How do I disable "Register this connection's addresses in DNS"

I have about 400 laptops in my organization and I want to have each client disable their DNS setting so they will not populate their addresses on my DNS servers. Rather than visiting each client, is this something that can be pushed down through group policy? If it cant be pushed through group policy, what is the easiest way to do this?
dsheltzelAsked:
Who is Participating?
 
Netman66Commented:
Scavenging is how this is handled.  By default, DHCP leases are 8 days in length.  If you set scavenging on the zone you can adjust the rate to match DHCP.  Shorten the lease, then shorten the Scavenging interval.

The IP shouldn't change at all after the workstation gets its first address unless it is offline for longer than the lease period.

0
 
PberSolutions ArchitectCommented:
Try this:

In the GPO for your computers set the following:

Computer Configuration\Administrative Templates\Network\DNS Client

Disable the following settings:

Dynamic Update
Register DNS records with connection-specific DNS suffix
Register PTR Records.

It might take a reboot for this to propogate to the clients.
0
 
Netman66Commented:
Why would you want to do this?

Just curious.

0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
dsheltzelAuthor Commented:
Well its my understanding, and maybe I am confused, that if you run DHCP, will these address automatically udate thier PTR's in DNS? What if the IP changes every 2 or 3 days? How does it work then?
0
 
PberSolutions ArchitectCommented:
If you have machines moving around lots, the method you are going is good.
You are probably having issues with DNS and clients having multiple A records in DNS.  DNS Aging and Scavenging is good and should be enabled on DNS, but it is not quick enough to keep DNS clean.

Let DHCP do the registrations as configured in the each DHCP Scope's DNS TAB.
When machines release thier IP, DNS is cleaned up right away.  No need to wait for aging/scavenging to do it's job.
0
 
dsheltzelAuthor Commented:
wwhere do I view the scavenging settings to change them?
0
 
PberSolutions ArchitectCommented:
Load the DNS MMC
expand the forward lookup zones
Expand your DNS zone
Right click it and select Properties.
Click the Aging button.

Or Right click the DNS server in the MMC
Select Set Aging/Scavenging for all zones
0
 
dsheltzelAuthor Commented:
I found it. What should my times be for no-refresh and refresh?
0
 
PberSolutions ArchitectCommented:
As Netman66 mentioend, it is based on your DHCP lease times.  You usually pick your longest DHCP lease time and set it based on that.

Here are some guidelines
http://searchwincomputing.techtarget.com/tip/0,289483,sid68_gci1040355,00.html
http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_21349818.html?query=scavenging+refresh&clearTAFilter=true
0
 
Netman66Commented:
No refresh is the time DNS doesn't allow the entry to be refreshed.  You want this less than the refresh time.

You can Scavenge at shorter intervals than DHCP because DHCP will reregister the client automatically.

0
 
dsheltzelAuthor Commented:
I am noticing multiple computer names showing up in my DNS with the same IP address. Does this mean it is not dumping old regiters in an adequate amount of time? How should I address this?
0
 
Netman66Commented:
The Scavenging isn't working right.

Your Scavenging should be before the DHCP lease expires (barely).  Your "No Refresh" on Scavenging should also be before the Scanvenging interval and the lease expires.  If no refresh is longer then Scavenging will be blocked.

You also need to turn Scavenging on for the DNS server - then - for each zone.

0
 
PberSolutions ArchitectCommented:
Further to Netman66's advice...

If your DHCP lease times are all the same, you can set all your Scavenging/Aging for all your zones all in one step.  Just right click your DNS server from the DNS MMC and select "Set Aging/Scavenging for All Zones".  This will save you lots of time.

Also you only need to turn on scavenging on one server as the remaining servers will get the updates.
0
 
dsheltzelAuthor Commented:
I am still seeing a couple duplicates popping up, but far less than there were. Is this due to stale records and not being deleted?
0
 
Netman66Commented:
It could be that, or it could be a workstation that was renamed after it registered and it has not yet gone stale.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.