Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6652
  • Last Modified:

'ping' is not recognized as an internal or external command, operable program or batch file.


I am running Windows XP Pro.  I seem to be having a problem calling windows utilities from a command line, for example ping, tracert, ipconfig, etc....

Ping (or any other system32 exes) are not recognized from any folder other than system32.  My path seemed
fine, but I removed all other references from it besides C:\Windows and C:\Windows\system32 and rebooted,
just to ensure there was nothing else causing the problem.

Ping.exe (and all others) still exist, and are working correctly from within the system32 folder.

Below is an demonstration of what is happening:

C:\>ping 127.0.0.1
'ping' is not recognized as an internal or external command,
operable program or batch file.

C:\>cd WINDOWS\system32

C:\WINDOWS\system32>ping 127.0.0.1

Pinging 127.0.0.1 with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\WINDOWS\system32>path
PATH=C:\WINDOWS; C:\WINDOWS\system32;



I would prefer not to have to reload the machine if at all possible.

Thank you in advance for any help.
0
Crossroads305
Asked:
Crossroads305
  • 2
1 Solution
 
KenneniahCommented:
You have a space in your path.
PATH=C:\WINDOWS; C:\WINDOWS\system32;
Should be...
PATH=C:\WINDOWS;C:\WINDOWS\system32;
0
 
Crossroads305Author Commented:
If only you could see the mark I just made from slapping myself in the forehead.....

Thank you.
0
 
Justin CollinsIT Support TechnicianCommented:
ok, I have seen this before and you may have underlying problems that are causing this.  Go into your System32 folder and click on Tools>Folder Options>and Check Show Hidden Files and Folders, and go a couple more down and uncheck "Hide Protected Operating System Files", Apply,Ok.  Now, scroll down to ping.exe.  If I remember right(and you have the same problem as I), there are 2 different ping files.  One is either hidden or isn't an exe.  Delete it.  Leaving only the ping.exe.
0
 
KenneniahCommented:
"If only you could see the mark I just made from slapping myself in the forehead....."
I tend to get a lot of those marks myself each day :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now