Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17


DNS server can find A records but not MX?

Posted on 2006-07-19
Medium Priority
Last Modified: 2011-09-20
I have 12 DCs all running DNS.  My mail gateway is using one in particular for DNS and lately we've been getting a few of these

The following message to <> was undeliverable.
The reason for the problem:
5.4.7 - Delivery expired (message too old) 'DNS Soft Error looking up (MX) while asking 192.168.75.x. Error was: ServFail'

so i tested looking up that MX record from that DC and it times out.  When I look it up from all the other DCs in the domain it finds it fine.  Also when I look up just the A record for it finds it fine.  The only difference in configuration is that this DC has forwarders on (pointed to our ISPs DNS servers).  I took them off to see if that would make a difference but it still fails.  I've run dcdiag and netdiag and both come back clean.

any ideas what else could be going on?
Question by:shanna1017
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +1
LVL 22

Expert Comment

ID: 17139358
I would check to make sure the DNS forwarders are still correct.  Your DNS server shouldn't know about so it will have to go to the ISP's DNS servers to get an answer.

You mentioned that your other DNS servers don't have forwarders setup, are you hosting the "." zone?  If so I suggest deleting it and handling all of those requests from your ISPs DNS.

Author Comment

ID: 17139380
thanks for the quick reply.

i've used nslookup to lookup that address using those ISP DNS servers and it finds the MX record fine.  The other DNS servers are simply using root hints to find domains other than ours.  Is that what you're asking?
LVL 22

Expert Comment

ID: 17139398
OK, you are just using root hints.  I wanted to make sure you didn't have a forward lookup zone called "."  If you are you should delete it.

I know this seems silly, but have you tried restarting DNS services on the server or restarting the whole server?

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.


Author Comment

ID: 17139405
i've tried restarting the DNS service on that server but not the whole server since it's our main file/print server.  I will try that tonight

Author Comment

ID: 17139722
actually i found a time when nobody had open files and quickly rebooted it.  still can't find the MX record.  

i don't get it?  what could be stopping it?  it's not in our domain so it should just use the forwarders to query the ISPs DNS servers right?  and those have already proven that they know about that record.  


Expert Comment

ID: 17140608
did this only start happening this afternoon?

Author Comment

ID: 17140928
i think i actually fixed it by disabling Extension Mechanisms for DNS.  After I did that and restarted the service I was able to retrieve the MX record from that box.  either that or it was just coincidence.  Anybody have any explanation for why that would fix it?  The only reason I'm suspicious is because we only have 1 internet connection that all traffic from our WAN goes through so if that fixed the issue why would the other servers have been able to do it successfully with that feature turned on?

Accepted Solution

ee_ai_construct earned 0 total points
ID: 17545632
PAQ / Refund
ee ai construct, community support moderator

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question