Solved

Multiple VPN connections

Posted on 2006-07-19
3
191 Views
Last Modified: 2013-11-16
Hi experts,
What should be added to the config below to enable multiple VPN connections using VPN client software



PIX Version 6.1(4)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password aYiGONOGTxE2368q encrypted
passwd t7oLYycQGA49Yo2i encrypted
hostname BGLKEEPER
domain-name mmmm.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list acl_inbound permit icmp any any
access-list acl_inbound permit udp host 1.2.3.6 host 1.2.4.2 eq isakmp
access-list acl_inbound permit ah host 1.2.3.6 host 1.2.4.2
access-list acl_inbound permit esp host 1.2.3.6 host 1.2.4.2
access-list acl_inbound permit tcp any host 1.2.3.7 eq 3389
access-list 101 permit ip 172.16.0.0 255.255.240.0 192.168.1.0 255.255.255.0
access-list 101 permit ip 172.16.0.0 255.255.240.0 172.16.11.0 255.255.255.0
pager lines 24
logging on
logging timestamp
logging trap debugging
logging host inside 172.16.0.1
no logging message 106015
no logging message 305004
no logging message 305001
no logging message 302003
no logging message 302002
no logging message 304001
no logging message 302001
no logging message 302006
no logging message 302005
no logging message 609002
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside 1.2.3.6 255.255.255.240
ip address inside 192.1.1.251 255.255.255.0
ip verify reverse-path interface inside
ip audit info action alarm
ip audit attack action alarm
ip local pool bglpool 192.168.1.1-192.168.1.254
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
pdm location 192.1.1.251 255.255.255.255 inside
pdm location 172.16.0.9 255.255.255.255 inside
pdm location 172.16.0.20 255.255.255.255 inside
pdm location 172.16.0.99 255.255.255.255 inside
pdm location 172.16.10.9 255.255.255.255 inside
pdm location 172.16.1.200 255.255.255.255 inside
pdm logging critical 100
pdm history enable
arp timeout 14400
global (outside) 1 1.2.3.2
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 1.2.3.5 172.16.0.20 netmask 255.255.255.255 0 0
static (inside,outside) 1.2.3.7 172.16.1.200 netmask 255.255.255.255 0 0
static (inside,outside) 1.2.3.8 172.16.0.9 netmask 255.255.255.255 0 0
access-group acl_inbound in interface outside
route outside 0.0.0.0 0.0.0.0 1.2.3.1 1
route inside 10.170.0.0 255.255.255.0 192.1.1.30 1
route inside 172.16.0.0 255.255.240.0 192.1.1.30 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol tacacs+
http server enable
no snmp-server location
snmp-server community xxxxxx
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto ipsec transform-set BASEPIX esp-des esp-sha-hmac
crypto ipsec transform-set bgn_mines esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map outside_map 20 ipsec-isakmp
crypto map bgn_map 1 ipsec-isakmp
crypto map bgn_map 1 match address 101
crypto map bgn_map 1 set peer 1.2.4.2
crypto map bgn_map 1 set transform-set bgn_mines
crypto map bgn_map interface outside
isakmp enable outside
isakmp key ******** address 1.2.4.2 netmask 255.255.255.248
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 86400
isakmp policy 10 authentication rsa-sig
isakmp policy 10 encryption des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication rsa-sig
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
vpngroup BGL_roam idle-time 1800
vpngroup gsrgh-vpn address-pool bglpool
vpngroup gsrgh-vpn dns-server 172.16.0.1
vpngroup gsrgh-vpn wins-server 172.16.0.3
vpngroup gsrgh-vpn default-domain password
vpngroup gsrgh-vpn idle-time 1800
vpngroup gsrgh-vpn password ********
telnet 192.1.1.220 255.255.255.255 inside
telnet timeout 5
ssh 172.16.2.55 255.255.255.255 inside
ssh timeout 5
vpdn username xxx password xxx
vpdn username xxx password xxx
terminal width 80
Cryptochecksum:e41785d365372f5d64523d7dff608d46





















0
Comment
Question by:it_gsr
3 Comments
 
LVL 32

Accepted Solution

by:
rsivanandan earned 250 total points
ID: 17146058
I see a lot of stuff there; Ideally this is what it would look like;

ip local pool swimming 10.1.4.1-10.1.4.254

access-list nonat permit ip <InsideNetwork> <Mask> 10.1.4.0 255.255.255.0
access-list split permit ip <InsideNetwork><Mask> 10.1.4.0 255.255.255.0

nat(inside) 0 access-list nonat

crypto ipsec transform-set MySet esp-aes-256 esp-md5-hmac
crypto dynamic-map MyDyn 30 set transform-set MySet
crypto map MyMap 10 ipsec-isakmp dynamic MyDyn
crypto map MyMap client authentication win2000
crypto map MyMap interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 14400
vpngroup My address-pool swimming
vpngroup My dns-server 10.0.4.20 10.0.4.21
vpngroup My default-domain lhas.org
vpngroup My split-tunnel Split
vpngroup My idle-time 14400
vpngroup My authentication-server win2000
vpngroup My password ********

The above configuration basically allows a Cisco VPN Client to connect to the PIX and authenticate using Windows radius server through ActiveDirectory. This is an IPSEC VPN.

I'm not sure if this is what you want.

Cheers,
Rajesh
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now