Solved

Error No. in Mysql Replication

Posted on 2006-07-20
8
235 Views
Last Modified: 2008-02-01
Error No. 1449

there is not user 'xxxxx@%' not registered on query.default database

The query works okay in the master. but it is being altered and a new column added today, after the CREATE OR REPLACE VIEW STATEMENT  salve stopped showing the command listed above.
0
Comment
Question by:tomjosem
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
8 Comments
 

Author Comment

by:tomjosem
ID: 17145090
Errro No.
0
 
LVL 35

Expert Comment

by:Raynard7
ID: 17145178
This error seems to be occuring because you are defining a user in the view that the slave user can not replicate.

If you do not have the SUPER privilege, the only legal user value is your own account, either specified literally or by using CURRENT_USER. You cannot set the definer to some other account.

Does the slave / replication user have super privledges?
Who are you setting as the definer in the view?

I would specifically define the user for creating the view - and give the slave user the super priveledge
0
 

Author Comment

by:tomjosem
ID: 17145477
I've given grant all to the user and hope it uncludes the SUPER PREVILEGE.

This occurs also when i restore the backup taken from mysql administrator.

The replication slave user granted super priveleges

0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 
LVL 6

Expert Comment

by:chigs20
ID: 17147064
What version of MySQL are you using?
There is a known bug when it comes to restoring views from mysqldump.
0
 

Author Comment

by:tomjosem
ID: 17149001
Mysql 5.0.16
0
 
LVL 6

Accepted Solution

by:
chigs20 earned 500 total points
ID: 17149704
I've had the same issue in my replication environment...
here is the bug:  http://bugs.mysql.com/bug.php?id=18462

it'll be fixed in 5.0.23 (not yet released)


chigs
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When table data gets too large to manage or queries take too long to execute the solution is often to buy bigger hardware or assign more CPUs and memory resources to the machine to solve the problem. However, the best, cheapest and most effective so…
In this blog post, we’ll look at how ClickHouse performs in a general analytical workload using the star schema benchmark test.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question