upgrading plesk from 7.5.4 to plesk 8

on fedora 3 trying to upgrade plesk 7.5.4 to plesk 8

tried doing it thru the plesk updater but get the following error:

ERROR: Impossible do installation while package rpm-python-4.3.2-21.i386 is installed in system

please help!
adamjimenezAsked:
Who is Participating?
 
pjedmondConnect With a Mentor Commented:
You need to put in a request on the Community Support Board to refund points.

(   (()
(`-' _\
 ''  ''

0
 
xDamoxCommented:
Hi,

Try SSH into your machine and type as root:

yum remove rpm-python

or

rpm -e rpm-python

Then try running the plesk updater
0
 
adamjimenezAuthor Commented:
thats gone now and it took yum with it.

now we get:

ERROR: Impossible do installation while package rpm-build-4.3.2-21.i386 is installed in system
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
xDamoxCommented:
Hi,

Type as root:

rpm -ihv http://dl.atrpms.net/all/rpm-python24-4.4.2-11_9.rhfc3.at.i386.rpm

This will reinstall the package you removed that stoped yum working now try:

yum update

and then try the plesk updater
0
 
adamjimenezAuthor Commented:
# rpm -ihv http://dl.atrpms.net/all/rpm-python24-4.4.2-11_9.rhfc3.at.i386.rpm
Retrieving http://dl.atrpms.net/all/rpm-python24-4.4.2-11_9.rhfc3.at.i386.rpm
warning: /var/tmp/rpm-xfer.al377t: V3 DSA signature: NOKEY, key ID 66534c2b
error: Failed dependencies:
        /usr/lib/python2.4/site-packages is needed by rpm-python24-4.4.2-11_9.rhfc3.at.i386
        librpm-4.4.so is needed by rpm-python24-4.4.2-11_9.rhfc3.at.i386
        librpmbuild-4.4.so is needed by rpm-python24-4.4.2-11_9.rhfc3.at.i386
        librpmdb-4.4.so is needed by rpm-python24-4.4.2-11_9.rhfc3.at.i386
        librpmio-4.4.so is needed by rpm-python24-4.4.2-11_9.rhfc3.at.i386
        python(abi) = 2.4 is needed by rpm-python24-4.4.2-11_9.rhfc3.at.i386
        rpm = 4.4.2 is needed by rpm-python24-4.4.2-11_9.rhfc3.at.i386
0
 
xDamoxCommented:
Opps sorry its:

rpm -ihv ftp://fr2.rpmfind.net/linux/fedora/core/3/i386/os/Fedora/RPMS/rpm-python-4.3.2-21.i386.rpm

I noticed that I given you an updated version of rpm-python. The try

yum update
0
 
adamjimenezAuthor Commented:
ok i did that and also reinstalled yum and ran yum update.

now yum fails with errors:

Error: missing dep: librpmdb-4.3.so for pkg psa-autoinstaller
Error: missing dep: librpm-4.3.so for pkg psa-hotfix6
Error: missing dep: librpmdb-4.3.so for pkg psa-hotfix6
Error: missing dep: librpm-4.3.so for pkg psa
Error: missing dep: librpm-4.3.so for pkg psa-autoinstaller
Error: missing dep: librpmio-4.3.so for pkg psa-autoinstaller
Error: missing dep: librpmio-4.3.so for pkg psa
Error: missing dep: librpmdb-4.3.so for pkg psa
Error: missing dep: librpmdb-4.3.so for pkg psa-pre-keyupdate
Error: missing dep: librpmio-4.3.so for pkg psa-hotfix6
Error: missing dep: librpmio-4.3.so for pkg psa-pre-keyupdate
Error: missing dep: php for pkg php-pear
Error: missing dep: librpm-4.3.so for pkg psa-pre-keyupdate
0
 
xDamoxCommented:
Hi,

Hmmm this is weired anyways my last solution is try:

yum update rpm-python

See if that helps.
0
 
adamjimenezAuthor Commented:
ok i just did that and i get these errors:

Error: missing dep: librpmio-4.3.so for pkg psa
Error: missing dep: librpmdb-4.3.so for pkg psa-hotfix6
Error: missing dep: librpmio-4.3.so for pkg psa-hotfix6
Error: missing dep: librpm-4.3.so for pkg psa-pre-keyupdate
Error: missing dep: librpmdb-4.3.so for pkg psa-autoinstaller
Error: missing dep: librpm-4.3.so for pkg psa
Error: missing dep: librpm-4.3.so for pkg psa-hotfix6
Error: missing dep: librpmio-4.3.so for pkg psa-pre-keyupdate
Error: missing dep: librpmdb-4.3.so for pkg psa
Error: missing dep: librpmio-4.3.so for pkg psa-autoinstaller
Error: missing dep: librpmdb-4.3.so for pkg psa-pre-keyupdate
Error: missing dep: librpm-4.3.so for pkg psa-autoinstaller
Error: missing dep: php for pkg php-domxml
Error: missing dep: httpd-suexec for pkg psa
Error: missing dep: php for pkg php-pear
0
 
pjedmondCommented:
I'm assuming that the Plesk update comes as an rpm?

Stick that rpm in a directory, and then run the command:

rpm -Uvh *.rpm

You will get dependency issues. Add the appropriate rpms to the directory, and keep repeating. This will take some time, and may require as many as 20 rpms. (My update took 18!)

Let us know how it goes.

(   (()
(`-' _\
 ''  ''
0
 
adamjimenezAuthor Commented:
needed to change FC4 to FC3 in /etc/redhat-release
0
 
adamjimenezAuthor Commented:
i'm happy to give you the points as you put me on the right track.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.